PDA

View Full Version : Canon Elph 2 Problem


Diggi
6th of June 2002 (Thu), 23:08
I know this is not a digital camera, but it is very similar to the Canon Elph Digital in functionality and photo processing and I need your help!! I hope someone at Canon or a Canon user knows the ins and outs of this marvel camera, The Elph 2.

The problem I am having is that the camera APS film cover does not want to open. The CPU "thinks" that the cover latch is open but it is locked closed with no film inside. In this mode the camera doesn't do anything!! I tried tthe mid roll change button, I tried the rewind button, I tried removing the batteries, I tried resetting the time and date but nothing works??!! The camera is jammed in this mode!

If anyone knows how to reset the CPU (by pressing several buttons at the same time while power on or something) maybe this might do it.

Please your help is very much apppreciated and THANKS A MILLION in advance!

Diggi

Rustle
7th of June 2002 (Fri), 08:03
Wouldn't taking the batteries out for an extended period reset the CPU? Assuming that it is a CPU problem, and not a broken switch or something.

Russ

Diggi
9th of June 2002 (Sun), 22:58
Thanks Russ for your reply.

I did try removing the batteries for days but unfortunately that didn't help either. Somehow the camera "thinks" that the cover is open and doesn't wont to eject the latch to "re-open" the film compartment again.

I am still open for any ideas or comments and thanks to all.

Diggi