Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Sharing Knowhow' section > Presentation
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 9th of February 2011 (Wed)   #1
HWDylan
Junior Member
 
Join Date: Jan 2011
Posts: 6
Default "Photo Section" of my website

I have had this section up and running for a while now and was just curious to see what you guys thought about it.

http://www.herpingwithdylan.com/photos.aspx

Good? Bad? Have suggestions?
I realize not all of the photos are great. Many of these were taken before I had a DSLR and none of them have been taken since I got me external flash. I am also working on a way to integrate habitat photography into the site as well. Just not quite sure how I want to organize it.

All input is welcome.

Thanks
Dylan
HWDylan is offline   Reply With Quote
This ad block will go away when you log in as member
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are you afraid to post in the "photo sharing" section? august23 Small Compact Digitals by Canon 15 4th of February 2011 (Fri) 23:06
Revamping Website, are these photos too erotica for a "Glam" section? *NWS* Hotrodguru Critique Corner 8 19th of July 2010 (Mon) 14:22
Product photo thread continuation from the "Talk" section Gr8outdrsmn Still Life, B/W & Experimental 1 30th of January 2010 (Sat) 10:53
Website names: "photo" vs "photography"? photoguy6405 The Business of Photography 22 8th of January 2010 (Fri) 11:35
How much for a 2"x4" photo in sports section of paper? musicmaster The Business of Photography 3 28th of May 2008 (Wed) 21:10


All times are GMT -5. The time now is 15:17.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.