Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > Exhibit Engine > EE 2 Bugs
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 29th of May 2011 (Sun)   #1
UweB
Member
 
UweB's Avatar
 
Join Date: Aug 2003
Location: Zürich, Switzerland
Posts: 149
Default Broken Gallery after upgrade to 2.04 (solved)

Hello, i upgraded my gallery editor from version 2.02 to 2.04 a couple of days ago... i made a backup of the DB just in case it's needed.

Now my indexpage looks funny and all links are broken. I can see the whole menu structure on the left top and no clicks work...

I tried this with 3 browsers, Firefox 3.6, Seamonkey 1.8 and IE 8 and they all show the same results.

How can i get back a working gallery?

----

Well, i changed the header.php from 2.04 back to the old version... as to why this new file causes me trouble i do not know.
__________________
I own some great analog equiment from Canon like the Cameras F-1N, A-1 and a range of lenses from 14mm to 300mm plus some accessories. Photography for me is fun and pleasure but also a sometimes difficult creative process.
Please view here: http://www.borck.ch/gallery

Last edited by UweB : 2nd of June 2011 (Thu) at 07:52.
UweB is offline   Reply With Quote
This ad block will go away when you log in as member
Old 31st of May 2011 (Tue)   #2
UweB
Member
 
UweB's Avatar
 
Join Date: Aug 2003
Location: Zürich, Switzerland
Posts: 149
Default Re: Broken Gallery after upgrade to 2.04

Yeah well, my question is still how to revert the gallery installation to version 2.02 of which i have a DB backup or to version 2.04 which was confirmed after the upgrade.

There is a layer of links above all pages and clicks through it are not possible...

Any advise for me?

__________________
I own some great analog equiment from Canon like the Cameras F-1N, A-1 and a range of lenses from 14mm to 300mm plus some accessories. Photography for me is fun and pleasure but also a sometimes difficult creative process.
Please view here: http://www.borck.ch/gallery
UweB is offline   Reply With Quote
Old 2nd of June 2011 (Thu)   #3
MMCM
Member
 
Join Date: Nov 2004
Location: Vienna, Austria
Posts: 105
Default Re: Broken Gallery after upgrade to 2.04

You didn't do a file system backup of your web site before the upgrade, which you can restore now?
I somewhere have a self-made diff-file of the changes in 2.04, you could try to reverse apply it to your site to revert the changes?

Edit: maybe you selected "multi area navigation" for "Clicking a big photo gets you" on the photo page settings?

Last edited by MMCM : 2nd of June 2011 (Thu) at 14:45.
MMCM is offline   Reply With Quote
This ad block will go away when you log in as member
Old 4th of June 2011 (Sat)   #4
UweB
Member
 
UweB's Avatar
 
Join Date: Aug 2003
Location: Zürich, Switzerland
Posts: 149
Default Re: Broken Gallery after upgrade to 2.04

Hello MMCM

yes i have multiarea navigation active. No i did not think about a file system backup...

But as i've found out, it was the header file which caused this. A visible layer of the menu structure over all pages. I now reverted back to the header file of the 2.02 version and all seems well... on the outside. I do not now enough about PHP for an explanation... the 2 files look very different.

The only thing is wrong security settings on the filestructure. I do not know what would be the default. Ithink 777 for the temp and upload folder and 755 on the rest.... i'm not sure.
__________________
I own some great analog equiment from Canon like the Cameras F-1N, A-1 and a range of lenses from 14mm to 300mm plus some accessories. Photography for me is fun and pleasure but also a sometimes difficult creative process.
Please view here: http://www.borck.ch/gallery
UweB is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
broken 40D/ loyalty upgrade to 50D? bigarchi Canon EOS Digital Cameras 35 12th of April 2010 (Mon) 15:51
50D or 40D upgrade from broken 30D k4show Canon EOS Digital Cameras 7 7th of June 2009 (Sun) 07:27
How should I replace/upgrade from my broken sigma 28-300mm TimTab Canon EF and EF-S Lenses 21 9th of February 2008 (Sat) 20:15
Say no to upgrade-itis. New G2 gallery akellas Presentation 6 3rd of October 2004 (Sun) 14:29


All times are GMT -5. The time now is 10:41.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.