Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Small Flash and Studio Lighting
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 11th of May 2012 (Fri)   #1
macoylaroza
Member
 
macoylaroza's Avatar
 
Join Date: Oct 2009
Location: Alaska
Posts: 182
Smile Anyone else here using the YONGNUO ST-E2

Any pros and cons? Also, I want to get more ideas using this device in HSS mode.

Your inputs area highly appreciated!
__________________
Canon 5DIII 24-70 f2.8 | 35 f1.4 | 70-200 f2.8| 135 f2| AB1600|RF-602
noy-pi
FlickR
www.fstopavenue.com
macoylaroza is offline   Reply With Quote
This ad block will go away when you log in as member
Old 11th of May 2012 (Fri)   #2
kaftanka
Junior Member
 
Join Date: Apr 2012
Location: Torbay, UK
Posts: 11
Default Re: Anyone else here using the YONGNUO ST-E2

I purchased one just over 3 weeks ago, but it did not fire any AF-assist beam at all - so in very low-light conditions my 5D2 couldn't focus.
I also found it an inconvenient variable to keep worrying about making sure that the infra-red beam system would communicate with the speedlites in my softbox/umbrella etc.
I returned it, and purchased a set of Pixel Kings instead.
kaftanka is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
forget pocketwizards, hello yongnuo...yongnuo peeps, need advice kaitanium Small Flash and Studio Lighting 38 16th of April 2011 (Sat) 17:55
Yongnuo YN460-II vs Yongnuo YN460 & LumoPro LP120 Speedlights Kurbster Small Flash and Studio Lighting 30 30th of January 2010 (Sat) 20:43


All times are GMT -5. The time now is 11:47.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.