Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Other Digital Cameras Medium Format Digital Cameras and Backs
Thread started 02 Feb 2016 (Tuesday) 01:28
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Yashica MAT help needed URGENT***

 
urbanfreestyle
I am a squirrel who loves rubbing bottles and I have Nuts in my drawers, too!
urbanfreestyle's Avatar
Joined Dec 2013
Exeter, Devon
Feb 02, 2016 01:28 |  #1

Hi everyone,
Hopefully someone can help me with this one....
I have recently bought a Yashica Mat and some 120mm film to go with it...
Today i decided to load it up and take some shots in the office with it but after loading the film and winding it on. it would appear that the shutter is stuck shut! :-( so now i have a roll of film in here that isn't exposed but wound onto the take up reel. I'm wondering if it is possible to unwind the film back onto the original reel or something so that i can use it again as it hasn't been exposed.

Also is there a way to check if the shutter is functioning?


Facebook (external link)
Sony @6000 | Sony 18-105 f4 G Series | Sony 16 f2.8 | Helios 44/m | Pentacon 135mm f2.8 | Yongnuo 560EX II | Manfrotto 055CX PRO3 | 3LT Mohawk ballhead | Lubitel 2 med format camera | Zenit EM 35mm camera |

LOG IN TO REPLY
Georgeinnj
Member
87 posts
Joined Jul 2012
USA
Feb 02, 2016 20:04 |  #2

When you cranked the film winder to advance the film did you then crank the film winder backwards to its original position to cock the shutter?




LOG IN TO REPLY
urbanfreestyle
THREAD ­ STARTER
I am a squirrel who loves rubbing bottles and I have Nuts in my drawers, too!
urbanfreestyle's Avatar
Joined Dec 2013
Exeter, Devon
Feb 03, 2016 01:10 as a reply to Georgeinnj's post |  #3

yep, cranked and cocked. also the self timer now appears to be stuck :-(

I know the guy i bought it from and he has sent me a refund so that's good i guess...


Facebook (external link)
Sony @6000 | Sony 18-105 f4 G Series | Sony 16 f2.8 | Helios 44/m | Pentacon 135mm f2.8 | Yongnuo 560EX II | Manfrotto 055CX PRO3 | 3LT Mohawk ballhead | Lubitel 2 med format camera | Zenit EM 35mm camera |

LOG IN TO REPLY

1,598 views & 0 likes for this thread
Yashica MAT help needed URGENT***
FORUMS Other Digital Cameras Medium Format Digital Cameras and Backs


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00195 for 6 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is susanac
914 guests, 479 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016