Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Other Digital Cameras Fuji Digital Cameras
Thread started 15 Dec 2017 (Friday) 22:46
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

New X-T1 with XF18-55 Kit Lens - Aperture Selection Not Working

 
ldn323
Goldmember
ldn323's Avatar
Joined Dec 2006
Dec 15, 2017 22:46 |  #1

Greetings!

My new X-T1 and XF18-55 kit lens arrived this afternoon. Beautiful equipment! I played and played with it until I ran into what seemed like an issue: the aperture could not be changed with the rear command dial in either A mode or M mode.

What I did:
- "M" mode: switch on lens taken off the "A" position, shutter dial set at a position other than "A". Tried turning the rear command dial. No change. Aperture showed F2.8 when lens was set at 18mm zoom position, and F4.0 when lens was set at 55mm zoom level. In other words, max aperture at given zoom setting.
- "A" mode: switch on lens taken off the "A" position, shutter dial set at "A". Tried turning the rear command dial. Same incorrect behavior as above.

In Menus - Shooting Mode, "Aperture Setting" was set at "A+Manual" and the selection is greyed out so I could not try any other choices.

The manual (page 82) said "Aperture can not be adjusted while the view through the camera lens is zoomed in". I made sure this was not the case.

I have also tried cleaning the contact points on the lens and the camera body.

What did I miss? How do I adjust the aperture in A and M modes? Did I have a defective lens/body?

Thanks for any help you can provide.


Linh - My Flickr (external link)
1Dx, 7D Mark II, XTi, Fuji X100s, Sigma 150-600mm f/5-6.3 DG OS HSM Contemporary, Canon 100-400mm f/4.5-5.6 L IS II, Canon 70-200mm f/2.8 L IS II, Canon 24-105mm f/4 L IS, Canon 10-22mm f/3.5-4.5, Canon 1.4X II, Canon 2x III

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
ldn323
THREAD ­ STARTER
Goldmember
ldn323's Avatar
Joined Dec 2006
Dec 15, 2017 23:06 |  #2

False alarm. Found the answer to my question.

The XF18-55 lens does have an aperture ring. It is just unmarked. So, the ring must be used to change the aperture setting. I actually like it better this way. However, since there is no marking, I thought it is one of the Fuji lenses that do not have aperture ring and therefore the rear command dial must be used.

Phew!


Linh - My Flickr (external link)
1Dx, 7D Mark II, XTi, Fuji X100s, Sigma 150-600mm f/5-6.3 DG OS HSM Contemporary, Canon 100-400mm f/4.5-5.6 L IS II, Canon 70-200mm f/2.8 L IS II, Canon 24-105mm f/4 L IS, Canon 10-22mm f/3.5-4.5, Canon 1.4X II, Canon 2x III

LOG IN TO REPLY
gremlin75
Goldmember
gremlin75's Avatar
Joined Feb 2011
Detroit, MI
Post has been edited 2 months ago by gremlin75.
Dec 17, 2017 17:56 |  #3

ldn323 wrote in post #18519005 (external link)
False alarm. Found the answer to my question.

The XF18-55 lens does have an aperture ring. It is just unmarked. So, the ring must be used to change the aperture setting. I actually like it better this way. However, since there is no marking, I thought it is one of the Fuji lenses that do not have aperture ring and therefore the rear command dial must be used.

Phew!

Almost all Fuji XF lenses have aperture rings (only one I can think of that doesn't is the 27mm f2.8). However a few XF lenses do not have marked aperture rings (18-55, 55-200, and 10-24 are the ones I know don't)

Fuji's XC lenses (16-50 and 50-230) have no aperture ring. Those (along with the 27) are the lenses that have to use a command dial to change the aperture.

I know you already figured this out but just adding the info in case anyone comes across this in a search for a similar problem.




LOG IN TO REPLY
Two ­ Hot ­ Shoes
Goldmember
Two Hot Shoes's Avatar
Joined Apr 2014
Ireland
Dec 17, 2017 18:23 as a reply to gremlin75's post |  #4

Any variable aperture XF lens has no markings on the aperture ring, for obvious reasons.


Fuji: X-PRO2, X-T1, X-E2 | 16/1.4, 18/2, 23/1.4, 35/1.4, 56/1.2, 90/2, 16-55/2.8, 10-24/4. AD600BM, TT865F, AL-H198, ThinkTank AS2, Peli1514, Ona Bowery, Matthews Grip
flickr (external link)Instagram (external link)Blog (external link)

LOG IN TO REPLY
EverydayGetaway
Cream of the Crop
EverydayGetaway's Avatar
Joined Oct 2012
Bowie, MD
Dec 18, 2017 01:08 |  #5

Two Hot Shoes wrote in post #18520418 (external link)
Any variable aperture XF lens has no markings on the aperture ring, for obvious reasons.

Honestly, I wish they'd have gone the route of old SLR lenses where they mark it with "2.8-4" for the first stop, or even just mark it "Max" then have hard stops from there. I hate the aperture rings on the variable aperture lenses (mainly the 18-55mm) because I bump them every now and then without realizing it.


Fuji X-Pro2 // Fuji X-T1 // Fuji X-100T // XF 18mm f2 // XF 35mm f1.4 // XF 60mm f2.4 // Rokinon 12mm f2 // Rokinon 21mm f1.4 // XF 18-55mm f/2.8-4 // XF 55-200mm f3.5-4.8 // Rokinon 85mm f1.4 // Zhonghi Lensturbo ii // Various adapted MF lenses
flickr (external link) // Instagram (external link)

LOG IN TO REPLY
Osa713
Senior Member
Osa713's Avatar
Joined Jun 2011
Houston, TX
Dec 18, 2017 23:42 |  #6

EverydayGetaway wrote in post #18520639 (external link)
Honestly, I wish they'd have gone the route of old SLR lenses where they mark it with "2.8-4" for the first stop, or even just mark it "Max" then have hard stops from there. I hate the aperture rings on the variable aperture lenses (mainly the 18-55mm) because I bump them every now and then without realizing it.

Same, I moved up to the 16-55 because I am ocd


LIGHT>LENS>BODY

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)

369 views & 4 likes for this thread
New X-T1 with XF18-55 Kit Lens - Aperture Selection Not Working
FORUMS Other Digital Cameras Fuji Digital Cameras


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00141 for 6 database queries.
PAGE COMPLETED IN 0.05s
Latest registered member is vivekkvikasphotography
932 guests, 432 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017