Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Other Digital Cameras Olympus Digital Cameras 
Thread started 06 Feb 2018 (Tuesday) 15:43
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Firmware update

 
racketman
Cream of the Crop
Avatar
20,726 posts
Gallery: 12 photos
Likes: 405
Joined Oct 2005
Location: Richmond Surrey
     
Feb 06, 2018 15:43 |  #1

Trying to use Olympus Digital Camera Updater to update firmware on EM-1 MKII from 1.0 to 1.4 but getting message 'failed to communicate with camera" iMac running with High Sierra 10.13.3
Assuming Olympus hasn't caught up with the iMac is there a workaround?


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Jerry ­ Coupe
Member
122 posts
Gallery: 1 photo
Likes: 23
Joined Mar 2013
Location: Kent, WA
     
Feb 07, 2018 00:21 |  #2

Do you have a good photo dealer nearby. Perhaps they would do the update for you.




  
  LOG IN TO REPLY
racketman
THREAD ­ STARTER
Cream of the Crop
Avatar
20,726 posts
Gallery: 12 photos
Likes: 405
Joined Oct 2005
Location: Richmond Surrey
     
Feb 07, 2018 13:21 as a reply to  @ Jerry Coupe's post |  #3

Nothing so useful, all boutiques and estate agents round here zzzzzz


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

  
  LOG IN TO REPLY
racketman
THREAD ­ STARTER
Cream of the Crop
Avatar
20,726 posts
Gallery: 12 photos
Likes: 405
Joined Oct 2005
Location: Richmond Surrey
     
Feb 08, 2018 08:42 |  #4

This worked :-)

We have received the following information which might resolve these issues on some of the computers running on High Sierra.

Please follow these steps to resolve the issues.

1. Download the latest version of the Olympus Viewer 3, from the following link

http://download.olympu​s.cz/ECSC/Viewer/OV3Se​tup.dmg (external link)

2. On the mac, perform the permission operation using the following procedure:

Choose "System Preferences" from the Apple menu

Click "Security & Privacy"

Click the ”Allow" button

If there is no improvement, my best advice is to perform the firmware udate on a computer running on MAC OS 10.12 or earlier, or any computer running on Windows .


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

  
  LOG IN TO REPLY
Quadna71
Senior Member
Avatar
371 posts
Likes: 1
Joined Mar 2012
     
Feb 10, 2018 15:38 |  #5

I have 10.13.3 on my Macbook and had no problems going from 1.0 to 1.4 last night on my mark II. Are you using the included USB-C cable to connect up?


6D | 50/1.4 | 40/2.8

  
  LOG IN TO REPLY
MCAsan
Goldmember
Avatar
3,708 posts
Likes: 33
Joined Jun 2010
Location: Atlanta
Post edited 3 months ago by MCAsan.
     
Feb 20, 2018 08:42 |  #6

Zero problem doing updates to our E-M1 II bodies running High Sierra on our iMacs. Will be doing another firmware upgrade to version 2 on Feb 28.




  
  LOG IN TO REPLY
Lyndön
Goldmember
1,970 posts
Gallery: 2 photos
Best ofs: 1
Likes: 118
Joined Oct 2008
Location: Knoxville, TN
     
Mar 30, 2018 03:10 |  #7

For some reason you can’t update the Oly Update program from within itself. You have to update it from the Oly Viewer program, then it’s always worked fine for me on my EM1.2 and EM10.2, as well as several lenses on my iMac on the latest MacOS versions.


GEAR LIST

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

537 views & 1 like for this thread
Firmware update
FORUMS Other Digital Cameras Olympus Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is cabvkam
749 guests, 343 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.