Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Small Compact Digitals by Canon
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 12th of March 2011 (Sat)   #1
digiman100
Junior Member
 
Join Date: Dec 2005
Posts: 2
Default IXUS 95IS, Shoot button not working

Although everything seems ok when teh camera is switch on, teh screen shows what should be the scene, the shoot button does not work, it will not press to take the photo. Any suggestions please
digiman100 is offline   Reply With Quote
This ad block will go away when you log in as member
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canon IXUS 95IS scruffyone Canon EOS Digital Cameras 0 13th of February 2011 (Sun) 08:30
7D AF-On Button not working intermittedly WAF Canon EOS Digital Cameras 3 27th of December 2009 (Sun) 07:00
shutter button not working xti TwoWheelMotion Canon EOS Digital Cameras 2 11th of August 2009 (Tue) 12:37
Shutter button on grip not working, anyone know a fix? mrloofer Canon EOS Digital Cameras 2 22nd of July 2009 (Wed) 08:28
Dropped ixus 500 - missing shutter button Miche Small Compact Digitals by Canon 2 21st of March 2005 (Mon) 10:54


All times are GMT -5. The time now is 09:05.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.