Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Small Compact Digitals by Canon
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 28th of March 2011 (Mon)   #1
Crunchberry
Junior Member
 
Crunchberry's Avatar
 
Join Date: Mar 2011
Location: NW Georgia
Posts: 16
Default Problem with my Powershot A590's flash

I'm new and I hope this is in the right place.

The flash on my camera has stopped working. I've replaced the batteries several times with fresh ones, it still doesn't work. It still takes good pics outdoors in the sunlight and it takes great video's.

Any ideas what to do? I received it a couple-three years ago-my 1st ever 'brand name' camera. It has to be out of warranty by now...
__________________
n00b alert!
Crunchberry is offline   Reply With Quote
This ad block will go away when you log in as member
Old 28th of March 2011 (Mon)   #2
Jon
Moderator

Cocker Spaniel Mod

 
Jon's Avatar
 
Join Date: Jun 2004
Location: Bethesda, MD USA
Posts: 67,955
Default Re: Problem with my Powershot A590's flash

I'm afraid that after over 2 years it is out of warranty.

This is in all modes, including "Green Box" full Auto? The flash icon is showing properly on the display (doesn't have the circle/slash over it)?
__________________
Jon
----------

Cocker Spaniels
Maryland and Virginia activities

Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE
Jon is offline   Reply With Quote
Old 28th of March 2011 (Mon)   #3
Crunchberry
Junior Member
 
Crunchberry's Avatar
 
Join Date: Mar 2011
Location: NW Georgia
Posts: 16
Default Re: Problem with my Powershot A590's flash

Yes, it won't even take an indoor/flash pic in full auto.

Oh! The flash indicator blinks off and on, but the flash won't fire
__________________
n00b alert!
Crunchberry is offline   Reply With Quote
This ad block will go away when you log in as member
Old 28th of March 2011 (Mon)   #4
Jon
Moderator

Cocker Spaniel Mod

 
Jon's Avatar
 
Join Date: Jun 2004
Location: Bethesda, MD USA
Posts: 67,955
Default Re: Problem with my Powershot A590's flash

Blinks off and on? That shouldn't be. Sounds like there's a bad connection inside. I doubt it'll be cost-effective to get it fixed, but if you send it in to Canon for service they may offer to sell you a refurbished model at a reduced price from the Canon Loyalty Program.
__________________
Jon
----------

Cocker Spaniels
Maryland and Virginia activities

Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE
Jon is offline   Reply With Quote
Old 28th of March 2011 (Mon)   #5
Crunchberry
Junior Member
 
Crunchberry's Avatar
 
Join Date: Mar 2011
Location: NW Georgia
Posts: 16
Default Re: Problem with my Powershot A590's flash

Ok. I'm a little sad, but I'll see what they say. Thank you.
__________________
n00b alert!
Crunchberry is offline   Reply With Quote
Old 31st of October 2011 (Mon)   #6
pennstatejeff
Junior Member
 
Join Date: Mar 2009
Location: West Chester, PA
Posts: 2
Default Re: Problem with my Powershot A590's flash

Crunchberry: Did you ever resolve your "flash" dilemma? My wife's A580 is having the same problem, the flash does not work, but the "flash icon" does flash off/on when trying to take an indoor picture. If I try it again it will make a barely audible "click" as if sending voltage to the flash or something, and it will take the photo, but obviously the image is barely visible. One add'l thing for anyone reading this who can help: I noticed recently that her A580 seemed to have an abnormal "delay" between pressing the shutter release and taking the actual picture. Not sure whether that's related to the problem, but thought I'd reach out for help. Thanks or any suggestions.
__________________
PennStateJeff
Equipment: A560 (July 2007), A580 (Nov 2008-wife's)
pennstatejeff is offline   Reply With Quote
Old 26th of February 2014 (Wed)   #7
wentidos
Junior Member
 
Join Date: Feb 2014
Posts: 1
Default Re: Problem with my Powershot A590's flash

Quote:
Originally Posted by pennstatejeff View Post
Crunchberry: Did you ever resolve your "flash" dilemma? My wife's A580 is having the same problem, the flash does not work, but the "flash icon" does flash off/on when trying to take an indoor picture. If I try it again it will make a barely audible "click" as if sending voltage to the flash or something, and it will take the photo, but obviously the image is barely visible. One add'l thing for anyone reading this who can help: I noticed recently that her A580 seemed to have an abnormal "delay" between pressing the shutter release and taking the actual picture. Not sure whether that's related to the problem, but thought I'd reach out for help. Thanks or any suggestions.
Hola, Me pasaba igual, sólo que ninguna de las luces del flash encendían, lo que hice fué reiniciarlo, saqué la batería cr1220 (batería de reloj) y la volví a meter, se reinicia la configuración, pero ahora funciona el flash.

Google traduction: Hi, I ran the same, only that none of the lights flash lit, what I did was reset, pulled out battery cr1220 (watch battery) and went back to get the configuration restarts but now the flash works.
wentidos is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Powershot A590 Question CNW 6000 Small Compact Digitals by Canon 8 27th of July 2010 (Tue) 04:48
Powershot A580 (or A590?) stevod Small Compact Digitals by Canon 1 8th of May 2009 (Fri) 08:35
I just bought a Powershot A590 IS Perry Ge Small Compact Digitals by Canon 32 22nd of March 2009 (Sun) 11:10
Powershot A590 & CHDK? Flaxe Small Compact Digitals by Canon 3 1st of August 2008 (Fri) 07:11


All times are GMT -5. The time now is 20:30.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.