Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon EOS Digital Cameras
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 28th of May 2011 (Sat)   #1
osuvette
Member
 
osuvette's Avatar
 
Join Date: May 2010
Location: Central Ohio
Posts: 56
Default Main dial on 50D stopped then started working

Had a scare last night, the main dial button on my 50D stopped responding, would turn, no action.

I could not change the ISO, Aperture, advance pics in play mode, etc. I turned the camera off and back on, no joy. Changed from the 70-200 2.8 lens (it was stuck on the 2.8 setting), put on the 24-105 f/4 lens, the setting changed to f/4, could not adjust. Turned off and back on, then it started working. Very nervous, the 70-200 lens is new (used) to me, was only the second time I used it.

No errors displayed either and it worked the rest of the night, ~ 100 more pictures. Anyone have this experience? Considering sending to Canon, however don't really want to be without it while being inspected.
2 days ago

Anyone else have a similar experience?

Jeff
__________________
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Gripped Canon 50D | Canon 70-200 f/2.8 L | Canon 24-105 f/4 IS L | Canon 300 f/4 IS | Canon 50 f/1.8 | Tamron 17-50 f/2.8 | Canon Speedlight 430EX | Crumpler 7 Million Dollar Bag
osuvette is offline   Reply With Quote
This ad block will go away when you log in as member
Old 28th of May 2011 (Sat)   #2
oldvultureface
Goldmember
 
oldvultureface's Avatar
 
Join Date: Jun 2008
Location: Northwest Indiana
Posts: 3,846
Default Re: Main dial on 50D stopped then started working

Was the grip attached at the time? Frequently, that's the culprit.
oldvultureface is online now   Reply With Quote
Old 28th of May 2011 (Sat)   #3
yogestee
"hangs around male genitalia"
 
yogestee's Avatar
 
Join Date: Dec 2007
Location: Aussie living in Laos
Posts: 13,418
Default Re: Main dial on 50D stopped then started working

Possibly you didn't have the three way switch properly engaged to the upper position.

This has happened to me and my heart went into my throat for a few seconds.
__________________
Jurgen
50D~20D~700D~EOS M~S95

http://www.pbase.com/jurgentreue
The Title Fairy,, off with her head!!
yogestee is offline   Reply With Quote
This ad block will go away when you log in as member
Old 28th of May 2011 (Sat)   #4
RandyS
Senior Member
 
RandyS's Avatar
 
Join Date: Dec 2009
Location: Minnesota
Posts: 1,046
Default Re: Main dial on 50D stopped then started working

Quote:
Originally Posted by yogestee View Post
Possibly you didn't have the three way switch properly engaged to the upper position.

This has happened to me and my heart went into my throat for a few seconds.
Same exact thing happened to me last night.

Just yesterday afternoon, I had been using the main dial. Pulled my camera out to use it last night and the main dial wouldn't respond. For a few seconds, I started to panic ... then I looked at the power switch.

RandyS is offline   Reply With Quote
Old 28th of May 2011 (Sat)   #5
oldvultureface
Goldmember
 
oldvultureface's Avatar
 
Join Date: Jun 2008
Location: Northwest Indiana
Posts: 3,846
Default Re: Main dial on 50D stopped then started working

Quote:
Originally Posted by osuvette View Post
... the main dial button on my 50D stopped responding ...
To be clear, the main dial is the one by the shutter button. It won't be affected by the position of the on-off switch. If the main dial on the grip is between clicks, it will disable the main dial on the camera. The quick control dial is the one on the back of the camera and some of its functionality is affected by the on-off switch.
oldvultureface is online now   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Main dial not responding Molnies Canon EOS Digital Cameras 9 1st of December 2012 (Sat) 00:29
Main Dial on 5D Mkii not working occasionally Michael.tenggala Canon EOS Digital Cameras 15 12th of November 2011 (Sat) 16:42
G5 main dial bben Canon G-series Digital Cameras 7 29th of March 2008 (Sat) 11:26
G6 manual mode main dial not working paradyne64 Canon G-series Digital Cameras 4 25th of January 2007 (Thu) 13:02
dropped s500...mode dial stopped working (now fixed) and card door broke hurricanesteve Small Compact Digitals by Canon 0 27th of May 2006 (Sat) 11:18


All times are GMT -5. The time now is 12:35.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.