Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras
Thread started 28 May 2011 (Saturday) 06:02
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Main dial on 50D stopped then started working

 
osuvette
Member
osuvette's Avatar
57 posts
Joined May 2010
Central Ohio
May 28, 2011 06:02 |  #1

Had a scare last night, the main dial button on my 50D stopped responding, would turn, no action.

I could not change the ISO, Aperture, advance pics in play mode, etc. I turned the camera off and back on, no joy. Changed from the 70-200 2.8 lens (it was stuck on the 2.8 setting), put on the 24-105 f/4 lens, the setting changed to f/4, could not adjust. Turned off and back on, then it started working. Very nervous, the 70-200 lens is new (used) to me, was only the second time I used it.

No errors displayed either and it worked the rest of the night, ~ 100 more pictures. Anyone have this experience? Considering sending to Canon, however don't really want to be without it while being inspected.
2 days ago

Anyone else have a similar experience?

Jeff


^^^^^^^^^^^^^^^
Gripped Canon 50D | Canon 70-200 f/2.8 L | Canon 24-105 f/4 IS L | Canon 300 f/4 IS | Canon 50 f/1.8 | Tamron 17-50 f/2.8 | Canon Speedlight 430EX | Crumpler 7 Million Dollar Bag

LOG IN TO REPLY
oldvultureface
Goldmember
oldvultureface's Avatar
Joined Jun 2008
Northwest Indiana USA
May 28, 2011 06:39 |  #2

Was the grip attached at the time? Frequently, that's the culprit.


OVF

LOG IN TO REPLY
yogestee
"my posts can be a little colourful"
yogestee's Avatar
13,829 posts
Gallery: 5 photos
Joined Dec 2007
Australia
May 28, 2011 07:55 as a reply to oldvultureface's post |  #3

Possibly you didn't have the three way switch properly engaged to the upper position.

This has happened to me and my heart went into my throat for a few seconds.


Jurgen
50D~700D~EOS M~GoPro Hero4 Silver~S95

http://www.pbase.com/j​urgentreue (external link)
The Title Fairy,, off with her head!!

LOG IN TO REPLY
RandyS
Goldmember
RandyS's Avatar
1,046 posts
Joined Dec 2009
Minnesota
May 28, 2011 08:21 |  #4

yogestee wrote in post #12493637 (external link)
Possibly you didn't have the three way switch properly engaged to the upper position.

This has happened to me and my heart went into my throat for a few seconds.

Same exact thing happened to me last night.

Just yesterday afternoon, I had been using the main dial. Pulled my camera out to use it last night and the main dial wouldn't respond. For a few seconds, I started to panic ... then I looked at the power switch.

IMAGE: http://i69.photobucket.com/albums/i61/rsamos/smilies/doh.gif



LOG IN TO REPLY
oldvultureface
Goldmember
oldvultureface's Avatar
Joined Jun 2008
Northwest Indiana USA
May 28, 2011 12:49 |  #5

osuvette wrote in post #12493417external link
... the main dial button on my 50D stopped responding ...

To be clear, the main dial is the one by the shutter button. It won't be affected by the position of the on-off switch. If the main dial on the grip is between clicks, it will disable the main dial on the camera. The quick control dial is the one on the back of the camera and some of its functionality is affected by the on-off switch.


OVF

LOG IN TO REPLY

1,160 views & 0 likes for this thread
Main dial on 50D stopped then started working
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00144 for 4 database queries.
PAGE COMPLETED IN 0.02s
Latest registered member is IBC-Gene
942 guests, 668 members online
Simultaneous users record so far is 5577, that happened on Mar 02, 2016