Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon EOS Digital Cameras
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 27th of May 2012 (Sun)   #1
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default 7D with battery/shut down issues

Hi All,

My 7D has suddenly started playing up, when putting either of my geniune canon batteries in I get the flashing battery not reconised symbol flashing on the top screen, taking out & re-serting the battery will get the 7D to see it properly after a few attempts, but then if the camera in burst mode it will completely shut itself down!

The charger says both batteries are ok, and if I go to the camera menu and look at the battery info it states its OK?

Would this be anything to do with the backup battery or an actual fault with the camera?

Its running the latest firmware & ive not changed anything? Never used a battery grip either, if it needs to go in for repairs so be it, but don't wanna send it in for no reason....

I've tried googling & searching this site, found a few people with similar probs, but nothing to say what they actually found wrong/if it needed repairing?

Any help please?

Thanks inadvance

Shelton.
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
This ad block will go away when you log in as member
Old 28th of May 2012 (Mon)   #2
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

nobody?
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 28th of May 2012 (Mon)   #3
joeseph
"smells like turd"
 
joeseph's Avatar
 
Join Date: Jan 2004
Location: Auckland, New Zealand
Posts: 7,181
Default Re: 7D with battery/shut down issues

hard to say, but if the charger's okay then either the batteries aren't really in tip-top condition , or the camera's got a problem that you're not likely to be able to fix without sending it in.

Only way to know for sure is by substitution.

How old are the batteries? would it be worth popping down to your local camera shop & asking if they minded trying your battery in one of their demo cameras? (or one of their shiny new batties in yours...)
__________________
canon camera stuff, canon lenses, Manfrotto "thingy", 1D MK II converted for IR
TF posting: here
joeseph is offline   Reply With Quote
This ad block will go away when you log in as member
Old 29th of May 2012 (Tue)   #4
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

The batteries are the same age as the camera, about 2yrs old..... I wonder if its worth trying to deep discharge atleast one of the batteries to see if that helps?

I've also ordered a replacement button battery, but will take it to a local shop at the weekend if all else fails to see whether using one of their batteries makes a difference.....

Thanks for the thoughts!
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 1st of June 2012 (Fri)   #5
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

Solved the problem!

Its my bloody EFS 17-55 causing the probs! If I have that lens on then I get the battery flashing symbol, if I do get it to work then it shuts the camera down in High speed mode!

Single shot or the standard speed multis its fine, tried my 100mm macro & its totally fine with everything, tried a new battery & also a different CF card with the 17-55 & get the probs

Any advice re the lens now?

Shelton.
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 1st of June 2012 (Fri)   #6
John from PA
Goldmember
 
Join Date: May 2003
Location: Southeast Pennsylvania
Posts: 4,324
Default Re: 7D with battery/shut down issues

Clean the lens contacts, and might as well do the body contacts as well. Use a clean cloth, dry or very lightly damped with some isopropyl alcohol. Do not use an eraser ("rubber" as you call it) on a pencil. There is a very thin plating on the contacts which you do not want to remove. Hold the camera body with the lens opening pointed down to avoid any dust getting into the body.

Last edited by John from PA : 1st of June 2012 (Fri) at 15:38.
John from PA is offline   Reply With Quote
Old 1st of June 2012 (Fri)   #7
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

As per my last post, its not actually the batteries causing the problems, its the EF-S 17-55 lens!

On swopping to my macro lens the problems all go away (i've also tried a new button/main battery, plus CF card with the 17-55 to make sure its deff that)
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 2nd of June 2012 (Sat)   #8
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

Bugger!

Its still doing it, looks like a trip to one of the repair centres is required, anybody reccomend one more than others in the UK or are all ok?
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 2nd of June 2012 (Sat)   #9
John from PA
Goldmember
 
Join Date: May 2003
Location: Southeast Pennsylvania
Posts: 4,324
Default Re: 7D with battery/shut down issues

If you are reasonably sure it is the lens, then I would suggest you see about a used replacement. At least here in the states that lens is so inexpensive it doesn't justify repair. You can often find it even new, broken out of a kit at very attractive prices ($100).
John from PA is offline   Reply With Quote
Old 3rd of June 2012 (Sun)   #10
Echo Johnson
Member
 
Echo Johnson's Avatar
 
Join Date: Aug 2011
Location: UK
Posts: 406
Default Re: 7D with battery/shut down issues

Quote:
Originally Posted by John from PA View Post
If you are reasonably sure it is the lens, then I would suggest you see about a used replacement. At least here in the states that lens is so inexpensive it doesn't justify repair. You can often find it even new, broken out of a kit at very attractive prices ($100).
The 17-55 for $100?
__________________
Canon 5D3 | 17-40 | 50/1.4 | 135/2
...and other stuff.
Echo Johnson is offline   Reply With Quote
Old 3rd of June 2012 (Sun)   #11
fidji
Junior Member
 
Join Date: Nov 2010
Posts: 11
Default Re: 7D with battery/shut down issues

Hi there,only had to send my camera in to canon once,so don't know if they are always as efficent and helpful.It went to canon at elstree,very near to you.Tel:-0208 731 4100 unless it's changed in the last two years.Regards.
fidji is offline   Reply With Quote
Old 10th of June 2012 (Sun)   #12
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

Been sent into the Colchester centre, awaiting an update as to whats wrong & will update this thread for others once I know
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Old 11th of July 2012 (Wed)   #13
Shultz
Lucky 13
 
Join Date: Aug 2005
Location: Suffolk, UK
Posts: 392
Default Re: 7D with battery/shut down issues

UPDATE...

Finally got camera back tuesday, will not be using Colchester Camera Centre again very poor service....

That having been said the actual problem was the main PCB had gone, total repair cost 385 but I have my camera back now and its working fine
__________________

7D ~ 17-55 f2.8 EF-S ~ 100mm f2.8 Macro ~ 50mm MK I ~ Sigma 100-300 f4 APO EX DG ~ TC x1.4 ~ Man 055XPROB & 488RC2 ~ NISSIN Di622
Shultz is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7D battery issues CatchingUp Canon EOS Digital Cameras 1 6th of June 2011 (Mon) 08:03
BG-E2N battery lvl issues FociBC Canon EOS Digital Cameras 6 19th of December 2008 (Fri) 01:08
S3 battery issues ceriltheblade Small Compact Digitals by Canon 8 8th of November 2007 (Thu) 19:10
battery issues..HELP!!!!! gb_eh Canon EOS Digital Cameras 8 11th of October 2006 (Wed) 11:38
20D battery issues again jph Canon EOS Digital Cameras 3 21st of February 2006 (Tue) 08:20


All times are GMT -5. The time now is 04:04.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.