Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon
Thread started 29 Jun 2017 (Thursday) 02:52
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

powershot s3is

 
johnmartin057
Hatchling
1 post
Joined Jun 2017
Jun 29, 2017 02:52 |  #1

Have not used camera for couple of years and on switching on (with new batteries) seems to function and do not have image on lcd and viewfinder. Information comes up on screen but no image. Date battery is ok as correct date is displayed, shutter operates but blank image. Would appreciate any advice




LOG IN TO REPLY

1,892 views & 0 likes for this thread
powershot s3is
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00064 for 4 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is aka5h
904 guests, 462 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017