Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting
Thread started 28 Jul 2017 (Friday) 12:42
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Godox AD-600 battery indicator flawed?

 
mmmfotografie
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Post has been edited 2 months ago by mmmfotografie.
Jul 28, 2017 12:42 |  #1

I think this is my third time I have to charge the battery. The on battery and on flash charge indicator still showed full charge. I know the way these batteries keep up very well but full after that many releases seems not to be possible.

I attached the charger and it started to change from the bottom of the LED's on the charger. So the battery seemed to be almost empty.

Does anyone have same improper indication of the charge state of the battery like I had?

Recharging took almost three hours so it was really low on charge.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Aug 17, 2017 03:54 |  #2

It seems that I am the only one having this problem so mine battety must be flawed.

It recharges fine and usage is fine but not knowing how much usage is left in the battery is missed very much.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
bobbyz
Cream of the Crop
18,302 posts
Joined Nov 2007
Bay Area, CA
Aug 18, 2017 02:22 |  #3

Wasn't there a battery issue and Adorama was taking care of the folks who bought from them. I do remember asking Helen here in some thread.


5dmk3, 35L, 85L II, 300mm f2.8 IS I, 400mm f5.6
Fuji XT-1, 14mm f2.8, 23mm f1.4, 35mm f1.4, 56mm f1.2, 90mm f2, 50-140mm f2.8

LOG IN TO REPLY
HelenOster
That's me!
HelenOster's Avatar
4,289 posts
Joined Jul 2008
New York
Aug 18, 2017 03:01 |  #4

mmmfotografie wrote in post #18413440 (external link)
I think this is my third time I have to charge the battery. The on battery and on flash charge indicator still showed full charge. I know the way these batteries keep up very well but full after that many releases seems not to be possible.

I attached the charger and it started to change from the bottom of the LED's on the charger. So the battery seemed to be almost empty.

Does anyone have same improper indication of the charge state of the battery like I had?

Recharging took almost three hours so it was really low on charge.


Please can you email me with your order number: Helen@adorama.com so I can arrange an exchange.


Adorama Camera Customer Service Ambassador
Helen@adorama.com
http://twitter.com/Hel​enOsterexternal link
http://www.flickr.com/​people/22264746@N07/external link

LOG IN TO REPLY
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Aug 18, 2017 04:14 |  #5

Thanks however I did not buy with Adorama. I would if it was not that I live in Europe.

I will contact my reseller to see if they are as good as Adorama.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
abbadon31
Goldmember
abbadon31's Avatar
Joined Jul 2009
SOCAL
Post has been edited 2 months ago by abbadon31.
Aug 18, 2017 12:47 |  #6

it has to be below 75% for it drop a bar on the battery led indicators


I AM SHOM

LOG IN TO REPLY
SereneSpeed
Senior Member
699 posts
Joined Jan 2013
Aug 18, 2017 13:04 as a reply to abbadon31's post |  #7

Mine never drops, regardless of batter power. It just shuts off when the battery dies. The LCD battery monitor has never worked. And, the on-battery monitor has never worked. The only monitor that works is the one on the charger.

I have written about this before. I did not know I could get support... Time to do that.


http://danielb.photogr​aphy (external link)
https://www.facebook.c​om/dmwbphotography (external link)
https://www.flickr.com​/photos/danielmwbuehle​r (external link)

LOG IN TO REPLY
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Post has been edited 2 months ago by mmmfotografie.
Aug 19, 2017 10:32 |  #8

SereneSpeed wrote in post #18431019 (external link)
Mine never drops, regardless of batter power. It just shuts off when the battery dies. The LCD battery monitor has never worked. And, the on-battery monitor has never worked. The only monitor that works is the one on the charger.

I have written about this before. I did not know I could get support... Time to do that.

Which version of the firmware is installed in your AD600?

I have gone back to 1.5 because I had a working battery indicator and the next shoot I can see if it starts working again.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
SereneSpeed
Senior Member
699 posts
Joined Jan 2013
Aug 19, 2017 14:57 as a reply to mmmfotografie's post |  #9

Good question. My Xplor600 was one of the first to ship. It has whatever firmware was on it when it arrived. We only have Apple computers at home, so upgrading firmware is not really possible... not without hassle at least.


http://danielb.photogr​aphy (external link)
https://www.facebook.c​om/dmwbphotography (external link)
https://www.flickr.com​/photos/danielmwbuehle​r (external link)

LOG IN TO REPLY
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Aug 19, 2017 15:40 as a reply to SereneSpeed's post |  #10

You can see your version very easy on the AD600 by switching it on and press the menu button. Now you see in the right upper corner of the display the version of the firmware in your AD600.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
SereneSpeed
Senior Member
699 posts
Joined Jan 2013
Aug 19, 2017 20:47 as a reply to mmmfotografie's post |  #11

Thanks, I'll give that a try.


http://danielb.photogr​aphy (external link)
https://www.facebook.c​om/dmwbphotography (external link)
https://www.flickr.com​/photos/danielmwbuehle​r (external link)

LOG IN TO REPLY
ThreeHounds
Senior Member
ThreeHounds's Avatar
Joined Mar 2014
Delray Beach, Fl USA
Aug 19, 2017 22:57 as a reply to SereneSpeed's post |  #12

Google Wine or Crossover. They run many Windows apps in a shell, including the Godox and Flashpoint firmware updaters.


5D MkIII | 7D | Bronica ETRS
24-105 f/4 L | 17-40 f/4 L | 70-300 f/4 L | 105 f/3.5 Zenzanon | Tamron SP90 f/2.8 Di Macro VC USM
flickr (external link)

LOG IN TO REPLY
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Sep 27, 2017 06:05 |  #13

So what time on and I had again a disappointment with the AD600 battery when it was empty but not indicate it before.

I have now noticed some very strange behaviour of the batterypack. Because it was empty I recharged it but not to full but to one constant led and one blinking led. I put it away and two days later I pressed the battery status button again and it show to my surprise that it had recharged itself to two constant and one blinking led.

Now I attached it to the AD600 and the display of that indicates the battery is full. Pressing the battery status button indicates also that the battery is full and even detached is shows that the battery is fully charged!

I have now a convincing story to go back to the store and ask for a replacement because this one is not good and the indicator(s) does not reflect true charged state of the battery.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
RDKirk
Cream of the Crop
RDKirk's Avatar
12,491 posts
Joined May 2004
USA
Sep 27, 2017 07:35 |  #14

mmmfotografie wrote in post #18461285 (external link)
So what time on and I had again a disappointment with the AD600 battery when it was empty but not indicate it before.

I have now noticed some very strange behaviour of the batterypack. Because it was empty I recharged it but not to full but to one constant led and one blinking led. I put it away and two days later I pressed the battery status button again and it show to my surprise that it had recharged itself to two constant and one blinking led.

Now I attached it to the AD600 and the display of that indicates the battery is full. Pressing the battery status button indicates also that the battery is full and even detached is shows that the battery is fully charged!

I have now a convincing story to go back to the store and ask for a replacement because this one is not good and the indicator(s) does not reflect true charged state of the battery.

When the recharger indicates the battery is fully charged, what is the actual battery life like? Anything close to 500 full-power pops?




LOG IN TO REPLY
mmmfotografie
THREAD ­ STARTER
Goldmember
mmmfotografie's Avatar
2,030 posts
Joined Jul 2013
Utrecht Netherlands
Sep 27, 2017 09:18 as a reply to RDKirk's post |  #15

The battery is good and recharging it to full takes hours. The indicator on/in the battery is bonkers.

I did two shoot with the battery and that is more than 500 pops but mixed of low and high intensity.


mmmfotografie : portfolio (external link) | ModelMayhem profile (external link)

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)

2,655 views & 2 likes for this thread
Godox AD-600 battery indicator flawed?
FORUMS General Gear Talk Flash and Studio Lighting


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00094 for 4 database queries.
PAGE COMPLETED IN 0.08s
Latest registered member is jjj9070749
878 guests, 373 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016