Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting
Thread started 02 Sep 2017 (Saturday) 02:56
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Neewer NW565EX Not syncing with D7000

 
Deliverator
Hatchling
2 posts
Joined Sep 2017
Sep 02, 2017 02:56 |  #1

I bought a Neewer NW564EX a while ago. I've used it on camera, and it works very well from the hotshoe. The specifications say it is compatible with Nikon cameras as an i-TTL slave. Recently, I tried testing it off-camera, and I can't get it to sync. I have the on board flash set to Commander Mode, and the flash set to i-TTL slave on group A, channel 1.

When I take a shot, I can see the flash fire, but it's not very bright, and contributes nothing to the image, which remains heavily underexposed. I have been able to use the flash as a manual slave, fired from the on-camera flash in manual mode, but I'd prefer i-TTL functionality.

I'm hoping it's just that I've missed something in my settings. I've uploaded images of the camera and flash settings for review.

HOSTED PHOTO
please log in to view hosted photos in full size.

HOSTED PHOTO
please log in to view hosted photos in full size.



LOG IN TO REPLY
Deliverator
THREAD ­ STARTER
Hatchling
2 posts
Joined Sep 2017
Sep 03, 2017 08:31 |  #2

I figured it out, and it's kind of embarrassing. I've gotten into the habit of shooting in quiet mode, mostly because I find it gives me better sharpness. Then I realised - the little delay introduced by quiet mode shooting messes up the sync. So, I put it in Continuous Low, and it synced, and worked perfectly.




LOG IN TO REPLY

1,714 views & 0 likes for this thread
Neewer NW565EX Not syncing with D7000
FORUMS General Gear Talk Flash and Studio Lighting


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00068 for 4 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is Desser
906 guests, 443 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016