Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses
Thread started 29 Oct 2017 (Sunday) 13:02
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Sigma 8-16mm on 80D? Anyone?

 
Bassat
THREAD ­ STARTER
"I am still in my underwear."
Bassat's Avatar
6,569 posts
Joined Oct 2015
Bourbon, Indiana - USA
Post has been edited 20 days ago by Bassat.
Oct 31, 2017 08:26 as a reply to post 18485266 |  #16

Ok, after TeamSpeed posted that his Σ8-16mm works on every camera under the sun, some of them newer than my 80D, I decided to start over with my 12-24 on the 80D. I got home this morning, and ran the focus from MFD to infinity a few dozen times, cleaned all the contacts, and re-flashed the 80D firmware. I'm not sure what exactly fixed it, but it is now working. My 80D can lock focus at any focal length, wide open. It is a bit slow, but that is the lens. I only tested out to about 5'; at that distance and f/8, the entire world is in focus. More importantly, it works just as well at MFD and wide open. It even works in light low enough to kick on the annoying 80D flash assist strobe.

Thanks all. Now I start my hunt for a nice Sigma 8-16mm. Anyone need a Sigma 12-24 II? I am still debating whether or not to sell the 6D. My fast(er) primes really shine on the 6D.


Tom

LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
7,453 posts
Joined May 2003
Southeast Pennsylvania
Oct 31, 2017 09:45 |  #17

Bassat wrote in post #18485341 (external link)
I got home this morning, and ran the focus from MFD to infinity a few dozen times, cleaned all the contacts, and re-flashed the 80D firmware. I'm not sure what exactly fixed it, but it is now working.

Was it a "refresh" of the existing firmware or was a newer version installed? As you likely are aware there are numerous instances discussed on these forums where strange behavior was corrected by a refresh, even when it wasn't a upgrade of the firmware.

I used to work for an instrument manufacturer and many products had a motherboard where firmware was installed by the board manufacturer well before installation in the final product. If a product was returned step 1 in the repair process was the firmware replacement in the final instrument chassis. In many instances the instrument worked properly even though the firmware was a refresh, not an upgrade.




LOG IN TO REPLY
Bassat
THREAD ­ STARTER
"I am still in my underwear."
Bassat's Avatar
6,569 posts
Joined Oct 2015
Bourbon, Indiana - USA
Oct 31, 2017 15:31 |  #18

John from PA wrote in post #18485389 (external link)
Was it a "refresh" of the existing firmware or was a newer version installed? As you likely are aware there are numerous instances discussed on these forums where strange behavior was corrected by a refresh, even when it wasn't a upgrade of the firmware.

I used to work for an instrument manufacturer and many products had a motherboard where firmware was installed by the board manufacturer well before installation in the final product. If a product was returned step 1 in the repair process was the firmware replacement in the final instrument chassis. In many instances the instrument worked properly even though the firmware was a refresh, not an upgrade.

I refreshed v1.02. I'm not sure that is what fixed it. I also cleaned all the contacts (lens & camera) and ran the AF from MFD to infinity several times (not sure that does anything :) ).


Tom

LOG IN TO REPLY

2,666 views & 2 likes for this thread
Sigma 8-16mm on 80D? Anyone?
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00095 for 4 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is aftahir
792 guests, 309 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016