Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses
Thread started 31 Oct 2017 (Tuesday) 15:17
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

New Canon 55-250 chipped element inside?

 
TeamSpeed
01010100 01010011
TeamSpeed's Avatar
32,226 posts
Gallery: 63 photos
Joined May 2002
Northern Indiana
Post has been last edited 14 days ago by TeamSpeed. 3 edits done in total.
Nov 06, 2017 15:16 |  #16

It is nearly impossible to think that 3 different lenses across manufacturers all have the same kind of defect in the same area of the lenses. Dust I could believe, but not optical imperfections/chips. Also, anything that small in the middle of your lens WON'T IMPACT your photos. Want to try a test? Cut out a 2mm x 2mm square from a postit note, and stick it in the same area as that "speck". I suspect after you take some shots with it, with that piece of yellow paper on your lens, you won't see it in your photos.

Finally, having a 55-250, I can tell you that if you look through the inside of the lens at just the right angle, you will concentrate a lens flare such that it bounces off the edge of the metal edges that hold the lens elements in place, making it look like a bright metal flake or chip. If you hold the lens up and look through it straight on and see nothing in the pathway, there is no issue. Angling the lenses to see what you can see on the outer edges of the inner groups of elements isn't going to help identify issues.


Past Equipment | My Gallery (external link)

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
Arpad
THREAD ­ STARTER
Hatchling
Arpad's Avatar
8 posts
Joined Oct 2017
Portlaoise, Ireland
Post has been edited 14 days ago by Arpad.
Nov 06, 2017 15:27 as a reply to TeamSpeed's post |  #17

I will try this, but should show some fringing or minimal distortion even if this small. I mean it won't be the same as without it. I think?

I would agree on this, but I have looked at it from soooo many angles and different light sources... Even with the front cap on it's visible.. So defo something there.




LOG IN TO REPLY
TeamSpeed
01010100 01010011
TeamSpeed's Avatar
32,226 posts
Gallery: 63 photos
Joined May 2002
Northern Indiana
Post has been edited 14 days ago by TeamSpeed.
Nov 06, 2017 15:45 |  #18

One would think, but no... If the sun was in the frame at an angle, this might show some ghosting, but in most shots, no visually identifiable impacts. This is why we constantly remind those that are concerned with dust in their lenses to ignore it.

HOSTED PHOTO
please log in to view hosted photos in full size.

HOSTED PHOTO
please log in to view hosted photos in full size.

Past Equipment | My Gallery (external link)

LOG IN TO REPLY
BigAl007
Cream of the Crop
Joined Dec 2010
Repps cum Bastwick, Gt Yarmouth, Norfolk, UK.
Nov 06, 2017 18:43 |  #19

If you make the obstruction large enough you might eventually make it large enough to affect the out of focus highlights. But it will need to get pretty large. Stopping right down will show stuff in the lens, or on the sensor, more in an image, but this does OK at it's fixed f/8.

IMAGE: https://farm5.staticflickr.com/4573/38172165806_e4fb344a15_o.jpg
[IMAGE'S LINK: https://flic.kr/p/21a9​jZL] (external link)0001 (external link) by Alan Evans (external link), on Flickr

Alan

My Flickr (external link)
My new Aviation images blog site (external link)

LOG IN TO REPLY
Inspeqtor
I never knew that!
Inspeqtor's Avatar
Joined Mar 2008
Elkhart, Indiana
Nov 06, 2017 23:34 |  #20

Arpad wrote in post #18490137 (external link)
Seems like on "own threads" should send the notifications automatically. Well it doesn't for me :-P I try to un-follow and follow again maybe that will help :-)

Pekka is working on upgrading the AMASS! software from version 1.4 (what we have now) to 2.0

When he uploads 2.0 then you will see notifications for posts

http://photography-on-the.net .../showthread.php?t=1​483601


Charles
Canon EOS 60D Gripped * Canon EOS XSi * Flickr Account (external link)
Tokina AT-X Pro DX 11-20 f/2.8 * Sigma 17-70 f2.8-4 DC Macro OS * Sigma 150-500 f5-6.3 APO DG OS HSM
Canon 18-55 IS Kit Lens * Canon 70-300 IS USM * Canon 50mm f1.8 * Canon 580EX II *** iOptron 3302W Star Tracker

LOG IN TO REPLY
Phoenixkh
a mere speck
Joined May 2011
Gainesville, Florida
Nov 07, 2017 11:53 |  #21

Arpad wrote in post #18490143 (external link)
I have cleaned a good few (20 something) lenses and destroyed 2 in a year. So I think I have seen some to compare, but sure not these specific ones. The truth is that I bought them from eglobal for good price so maybe I was suspicious in the first place... And got what I was expecting. I mean if you look in to my first picture you can clearly see the dot in the middle so even if you just quickly mount it still goes " yuhuuu I am here!!" That's the Canon. The sigma could be just some dust or small piece of plastic from somewhere it is tiny and not obvious. The youngnuo seems to be just a small pinhead shaped absence of coating so I can live with that. We have bought a few lenses and flashes even a 5D mkIII from eglobal and never had any issues.. Or maybe I just didn't care since it was for the company.. :rolleyes: :-P
My biggest reason was that if I will end up selling them in a few years no one would buy them. And they are somewhat expensive to just go "ehh okay, fine who cares" . thank guys for the support and advice. Have a nice evening :-)

I guess it's possible that eglobal buys defective lenses from its suppliers and sells them at a huge discount. As has been mentioned, getting three defective lenses in one purchase would be unlikely.... but my guess could be one possible scenario.


Kim (the male variety) Canon 1D IV | 6Dc | 16-35 f/4 IS | 24-105 f/4 IS |100L IS macro | 70-200mm f/2.8L IS II | 100-400Lii | 50 f/1.8 STM | Canon 1.4X III
RRS tripod and monopod | 580EXII | Cinch 1 & Loop 3 Special Edition

LOG IN TO REPLY
Arpad
THREAD ­ STARTER
Hatchling
Arpad's Avatar
8 posts
Joined Oct 2017
Portlaoise, Ireland
Nov 07, 2017 13:51 as a reply to Phoenixkh's post |  #22

Yeah, that's what I was thinking. But just to clarify the youngnuo was from ebay a different company. Today I got the DHL waybill from eglobal so they are heading to Hong Kong to Omega photo for further inspection and they will get a cleaning or replacement if needed. The bad thing (or not) is I am left with the yongnuo for my holidays..




LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
7,453 posts
Joined May 2003
Southeast Pennsylvania
Nov 07, 2017 15:28 |  #23

Arpad wrote in post #18491008 (external link)
Today I got the DHL waybill from eglobal so they are heading to Hong Kong to Omega photo for further inspection and they will get a cleaning or replacement if needed. The bad thing (or not) is I am left with the yongnuo for my holidays..

Keep us posted. This eGlobal (https://www.eglobalcen​tral.com/ (external link)) has some interesting pricing and might be worth some future exploration.




LOG IN TO REPLY
Arpad
THREAD ­ STARTER
Hatchling
Arpad's Avatar
8 posts
Joined Oct 2017
Portlaoise, Ireland
Nov 07, 2017 15:36 as a reply to John from PA's post |  #24

Yes they have some good deals, it's just very slow in customer service but as I said this was my first issue with them. Although I would recommend using PayPal to pay, for extra protection...




LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)

3,240 views & 7 likes for this thread
New Canon 55-250 chipped element inside?
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00091 for 4 database queries.
PAGE COMPLETED IN 0.02s
Latest registered member is mikejohn1
782 guests, 333 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016