Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Post Processing, Marketing & Presenting Photos RAW, Post Processing & Printing 
Thread started 02 Feb 2018 (Friday) 19:38
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

A question about Lightroom lens profile corrections.

 
JeffreyG
"my bits and pieces are all hard"
Avatar
15,346 posts
Gallery: 39 photos
Likes: 456
Joined Jan 2007
Location: Detroit, MI
     
Feb 02, 2018 19:38 |  #1

I own a number of lenses, and I would like Lightroom to automatically set the lens profile correction to the lens I used when I import. The problem I find is this: If I set lens profile correction to "Auto", it always forces distortion and vignette correction to 100%. I don't want that. I almost never want 100% vignette correction. I want Lightroom to correctly set the lens used automatically, but I want to be able to apply very little vignette correction. Does anyone know how to do this?

I find if I set the lens profile to "default" or "manual" it keeps my preferred settings on the sliders, but now every shot is assumed to be with just one lens and I have to tedious change the lens type one by one.

Finally aggravation - If I use auto on import and get the right lens selected, as soon as I change one of the sliders, the setting jumps to "manual" and the lens type changes to the wrong one! Arrrgh. It seems like there is no way to just get Lighroom to automatically set the lens type but then use my preferred default amounts.

Thanks for any help.


My personal stuff:http://www.flickr.com/​photos/jngirbach/sets/ (external link)
I use a Canon 5DIII and a Sony A7rIII

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Bassat
"I am still in my underwear."
Avatar
7,551 posts
Likes: 2539
Joined Oct 2015
Location: Bourbon, Indiana - USA
     
Feb 02, 2018 20:27 |  #2

Not sure if this answers the question or not, but I always shoot raw when using non-Canon lenses. LR has profiles for lots of lenses when shooting raw, not so many with JPG.

And once you move a slider, you are telling LR that you don't want AUTO corrections. The only other choice is MANUAL. Kind of a DUH! moment there?


Tom,
Film gear: Elan 7NE / Elan 7 / EOS T2
Yashica FX-D (x2) & FX-3 Super 2000 / DSB 28mm f/2.8 / 50mm ML f/2 / 135mm ML f/2.8 / Sigma Zoom-gamma II 21-35mm f/3.4.2 / Yashica ML 28-85mm f/3.5-4.5 / Tokina 70-210mm ML f/4.

  
  LOG IN TO REPLY
JeffreyG
THREAD ­ STARTER
"my bits and pieces are all hard"
Avatar
15,346 posts
Gallery: 39 photos
Likes: 456
Joined Jan 2007
Location: Detroit, MI
     
Feb 02, 2018 20:43 |  #3

Bassat wrote in post #18555113 (external link)
Not sure if this answers the question or not, but I always shoot raw when using non-Canon lenses. LR has profiles for lots of lenses when shooting raw, not so many with JPG.

I shoot RAW to. This is me importing RAW files and applying metadata corrections only.

And once you move a slider, you are telling LR that you don't want AUTO corrections. The only other choice is MANUAL. Kind of a DUH! moment there?

Yeah....but, it's still dumb on their part. So I create an import profile and tell it I want LR to apply "AUTO" lens profiles. When it does it automatically reads the lens (let's say for the moment this is my Sony FE 28/2 on my A7rIII). But unfortunately it also forces me to have 100% distortion and 100% vignette correction applied.

I don't want 100% vignette. I like some vignetting. So I reach over and move the vignette slider to 10% and BOOM! LR changes the lens profile to "MANUAL" and it fricking changes the lens profile to a Canon EF 100-400L IS II. That is super dumb. My problem was not that I wanted every lens to become a 100-400 when I adjust the vignette amount. Why does any deviation from AUTO also automatically change the lens to something that I definitely did not take the picture with?

So then I have to select "Make" to "Sony" and pick the right lens and profile. Changing this in every single image is very tedious.

If I get home from a trip where I shot 1000 photos using 7 different lenses, all I want LR to do is assign the correct profile to all of them, but not force me to 100% corrections by default. And for sure I do not want to have to manual set the lens profile for all 1000 photos just because I want less than 100% vignette correction most of the time.


My personal stuff:http://www.flickr.com/​photos/jngirbach/sets/ (external link)
I use a Canon 5DIII and a Sony A7rIII

  
  LOG IN TO REPLY
Bassat
"I am still in my underwear."
Avatar
7,551 posts
Likes: 2539
Joined Oct 2015
Location: Bourbon, Indiana - USA
     
Feb 02, 2018 20:50 |  #4

JeffreyG wrote in post #18555121 (external link)
I shoot RAW to. This is me importing RAW files and applying metadata corrections only.

Yeah....but, it's still dumb on their part. So I create an import profile and tell it I want LR to apply "AUTO" lens profiles. When it does it automatically reads the lens (let's say for the moment this is my Sony FE 28/2 on my A7rIII). But unfortunately it also forces me to have 100% distortion and 100% vignette correction applied.

I don't want 100% vignette. I like some vignetting. So I reach over and move the vignette slider to 10% and BOOM! LR changes the lens profile to "MANUAL" and it fricking changes the lens profile to a Canon EF 100-400L IS II. That is super dumb. My problem was not that I wanted every lens to become a 100-400 when I adjust the vignette amount. Why does any deviation from AUTO also automatically change the lens to something that I definitely did not take the picture with?

So then I have to select "Make" to "Sony" and pick the right lens and profile. Changing this in every single image is very tedious.

If I get home from a trip where I shot 1000 photos using 7 different lenses, all I want LR to do is assign the correct profile to all of them, but not force me to 100% corrections by default. And for sure I do not want to have to manual set the lens profile for all 1000 photos just because I want less than 100% vignette correction most of the time.

I've never encountered this. You are right, that seems incredibly dumb! I'll have to pay more attention to this. Sorry I couldn't help.


Tom,
Film gear: Elan 7NE / Elan 7 / EOS T2
Yashica FX-D (x2) & FX-3 Super 2000 / DSB 28mm f/2.8 / 50mm ML f/2 / 135mm ML f/2.8 / Sigma Zoom-gamma II 21-35mm f/3.4.2 / Yashica ML 28-85mm f/3.5-4.5 / Tokina 70-210mm ML f/4.

  
  LOG IN TO REPLY
Dan ­ Marchant
Do people actually believe in the Title Fairy?
Avatar
4,893 posts
Gallery: 19 photos
Likes: 1207
Joined Oct 2011
Location: Where I'm from is unimportant, it's where I'm going that counts.
     
Feb 02, 2018 22:31 |  #5

I certainly couldn't find anyway to solve your issue using the lens correction controls. However, there is an easy and better way to solve the vignette issue which is to add it using the post crop vignette tool. This is a better option because the regular lens induced vignette will be lost when you do any cropping anyway. So remove the lens induced vignette and then add the desired amount of creative vignette which will always be applied properly no matter how you crop the image (and can be set as a default).

Another more complex solution would be to make your own lens correction profiles for your lenses and set the distortion correction to the lower level you prefer.


Dan Marchant
Website/blog: danmarchant.com (external link)
Instagram: @dan_marchant (external link)
Gear Canon 5DIII + Fuji X-T2 + lenses + a plastic widget I found in the camera box.

  
  LOG IN TO REPLY
digital ­ paradise
Cream of the Crop
Avatar
12,932 posts
Gallery: 10 photos
Likes: 5086
Joined Oct 2009
Post edited 3 months ago by digital paradise.
     
Feb 03, 2018 01:29 |  #6

It should be on Default. You may want to update if you still have issues. This is what I do if it does not recognize a lens. One example was my 100-400 II was OK but when I added a TC it did not apply so I just did this.

Click on Setup - Reset Lens Profile Defaults. Make sure it does this. Double check it.

In the Lens Correction window find the lens in Make and then Model.

Setup automatically changes to Custom.

Click on Setup and then on Save New Lens Profile Defaults.

Setup switches back to Default and new lens has been added. Now it will find it no matter which camera you are using.


Image Editing OK

Website (external link) ~ Buy/Sell Feedback

  
  LOG IN TO REPLY
Immaculens
creeped by the TF....
Avatar
12,941 posts
Gallery: 78 photos
Likes: 2598
Joined Jul 2009
Location: Southern Canada
     
Feb 03, 2018 10:00 |  #7

Upon reading the original post I recalled a Lens Profile issue I have found and posted on the Adobe Lr Forum.

No solution yet but hopeful.

https://forums.adobe.c​om/message/10151006#10​151006 (external link)

The Lens Profile Panel seems under represented with tutorials on the internet :rolleyes:


Will immaculens.com (external link) gear
Learn to love to do well, and you shall. ~ C. Poseidon

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

569 views & 1 like for this thread
A question about Lightroom lens profile corrections.
FORUMS Post Processing, Marketing & Presenting Photos RAW, Post Processing & Printing 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is eyecancu
794 guests, 400 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.