Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Other Digital Cameras Olympus Digital Cameras
Thread started 06 Feb 2018 (Tuesday) 15:43
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

Firmware update

 
racketman
Cream of the Crop
racketman's Avatar
20,698 posts
Gallery: 12 photos
Joined Oct 2005
Richmond Surrey
Feb 06, 2018 15:43 |  #1

Trying to use Olympus Digital Camera Updater to update firmware on EM-1 MKII from 1.0 to 1.4 but getting message 'failed to communicate with camera" iMac running with High Sierra 10.13.3
Assuming Olympus hasn't caught up with the iMac is there a workaround?


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
Jerry ­ Coupe
Member
Joined Mar 2013
Kent, WA
Feb 07, 2018 00:21 |  #2

Do you have a good photo dealer nearby. Perhaps they would do the update for you.




LOG IN TO REPLY
racketman
THREAD ­ STARTER
Cream of the Crop
racketman's Avatar
20,698 posts
Gallery: 12 photos
Joined Oct 2005
Richmond Surrey
Feb 07, 2018 13:21 as a reply to Jerry Coupe's post |  #3

Nothing so useful, all boutiques and estate agents round here zzzzzz


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

LOG IN TO REPLY
racketman
THREAD ­ STARTER
Cream of the Crop
racketman's Avatar
20,698 posts
Gallery: 12 photos
Joined Oct 2005
Richmond Surrey
Feb 08, 2018 08:42 |  #4

This worked :-)

We have received the following information which might resolve these issues on some of the computers running on High Sierra.

Please follow these steps to resolve the issues.

1. Download the latest version of the Olympus Viewer 3, from the following link

http://download.olympu​s.cz/ECSC/Viewer/OV3Se​tup.dmg (external link)

2. On the mac, perform the permission operation using the following procedure:

Choose "System Preferences" from the Apple menu

Click "Security & Privacy"

Click the ā€¯Allow" button

If there is no improvement, my best advice is to perform the firmware udate on a computer running on MAC OS 10.12 or earlier, or any computer running on Windows .


Toby
6D, 80D, 100D & Olympus EM-1 MKII
Flickr collections (external link)
Gear

LOG IN TO REPLY
Quadna71
Senior Member
Quadna71's Avatar
371 posts
Joined Mar 2012
Feb 10, 2018 15:38 |  #5

I have 10.13.3 on my Macbook and had no problems going from 1.0 to 1.4 last night on my mark II. Are you using the included USB-C cable to connect up?


6D | 50/1.4 | 40/2.8

LOG IN TO REPLY
MCAsan
Goldmember
MCAsan's Avatar
3,672 posts
Joined Jun 2010
Atlanta
Post has been edited 2 days ago by MCAsan.
Feb 20, 2018 08:42 |  #6

Zero problem doing updates to our E-M1 II bodies running High Sierra on our iMacs. Will be doing another firmware upgrade to version 2 on Feb 28.




LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)

176 views & 1 like for this thread
Firmware update
FORUMS Other Digital Cameras Olympus Digital Cameras


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00085 for 4 database queries.
PAGE COMPLETED IN 0.02s
Latest registered member is dkiom
1059 guests, 484 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017