Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon EF and EF-S Lenses
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 8th of January 2007 (Mon)   #1
ps2user
Member
 
ps2user's Avatar
 
Join Date: Dec 2005
Posts: 107
Unhappy 50mm F/1.4 Broken again!!!! But good news :)

My 50mm has broken again!!!! This time the focus doesn't work at all and when turning the manual focus dial the distance scale doesn't move and i can't achieve anything in focus Luckily its still in warranty.

Taken to my local Jessops store to explain the problem and to show the previous warranty repair documentation. Luckily the guy working said they just replace it for a new one and let me try out the lens to be happy. Was more than happy as i didn't have to wait for the lens to be repaired He even printed me out a new reciept to show that the lens has been replaced and that i would have another 12months warranty

Hopefully this lens will be ok and will not break.
__________________
Canon 5D Body
Canon 16-35 L, 50 L, 85 L MK1, 24-105 L IS, Canon Speedlite 550EX
Sigma 70-200 Macro
ps2user is offline   Reply With Quote
This ad block will go away when you log in as member
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Good bag news Bad bag news g_robins Accessories & Storage 5 29th of June 2007 (Fri) 12:49
Good news (I think) ? Broncobear The Business of Photography 7 14th of December 2006 (Thu) 15:16
My broken 50mm f/1.4 ps2user Canon EF and EF-S Lenses 3 16th of October 2006 (Mon) 02:34
30D - Good News, Bad News (not about the camera!) & A Question! nitsch Canon EOS Digital Cameras 17 18th of March 2006 (Sat) 10:21
Good news and bad news. dewmuw RAW, Post Processing and Printing 8 18th of January 2005 (Tue) 09:52


All times are GMT -5. The time now is 16:21.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.