Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
Thread started 27 Jan 2007 (Saturday) 21:33
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

G3 Troubleshoting

 
Andy ­ T
Hatchling
3 posts
Joined Jan 2007
     
Jan 27, 2007 21:33 |  #1

Everything on my G3 seems to be working except the phtoto sensor. But I don't understand why or what to do about it.

I hadn't used my G3 in 36 months or so, but had kept it plugged into the ac adapter. I tried to use it recently and the camera didn't come all the way on. The battery meter said the battery wasn't fully charged. As the battery was original, I figured it had taken a set and needed to be replaced. So I bought a new battery, charged it up for 24 hrs, and started the camera. It came on and the battery meter said it was fully charged. But there's no image on the LCD when in the shooting mode.

I can scroll through all the lists and functions and menus just fine on the LCD screen. The flash goes off when I press the shutter all the way down. I can see pictures from the memory card fine in the review mode. The camera takes a picture (there's a file on the memory card after pressing the shutter) but its pitch black.

I've updated the firmware to no effect.

Does anybody have any thoughts on what happened to my camera? And if there's anything I can do to fix it?

Thanks,




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Pamela107
Senior Member
Avatar
320 posts
Joined Nov 2003
Location: S.East , Michigan
     
Jan 27, 2007 22:25 |  #2

Andy

Try this thread
www.photography-on-the.net/forum/showthre​ad.php?t=47102&highlig​ht=g3+lcd+broken
There are 2 spindles of wires, one or both could be loose or off.
Ive had this happen 3 times to my LCD screen


Canon Rebel XT
Canon 50 1.4
Canon 70-200 4L
Mamiya 645 Pro
www.exposedimages.net (external link)

  
  LOG IN TO REPLY
Andy ­ T
THREAD ­ STARTER
Hatchling
3 posts
Joined Jan 2007
     
Jan 27, 2007 23:22 as a reply to  @ Pamela107's post |  #3

Pamela,

Thanks for the reply and digging up the links.

Unless I'm missing something, I don't think I have the same problem. My LCD seems to work fine when given something to show. When I turn the camera on the blue screen with the Canon logo comes right up. When I switch to the review mode, old files on my memory card come up just fine. When I'm in the shooting mode, I can bring up the various menus and settings on the LCD OK. There's just no "picture" there-just black. As if the lense cap was still on (its not though. I'm sure.). When I "take" a picture the flash goes off, I hear a mechanical noise as if the shutter moved and the file counter goes up. The file is just a sea of black though.

Without understanding what actually goes on inside the camera, I'd describe the problem as seeming as though light isn't getting through the lens to the photo sensor.




  
  LOG IN TO REPLY
andrewaaa5
Goldmember
Avatar
1,225 posts
Joined Sep 2004
Location: scandinavia
     
Jan 28, 2007 05:21 |  #4

it sounds an obvious answer, but have you tried press the 'display' button once whilst in shooting mode? On the G3, you can cycle between showing a preview and not showing a preview by pressing the 'display' button.

NB: This feature is good if you want to save battery by turning the LCD off during shooting mode.


andrew crighton
website -- > www.butterpeanut.com (external link)
flickr -- > flickr/photos/andrewaa​a5 (external link)

  
  LOG IN TO REPLY
praetorion
Hatchling
1 post
Joined Jan 2007
     
Jan 28, 2007 08:53 as a reply to  @ andrewaaa5's post |  #5

Andy T, my G3 is having the same problem too. It was fine all this while and suddenly everything become black. It seems that my lense is broken inside as it is not getting any light pass through and I can take picture and even view images on the memory card, but all picture taken is black. I wonder if it is just some part got loose inside the camera or require to replace the whole lense.

my G3 is 3 yrs old and I wouldnt want to spend a fortune just to replace the lense.

has anyone else experience this before?




  
  LOG IN TO REPLY
Andy ­ T
THREAD ­ STARTER
Hatchling
3 posts
Joined Jan 2007
     
Jan 28, 2007 09:55 as a reply to  @ andrewaaa5's post |  #6

That's not it. When in a shooting mode, I can have things like the focus zone be on the LCD. Pressing the display buttom wipes them off. Pressing display again brings them back.

Thanks for the thought.




  
  LOG IN TO REPLY
peatyard2
Hatchling
1 post
Joined Aug 2005
     
Mar 23, 2007 22:15 as a reply to  @ Andy T's post |  #7

My G3 is also about 3 yrs+ old. Lcd shows fine, AE focus fine can capture picture,
however it is overexposed to white. Tried various settings, same results.
Does CCd eventually go bad? This Canon has been crap since new.




  
  LOG IN TO REPLY
Granite1
Junior Member
27 posts
Joined Mar 2007
Location: Scotland
     
Mar 28, 2007 21:06 |  #8

I've had my G3 since 2003 and its still ticking over nicely. Not used much now though since I upgraded to an XT. Can't help with OP's problem, sorry!




  
  LOG IN TO REPLY
mattjs
Member
114 posts
Joined Jun 2003
Location: Boston, MA USA
     
Mar 29, 2007 09:33 as a reply to  @ Granite1's post |  #9

I would try the wires even if you think that might not be it. A number of people (including me) had simillar problems with the G3 LCDs and that was the fix. If nothing else, you're not gonna hurt the camera for having tried that, and the only other option is to send it in to Canon for repair, which is going cost $200 bucks or so. You've got nothing to lose by opening it up, and it's easy to do.


- Matt
http://www.flickr.com/​photos/dmspics (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,709 views & 0 likes for this thread
G3 Troubleshoting
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.0forum software
version 2.0 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is henkbriek
747 guests, 267 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.