Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon EOS Digital Cameras
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 14th of January 2008 (Mon)   #1
Raphael V
Member
 
Raphael V's Avatar
 
Join Date: Nov 2006
Location: Karkala, Karnataka, India.
Posts: 421
Default 40D Error 99

My 40D stops after a few images, displays a message saying Error 99, Please switch off and on or reinsert the battery. After doing this it takes a few images, stops again with the same message.
What could be wrong?
__________________
7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.com/pages/Life-Digitals/346091085474493
Raphael V is offline   Reply With Quote
This ad block will go away when you log in as member
Old 14th of January 2008 (Mon)   #2
PAFC2004
Senior Member
 
PAFC2004's Avatar
 
Join Date: Mar 2006
Location: Adelaide, Australia
Posts: 1,084
Default Re: 40D Error 99

Have you tried taking off the lens and cleaning the contacts on the lens/camera?
__________________
Canon 5D MKii |Canon 350D | EF 17-40L | EF 70-200 2.8L | 580EX II | 430EX | EF 1.4x T/C II | EF 50 1.8II | Q6600 + 8800 Ultra
PAFC2004 is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #3
Raphael V
Member
 
Raphael V's Avatar
 
Join Date: Nov 2006
Location: Karkala, Karnataka, India.
Posts: 421
Default Re: 40D Error 99

No, I didn't do it. I thought it might be something with the battery.
__________________
7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.com/pages/Life-Digitals/346091085474493
Raphael V is offline   Reply With Quote
This ad block will go away when you log in as member
Old 14th of January 2008 (Mon)   #4
braduardo
Goldmember
 
braduardo's Avatar
 
Join Date: Jun 2006
Location: Minneapolis, MN
Posts: 2,629
Default Re: 40D Error 99

ERR 01 is actually the lens contacts for the 40D. I got that one plus ERR 99 repeatedly before my 40D died and wouldn't work with any lens. Yours probably isn't that big of a deal, but keep your eyes open to the condtions your problems arise in.
__________________
----Brad----
www.nybergstudio.com
40D: EF 17-40 f4 L ---- EF 70-200mm f4 L ---- EF 50mm f1.4 ---- EF 85mm f1.8
braduardo is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #5
Raphael V
Member
 
Raphael V's Avatar
 
Join Date: Nov 2006
Location: Karkala, Karnataka, India.
Posts: 421
Default Re: 40D Error 99

allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?
__________________
7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.com/pages/Life-Digitals/346091085474493
Raphael V is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #6
Performa01
Member
 
Performa01's Avatar
 
Join Date: Aug 2007
Location: Austria
Posts: 340
Default Re: 40D Error 99

Quote:
Originally Posted by Raphael V View Post
allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?
No, you should get a diagnosis first

What lens did you use?
Has the problem occurred with other lenses too if yes, which one?

If you only use a single lens that stays on the body all the time, then taking off and reinstalling the lens might be all you have to do.
Performa01 is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #7
gjl711
human (barely) and bribable
 
gjl711's Avatar
 
Join Date: Aug 2006
Location: Deep in the heart of Texas
Posts: 47,625
Default Re: 40D Error 99

I hate ERR99s. They suck. Anyway, I would contact Canon service right away and they will walk you through some simple debugging you can try before sending it in for service. I would definitely get it serviced while it is on warranty as ERR99 can get much worse over time. I had 4 and to Canons credit they stuck with it until all were taken care of but one lens did take three separate trips back to Canon service before they got it working.
__________________
Not sure why, but call me JJ.

I wondered why the baseball was getting bigger, then it hit me
.
::Flickr::
::Gear::
gjl711 is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #8
Jon
Moderator

Cocker Spaniel Mod

 
Jon's Avatar
 
Join Date: Jun 2004
Location: Bethesda, MD USA
Posts: 67,624
Default Re: 40D Error 99

ERR99 is a catch-all, I'm afraid. Do you have access to multiple lenses you can try the camera with to see if the problem might be with one particular lens? If you bought it from a local retailer, they may let you try a few shots with a lens from stock. They may have a spare or demo body that you can try your lens on as well. That's one thing that Canon will want you to try if possible before sending it in.

These "few images" - are they in quick succession (before the camera's had a chance to write everything to card), or just any combination of a few shots over any duration? If the former, do you have another card you can try?
__________________
Jon
----------

Cocker Spaniels
Maryland and Virginia activities


Image Posting Rules
and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
Jon is offline   Reply With Quote
Old 14th of January 2008 (Mon)   #9
rockfordhx
Member
 
rockfordhx's Avatar
 
Join Date: Jul 2007
Location: US
Posts: 694
Default Re: 40D Error 99

I had ERR 99 on my XTI and it just kept getting worst. I finally sent it in to Canon and they replaced the main board. If it is getting worst just send it in while it is under warranty.
__________________

rockfordhx is offline   Reply With Quote
Old 15th of January 2008 (Tue)   #10
Raphael V
Member
 
Raphael V's Avatar
 
Join Date: Nov 2006
Location: Karkala, Karnataka, India.
Posts: 421
Default Re: 40D Error 99

I have other lenses and memory cards. This thing happened with lens supplied with the camera. I wiped the lense contacts clean, cleaned the battery contacts, removed, reinserted and formatted the CF card, took out the time keeping battery for a whole 10 minutes for the camera to reset.
After this I have shot almost 300 images and this problem did not come back. Hope it won't.
Thanks everyone.
__________________
7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.com/pages/Life-Digitals/346091085474493
Raphael V is offline   Reply With Quote
Old 15th of January 2008 (Tue)   #11
khaz
Member
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 147
Default Re: 40D Error 99

I had an Error 99 on my 40D on the second shot I took with it. It started to click in the front of the body when the flash was enabled, and would not take the shot. I was told that the flash was bad, and that since it was on the first day, the store swapped it out no problem.
__________________
Kevin

Just trying to get better!
khaz is offline   Reply With Quote
Old 15th of January 2008 (Tue)   #12
Rob Wasley
Junior Member
 
Rob Wasley's Avatar
 
Join Date: Jan 2008
Location: Holland Landing, Ontario, Canada
Posts: 8
Default Re: 40D Error 99

I wonder how common this is throughout their product line - my XTi is 18 days old and suffering the same problem. I'm back to the retailer to discuss my options.....exchange for a new body?? I don't have that warm & fuzzy feeling...
Rob Wasley is offline   Reply With Quote
Old 15th of January 2008 (Tue)   #13
arrgeebee
Member
 
arrgeebee's Avatar
 
Join Date: Jul 2007
Location: Rhode Island
Posts: 835
Default Re: 40D Error 99

Quote:
Originally Posted by Raphael V View Post
allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?
I had it happen to me a few times. I took everything out (CF, Lens, Battery) & put it all back together. Haven't seen error 99 in 3 months now.
__________________
Bob

My Gallery - My Gear
arrgeebee is offline   Reply With Quote
Old 15th of January 2008 (Tue)   #14
gjl711
human (barely) and bribable
 
gjl711's Avatar
 
Join Date: Aug 2006
Location: Deep in the heart of Texas
Posts: 47,625
Default Re: 40D Error 99

Quote:
Originally Posted by Rob Wasley View Post
I wonder how common this is throughout their product line - my XTi is 18 days old and suffering the same problem. I'm back to the retailer to discuss my options.....exchange for a new body?? I don't have that warm & fuzzy feeling...
It's not always the body. Early on I had 4 separate ERR99 issues spread across three different devices. One turned out to be the body but the other three were with two lenses. The good news is Canon stuck with it for almost 4 months until all the equipment was ERR99 free. The body and lenses are now over two years old, still in use and have not had a ERR99 since.
__________________
Not sure why, but call me JJ.

I wondered why the baseball was getting bigger, then it hit me
.
::Flickr::
::Gear::
gjl711 is offline   Reply With Quote
Old 16th of January 2008 (Wed)   #15
Rob Wasley
Junior Member
 
Rob Wasley's Avatar
 
Join Date: Jan 2008
Location: Holland Landing, Ontario, Canada
Posts: 8
Default Re: 40D Error 99

Visited the retailer where I purchased it (Henry's Newmarket) and they are set to honour the 21-day exchange by swapping a replacement body. Thanks for all the info here about this.....I'm a d-slr newbie and would not like to be left with a bad taste.......
Rob Wasley is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody have Error 99 Issues with their 40D? thewavebb Canon EOS Digital Cameras 75 13th of September 2010 (Mon) 20:32
First error code with my 40D!! Bbryan5 Canon EOS Digital Cameras 10 4th of August 2008 (Mon) 16:58
NEW! 40D and got error 99 roetevs Canon EOS Digital Cameras 47 24th of April 2008 (Thu) 19:30
Error Code 01 on New Canon 40D Hy5 Canon EOS Digital Cameras 11 29th of January 2008 (Tue) 08:59
40D ERROR 6 Message Today M24 Canon EOS Digital Cameras 4 8th of October 2007 (Mon) 04:12


All times are GMT -5. The time now is 04:59.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.