Index  •   • New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras
Thread started 14 Jan 2008 (Monday) 05:27
PREV/NEXT

40D Error 99

 
Raphael ­ V
Senior Member
Raphael V's Avatar
421 posts

Joined Nov 2006

Karkala, Karnataka, India.
MORE INFO

My 40D stops after a few images, displays a message saying Error 99, Please switch off and on or reinsert the battery. After doing this it takes a few images, stops again with the same message.
What could be wrong?

Jan 14, 2008 05:27

7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.co​m ...-Digitals/3460910854744​93external link

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
PAFC2004
Goldmember
PAFC2004's Avatar
1,084 posts

Joined Mar 2006

Adelaide, Australia
MORE INFO

Have you tried taking off the lens and cleaning the contacts on the lens/camera?

Jan 14, 2008 05:30

Canon 5D MKii |Canon 350D | EF 17-40L | EF 70-200 2.8L | 580EX II | 430EX | EF 1.4x T/C II | EF 50 1.8II | Q6600 + 8800 Ultra

LOG IN TO REPLY
Raphael ­ V
THREAD ­ STARTER
Senior Member
Raphael V's Avatar
421 posts

Joined Nov 2006

Karkala, Karnataka, India.
MORE INFO

No, I didn't do it. I thought it might be something with the battery.

Jan 14, 2008 05:33

7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.co​m ...-Digitals/3460910854744​93external link

LOG IN TO REPLY
braduardo
Goldmember
braduardo's Avatar
2,629 posts

Joined Jun 2006

Minneapolis, MN
MORE INFO

ERR 01 is actually the lens contacts for the 40D. I got that one plus ERR 99 repeatedly before my 40D died and wouldn't work with any lens. Yours probably isn't that big of a deal, but keep your eyes open to the condtions your problems arise in.

Jan 14, 2008 05:35

:rolleyes: ----Brad---- :rolleyes:
www.nybergstudio.comexternal link
40D: EF 17-40 f4 L ---- EF 70-200mm f4 L ---- EF 50mm f1.4 ---- EF 85mm f1.8

LOG IN TO REPLY
Raphael ­ V
THREAD ­ STARTER
Senior Member
Raphael V's Avatar
421 posts

Joined Nov 2006

Karkala, Karnataka, India.
MORE INFO

allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?

Jan 14, 2008 05:52

7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.co​m ...-Digitals/3460910854744​93external link

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
Performa01
Senior Member
Performa01's Avatar
340 posts

Joined Aug 2007

Austria
MORE INFO

Raphael V wrote in post #4699298external link
allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?

No, you should get a diagnosis first ;-)a

What lens did you use?
Has the problem occurred with other lenses too – if yes, which one?

If you only use a single lens that stays on the body all the time, then taking off and reinstalling the lens might be all you have to do.

Jan 14, 2008 06:14



LOG IN TO REPLY
gjl711
human (barely) and bribable
gjl711's Avatar
48,477 posts

Joined Aug 2006

Deep in the heart of Texas
MORE INFO

I hate ERR99s. They suck. Anyway, I would contact Canon service right away and they will walk you through some simple debugging you can try before sending it in for service. I would definitely get it serviced while it is on warranty as ERR99 can get much worse over time. I had 4 and to Canons credit they stuck with it until all were taken care of but one lens did take three separate trips back to Canon service before they got it working.

Jan 14, 2008 10:27

Not sure why, but call me JJ.
I wondered why the baseball was getting bigger, then it hit me
.
::Flickr::external link
::Gear::

LOG IN TO REPLY
Jon
Moderator

Cocker Spaniel Mod

Jon's Avatar
68,445 posts

Joined Jun 2004

Bethesda, MD USA
MORE INFO

ERR99 is a catch-all, I'm afraid. Do you have access to multiple lenses you can try the camera with to see if the problem might be with one particular lens? If you bought it from a local retailer, they may let you try a few shots with a lens from stock. They may have a spare or demo body that you can try your lens on as well. That's one thing that Canon will want you to try if possible before sending it in.

These "few images" - are they in quick succession (before the camera's had a chance to write everything to card), or just any combination of a few shots over any duration? If the former, do you have another card you can try?

Jan 14, 2008 12:22

Jon
----------
Cocker Spaniels
Maryland and Virginia activities
Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE

LOG IN TO REPLY
rockfordhx
Senior Member
rockfordhx's Avatar
694 posts

Joined Jul 2007

US
MORE INFO

I had ERR 99 on my XTI and it just kept getting worst. I finally sent it in to Canon and they replaced the main board. If it is getting worst just send it in while it is under warranty.

Jan 14, 2008 13:31

http://www.nathan-photo.comexternal link

LOG IN TO REPLY
Raphael ­ V
THREAD ­ STARTER
Senior Member
Raphael V's Avatar
421 posts

Joined Nov 2006

Karkala, Karnataka, India.
MORE INFO

I have other lenses and memory cards. This thing happened with lens supplied with the camera. I wiped the lense contacts clean, cleaned the battery contacts, removed, reinserted and formatted the CF card, took out the time keeping battery for a whole 10 minutes for the camera to reset.
After this I have shot almost 300 images and this problem did not come back. Hope it won't.
Thanks everyone.

Jan 15, 2008 05:52

7D, 40D, 450D, EF17-40 f4L, EF24-105 f4L, EF-S10-22, EF-S18-135, EF-S18-55, EF-S18-55 IS, Sigma 24-70 f2.8, Sigma 17-70 f2.8-4, Sigma 70-300 DG 4-5.6, Vivitar f3.5 7mm Fisheye, 580 EXII, 430 EX, Olympus OM System, Vivitar 285HV, Legria HF G10, Panasonic HMC82EN.
"Men have become the tools of their tools" - Henry David Thoreau.s.
nhttp://www.facebook.co​m ...-Digitals/3460910854744​93external link

LOG IN TO REPLY
khaz
Member
147 posts
Joined Jan 2008

San Diego, CA
MORE INFO

I had an Error 99 on my 40D on the second shot I took with it. It started to click in the front of the body when the flash was enabled, and would not take the shot. I was told that the flash was bad, and that since it was on the first day, the store swapped it out no problem.

Jan 15, 2008 18:30

Kevin

Just trying to get better!

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
Rob ­ Wasley
Hatchling
Rob Wasley's Avatar
8 posts

Joined Jan 2008

Holland Landing, Ontario, Canada
MORE INFO

I wonder how common this is throughout their product line - my XTi is 18 days old and suffering the same problem. I'm back to the retailer to discuss my options.....exchange for a new body?? I don't have that warm & fuzzy feeling...

Jan 15, 2008 19:58 as a reply to khaz's post 1 hour earlier.



LOG IN TO REPLY
arrgeebee
Senior Member
arrgeebee's Avatar
835 posts

Joined Jul 2007

Rhode Island
MORE INFO

Raphael V wrote in post #4699298external link
allright, that is something to worry about. Now should I wait for the camera to die or should I send it for service?

I had it happen to me a few times. I took everything out (CF, Lens, Battery) & put it all back together. Haven't seen error 99 in 3 months now.

Jan 15, 2008 20:05

Bob
http://photography-on-the.net/forum/showthre​ad.php?t=469159
My Galleryexternal link - My Gear

LOG IN TO REPLY
gjl711
human (barely) and bribable
gjl711's Avatar
48,477 posts

Joined Aug 2006

Deep in the heart of Texas
MORE INFO

Rob Wasley wrote in post #4711615external link
I wonder how common this is throughout their product line - my XTi is 18 days old and suffering the same problem. I'm back to the retailer to discuss my options.....exchange for a new body?? I don't have that warm & fuzzy feeling...

It's not always the body. Early on I had 4 separate ERR99 issues spread across three different devices. One turned out to be the body but the other three were with two lenses. The good news is Canon stuck with it for almost 4 months until all the equipment was ERR99 free. The body and lenses are now over two years old, still in use and have not had a ERR99 since.

Jan 15, 2008 20:24

Not sure why, but call me JJ.
I wondered why the baseball was getting bigger, then it hit me
.
::Flickr::external link
::Gear::

LOG IN TO REPLY
Rob ­ Wasley
Hatchling
Rob Wasley's Avatar
8 posts

Joined Jan 2008

Holland Landing, Ontario, Canada
MORE INFO

Visited the retailer where I purchased it (Henry's Newmarket) and they are set to honour the 21-day exchange by swapping a replacement body. Thanks for all the info here about this.....I'm a d-slr newbie and would not like to be left with a bad taste.......

Jan 16, 2008 21:16 as a reply to gjl711's post 1 day earlier.



LOG IN TO REPLY

78,823 views & 0 likes for this thread
40D Error 99
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras

NOT A MEMBER YET? CLICK HERE TO REGISTER TO THE FORUMS
Registered members get all the features: search, more forums, private messaging, thread follow, notifications, own gallery, own reviews...




SEND FEEDBACK TO STAFF    •   JUMP TO FORUM    •   FORUM RULES    •   Index    •   New Posts    •   RTAT    •   "Best Of"    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: By using this site you agree that some cookies will be stored on your browser. For unlogged users we store one session id cookie. For registered members we store (in addition to login session cookie) only cookies that are essential for required functionality. We do not store any personal tracking data in cookies or other browsers' data storage methods.

POWERED BY AMASS 1.1version 1.1
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00352 for 4 database queries.
PAGE COMPLETED IN 0.03s
Latest registered member is jbenf
766 guests, 816 members online
Simultaneous users record so far is 3341, that happened on Dec 11, 2014