Index  •   • New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras
Thread started 10 Jan 2005 (Monday) 10:26
PREV/NEXT

Power-On problems with G5

 
grapar
Hatchling
2 posts
Joined Jan 2005

Ljubljana
MORE INFO

I have digital camera G5 with serious problems with power. Camera is not responding when i try to swich it on. After multiple atempts to reinsert batery and press power On switch (left or right) camera sometimes switches on, but it can take 10 or more times (removing and inserting the battery) to respond.
What do you think could be wrong with my camera? When turned on, it istarts working OK, but after several minutes it loses power and shuts down, sometimes with objective (lens) pulled out. I think that the problem has something to do with power.
I tryed with fully charged battery from another G5, but it didnt make much difference. I am intending to take the camera to service.
Is it possible that something is wrong with firmware? I have instaled version 2.0.0.0. Is it possible to restore it to previous firmware (original), if it is, please tell me how to do it and where to get this original firmware?

Thanks
Gregor

Jan 10, 2005 10:26



LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
Ballen ­ Photo
Moderator
Ballen Photo's Avatar
18,722 posts

Joined Nov 2003

Southern Nevada
MORE INFO

grapar wrote:
I have digital camera G5 with serious problems with power. Camera is not responding when i try to swich it on. After multiple atempts to reinsert batery and press power On switch (left or right) camera sometimes switches on, but it can take 10 or more times (removing and inserting the battery) to respond.
What do you think could be wrong with my camera? When turned on, it istarts working OK, but after several minutes it loses power and shuts down, sometimes with objective (lens) pulled out. I think that the problem has something to do with power.
I tryed with fully charged battery from another G5, but it didnt make much difference. I am intending to take the camera to service.
Is it possible that something is wrong with firmware? I have instaled version 2.0.0.0. Is it possible to restore it to previous firmware (original), if it is, please tell me how to do it and where to get this original firmware?

Thanks
Gregor

Gregor, I'm certainly no expert, but from your description, it sounds like your battery is not making good contact. :shock:
You might try cleaning the contacts with an eraser on a pencil. It will reach inside the battery compartment(Clean the contacts on the battery too). Also, make sure none of the contacts are bent or lower than the rest.
Good luck with this problem.
-Bruce

Jan 10, 2005 10:48

The Captain and crew finally got their stuff together, now if we can only remember where we left it. :cool:
http://c.24zero.comexternal link

LOG IN TO REPLY
grapar
THREAD ­ STARTER
Hatchling
2 posts
Joined Jan 2005

Ljubljana
MORE INFO

Ballen Photo wrote:
Gregor, I'm certainly no expert, but from your description, it sounds like your battery is not making good contact. :shock:
You might try cleaning the contacts with an eraser on a pencil. It will reach inside the battery compartment(Clean the contacts on the battery too). Also, make sure none of the contacts are bent or lower than the rest.
Good luck with this problem.
-Bruce

I tried like you sad, but it's not working!
Thanks, Gregor

Jan 11, 2005 14:16 as a reply to Ballen Photo's post 1 day earlier.



LOG IN TO REPLY
jaysmith
Hatchling
5 posts
Joined Sep 2004
MORE INFO

I have this exact same problem, it just started after using the camera for 11 months with no problems. Did you solve the problem, I would love to know if you fixed it or not.
Many thanks

Mar 01, 2005 14:15



LOG IN TO REPLY

1,707 views & 0 likes for this thread
Power-On problems with G5
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras

NOT A MEMBER YET? CLICK HERE TO REGISTER TO THE FORUMS
Registered members get all the features: search, more forums, private messaging, thread follow, notifications, own gallery, own reviews...




SEND FEEDBACK TO STAFF    •   JUMP TO FORUM    •   FORUM RULES    •   Index    •   New Posts    •   RTAT    •   "Best Of"    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: By using this site you agree that some cookies will be stored on your browser. For unlogged users we store one session id cookie. For registered members we store (in addition to login session cookie) only cookies that are essential for required functionality. We do not store any personal tracking data in cookies or other browsers' data storage methods.

POWERED BY AMASS 1.1version 1.1
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00111 for 4 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is dcottle1
887 guests, 870 members online
Simultaneous users record so far is 3341, that happened on Dec 11, 2014