Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon G-series Digital Cameras
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 10th of January 2005 (Mon)   #1
grapar
Junior Member
 
Join Date: Jan 2005
Location: Ljubljana
Posts: 2
Default Power-On problems with G5

I have digital camera G5 with serious problems with power. Camera is not responding when i try to swich it on. After multiple atempts to reinsert batery and press power On switch (left or right) camera sometimes switches on, but it can take 10 or more times (removing and inserting the battery) to respond.
What do you think could be wrong with my camera? When turned on, it istarts working OK, but after several minutes it loses power and shuts down, sometimes with objective (lens) pulled out. I think that the problem has something to do with power.
I tryed with fully charged battery from another G5, but it didnt make much difference. I am intending to take the camera to service.
Is it possible that something is wrong with firmware? I have instaled version 2.0.0.0. Is it possible to restore it to previous firmware (original), if it is, please tell me how to do it and where to get this original firmware?

Thanks
Gregor

Last edited by grapar : 10th of January 2005 (Mon) at 10:29.
grapar is offline   Reply With Quote
This ad block will go away when you log in as member
Old 10th of January 2005 (Mon)   #2
Ballen Photo
Moderator
 
Ballen Photo's Avatar
 
Join Date: Nov 2003
Location: Southern Nevada
Posts: 18,535
Default Re: Power-On problems with G5

Quote:
Originally Posted by grapar
I have digital camera G5 with serious problems with power. Camera is not responding when i try to swich it on. After multiple atempts to reinsert batery and press power On switch (left or right) camera sometimes switches on, but it can take 10 or more times (removing and inserting the battery) to respond.
What do you think could be wrong with my camera? When turned on, it istarts working OK, but after several minutes it loses power and shuts down, sometimes with objective (lens) pulled out. I think that the problem has something to do with power.
I tryed with fully charged battery from another G5, but it didnt make much difference. I am intending to take the camera to service.
Is it possible that something is wrong with firmware? I have instaled version 2.0.0.0. Is it possible to restore it to previous firmware (original), if it is, please tell me how to do it and where to get this original firmware?

Thanks
Gregor
Gregor, I'm certainly no expert, but from your description, it sounds like your battery is not making good contact.
You might try cleaning the contacts with an eraser on a pencil. It will reach inside the battery compartment(Clean the contacts on the battery too). Also, make sure none of the contacts are bent or lower than the rest.
Good luck with this problem.
-Bruce
__________________
The Captain and crew finally got their stuff together, now if we can only remember where we left it.

Ballen Photo is offline   Reply With Quote
Old 11th of January 2005 (Tue)   #3
grapar
Junior Member
 
Join Date: Jan 2005
Location: Ljubljana
Posts: 2
Default Re: Power-On problems with G5

Quote:
Originally Posted by Ballen Photo
Gregor, I'm certainly no expert, but from your description, it sounds like your battery is not making good contact.
You might try cleaning the contacts with an eraser on a pencil. It will reach inside the battery compartment(Clean the contacts on the battery too). Also, make sure none of the contacts are bent or lower than the rest.
Good luck with this problem.
-Bruce
I tried like you sad, but it's not working!
Thanks, Gregor
grapar is offline   Reply With Quote
This ad block will go away when you log in as member
Old 1st of March 2005 (Tue)   #4
jaysmith
Junior Member
 
Join Date: Sep 2004
Posts: 5
Default Re: Power-On problems with G5

I have this exact same problem, it just started after using the camera for 11 months with no problems. Did you solve the problem, I would love to know if you fixed it or not.
Many thanks
jaysmith is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loose Battery Door Causes Power Problems Tirzah Canon EOS Digital Cameras 17 28th of September 2006 (Thu) 04:31
Power problems with G5 Matfink Canon G-series Digital Cameras 3 3rd of January 2006 (Tue) 14:15
Tigger and Power problems with 20D!! HELP! MadMesh Canon EOS Digital Cameras 7 7th of July 2005 (Thu) 18:08
Power problems with A75 Whistler Small Compact Digitals by Canon 0 1st of May 2005 (Sun) 05:24
G3 Power Problems? johniem Canon G-series Digital Cameras 6 9th of September 2003 (Tue) 05:47


All times are GMT -5. The time now is 03:42.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.