Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras
Thread started 27 Apr 2009 (Monday) 11:12
Prev/next
sponsored links
(this ad will go away when you log in as registered member)

STICKY: G10 defect: Canon confirms; G10 hardware Recall; Service Notice

 
king ­ benny
Member
king benny's Avatar
88 posts
Joined Mar 2009
Vancouver, Canada
Jul 19, 2009 19:10 |  #76

The serial on mine (#82) falls under the affected ones, but I have had no issues with the pictures I've taken (and I've pixel peeped to be sure). I purchased it back in January.

I have no intentions of sending it in.


http://benandwindy.comexternal link

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
articles3.com
Hatchling
3 posts
Joined Jul 2009
Jul 20, 2009 13:11 |  #77

i read all posts on this forum but still can not make my mind can any one recommend anything.
thank you


Free Articles Directory | Article Submission | Submit Articles
http://www.articles3.c​omexternal link

LOG IN TO REPLY
vondo
Senior Member
374 posts
Joined Jan 2007
Aurora, IL
Aug 06, 2009 14:11 |  #78

udm wrote in post #8177679external link
yes , you can see the lines across the image... i can see lines on most of my RAW pics.

Is your serial number one of the affected ones?

You are the first person I've seen anywhere that is actually affected by this issue. That's too bad. I hope you get it resolved.


Canon 5DMkII, 7D, 40D, Elan 7E, EOS 10s, G12
50 f/1.8, 100 f/2, 400 f/5.6L,
18-55 IS, 24-105 f/4L IS, 70-200 f/4L IS
Kenko 1.4x T-con, 430EX

LOG IN TO REPLY
Rio ­ Sundoro
Member
Rio Sundoro's Avatar
215 posts
Joined Mar 2009
Aug 10, 2009 10:45 |  #79

Do the serial numbers basically indicate which market the product is sold at? Or is it just random?


flickrexternal link | gear

LOG IN TO REPLY
nantycoy
Hatchling
1 post
Joined Aug 2009
Aug 14, 2009 04:08 |  #80

vondo wrote in post #8411698external link
Is your serial number one of the affected ones?

You are the first person I've seen anywhere that is actually affected by this issue. That's too bad. I hope you get it resolved.

My G10 was one of the affected ones - sent it off to Canon (UK) and got it back in 3 days! Checked the firmware: 1.0.4.0

Does anyone out there know what 1.0.3 and 1.0.4 actually fixed?




LOG IN TO REPLY
Heuer
Hatchling
6 posts
Joined Aug 2009
Aug 21, 2009 13:10 as a reply to nantycoy's post |  #81

My G10 went back to one of Canon's UK service centres and took two weeks to be turned around, albeit I had them replace the scratched LCD screen whilst they had it. Now updated with 1.0.4. Maybe me, but the software response seems quicker.




LOG IN TO REPLY
Graeme ­ Ph
Mostly Lurking
12 posts
Joined May 2008
Aug 25, 2009 22:58 |  #82

I have scanned my G10 images (corresponding S/N to the affected examples) carefully but have not found lines a such
One white pixel with four dark pixels at NSE&W in the same location on all images - being one pixel it takes a bit of effort to pick it up though.
Probably not worth the trouble of sending it away at this point. Does the fault increase with time?




LOG IN TO REPLY
brianploop
Mostly Lurking
16 posts
Joined Jan 2010
Jan 22, 2010 18:34 |  #83
banned
SPAM PUT AWAY
This post is marked as spam.
madmanscam
Member
79 posts
Joined Nov 2007
Jun 28, 2010 11:23 |  #84

Hope mine is fine


EOS 5D/ EOD 7D/ EOS 30D / Sigma 10-20 EX F/4-5.6 / Sigma 17-70 F/2.8-4.5 / Canon EF 50mm F/1.8 Mk II / Canon EF 85mm F/1.8 USM / Canon EF 70-200L F/2.8 USM / Sigma 50-500 EX F/4-6.3
Canon 580EX / Lowepro Computrekker Plus AW

LOG IN TO REPLY
susitna
Member
84 posts
Joined Aug 2010
Sydney, Australia
Oct 13, 2010 06:38 |  #85

I have just come across this thread & my camera is in the affected Serial No range. I have had the camera since Feb 2009 & haven't noticed any issues. The only firmware for this camera that I can find on the web is 1.0.2.0 (which I already have). Where is the Version 3 or 4 that people are talking about in this thread??




LOG IN TO REPLY
kmh12345
Member
33 posts
Joined Nov 2010
Jan 04, 2011 19:06 |  #86

I'm glad I stuck with my G7!

---------------
KristeenMarie an Indianapolis Engagement Photographerexternal link


Kristeen Marie Photography an Indianapolis Photographerexternal link |Indianapolis Engagement Photographerexternal link | Indianapolis Newborn Photographerexternal link
www.KristeenMarie.com/​Photography

LOG IN TO REPLY
vondo
Senior Member
374 posts
Joined Jan 2007
Aurora, IL
Jul 10, 2011 16:04 |  #87

kmh12345 wrote in post #11574396external link
I'm glad I stuck with my G7!

Yes, because as you can see this is affecting all of us and has made our G10's worthless for the past two years. </sarcasm>

I'm glad you like your G7 and from what I hear it's a fine camera, but this is really a non-issue for G10 owners.


Canon 5DMkII, 7D, 40D, Elan 7E, EOS 10s, G12
50 f/1.8, 100 f/2, 400 f/5.6L,
18-55 IS, 24-105 f/4L IS, 70-200 f/4L IS
Kenko 1.4x T-con, 430EX

LOG IN TO REPLY
peterbj7
Goldmember
3,123 posts
Joined Oct 2007
A Caribbean island in Belize and occasionally UK
Apr 24, 2012 23:31 |  #88

I have a G10 that is exhibiting a different and intermittent problem. Sometimes it "freezes" mid action, whether that is pushing the lens out, taking a picture, or what. It doesn't happen often but it's infuriating when it does. Before I send it off I wonder if anyone else has had a similar problem. And where in the USA should it be sent?

Yes I know it's an old thread, but it seemed the closest fit.


5D & 7D (both gripped), 24-105L, 100-400L, 15-85, 50 f1.8, Tamron 28-75, Sigma 12-24, G10, EX-Z55 & U/W housing, A1+10 lenses, tripods, lighting gear, etc. etc.
"I prefer radio to television. The pictures are better"

LOG IN TO REPLY
Birdman7
Member
100 posts
Joined Jan 2013
Spain
Feb 03, 2013 09:10 as a reply to peterbj7's post |  #89

No Probs on mine :)


Birdwatching tours
Bird Photography
Digiscoping
Gibraltar, Spain & Morocco
www.aviantours.netexternal link

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)

107,743 views & 0 likes for this thread
G10 defect: Canon confirms; G10 hardware Recall; Service Notice
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras


Not a member yet? Click here to register to the forums.
Registered members get all the features: search, following threads, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, settings, view hosted photos, own reviews and more...


AAA

Send feedback to staff    •   Jump to forum...    •   Rules    •   Index    •   New posts    •   RTAT    •   'Best of'    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Privacy policy and cookie usage info.

POWERED BY AMASS 1.4version 1.4
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.00102 for 4 database queries.
PAGE COMPLETED IN 0.02s
Latest registered member is J4T4lyfe
721 guests, 278 members online
Simultaneous users record so far is 6106, that happened on Jun 09, 2016