Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies. Read More.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 10 Aug 2009 (Monday) 15:59
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

50mm f1.4 autofocus malfunctioning for the third time

 
Christina
Senior Member
Avatar
633 posts
Joined Jan 2007
Location: Pittsburgh
     
Aug 10, 2009 15:59 |  #1

I got this lens in December 2006. In November 2007, the autofocus stopped working and was repaired - fortunately at no cost as it was still under warranty. Then, in the summer of 2008 it malfunctioned again and this time it cost $100 to repair. :confused:

Now it is not working again. I haven't contacted Canon yet but I am sure they will say I have to pay $100 again to have it fixed. So frustrating!

Has anyone had any luck getting a replacement for something that repeatedly has problems like this?


Christina - Pittsburgh Wedding Photographer (external link)
Syncopated Pictures (external link)
http://christinamontem​urrophotography.com/bl​og/ (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
joosay
Goldmember
Avatar
1,325 posts
Joined Jul 2009
Location: City so nice they named it twice
     
Aug 10, 2009 16:39 |  #2

I bought a bad copy (didn't know how to check lens) but my 50 1.4 was not able to focus any closer than 8 feet. What kind of problems are you having with the autofocus?


Flickr (external link) - Angelito Jusay Photography (external link)

  
  LOG IN TO REPLY
JNRSM3
Member
Avatar
229 posts
Joined Jun 2009
     
Aug 10, 2009 16:42 |  #3

sorry to hear. I've only had mine for 3 months, but I've used it alot. So far no issues. Crossing fingers as it is one of my favorite lenses. Ultra sharp.

If this lens has been back to Canon twice already, wouldn't they have record of it? I wonder, if like cars, there is any lemon policy whereby Canon would remunerate for a crap lens with sufficient proof, like in this case, that the lens is just not up to snuff?


Gripped 7D ~EF 17-40 F/4 L ~ EF 24-105 F/4 L ~ EF 70-200 F/4 L IS ~ EF 50 F/1.4 ~ Manfrotto 498RC2/055XPROB ~ Lowepro AW200

  
  LOG IN TO REPLY
Christina
THREAD ­ STARTER
Senior Member
Avatar
633 posts
Joined Jan 2007
Location: Pittsburgh
     
Aug 10, 2009 19:54 |  #4

joosay wrote in post #8434891 (external link)
I bought a bad copy (didn't know how to check lens) but my 50 1.4 was not able to focus any closer than 8 feet. What kind of problems are you having with the autofocus?

Right now, it won't autofocus at all at any distance. The first time it went bad, it would work sometimes but then wouldn't work. Same with the second. Now.... nada.

I had the same thought about the lemon thing but the last time when I asked, they said no to that. :mad:


Christina - Pittsburgh Wedding Photographer (external link)
Syncopated Pictures (external link)
http://christinamontem​urrophotography.com/bl​og/ (external link)

  
  LOG IN TO REPLY
Rio ­ Sundoro
Member
Avatar
215 posts
Joined Mar 2009
     
Aug 11, 2009 01:44 |  #5

There is a small plastic component inside the lens that snapped (broke).


flickr (external link) | gear

  
  LOG IN TO REPLY
Rendition
Member
Avatar
245 posts
Joined Feb 2009
Location: Singapore
     
Aug 11, 2009 03:36 as a reply to  @ Rio Sundoro's post |  #6

Mine stropped working right before warranty ended but I got it replaced with a 1.2..... ya, crazy.... all that spending power just for the sake of a better mechanism. Apart from this common issue, the 1.4 is perfect, just hope Canon's gonna update to a Mark II.

The 1.4 I had just decided to stop working as and when it felt like and once was during a full day wedding session and that freaked me out but thank gawd a day prior, I read somewhere that turning the focus ring to one end, after the 'end', will get the AF working again but would die again intermittently.


// visualverve (external link) //
Canon EOS-1Ds Mark III + WFT-E2 II ❘ 5D Mark II
17-40L ❘ 24-70L ❘ 50L ❘ 70-200 f/2.8LIS ❘ 2X 580EXII ❘ 2X CP-E4
Elinchrom BXRi ❘ Velbon Neo Carmagne 640A

  
  LOG IN TO REPLY
hk300
Senior Member
253 posts
Joined Dec 2007
     
Aug 11, 2009 05:00 |  #7

the mechanics of the 50/1.4 are very easily damaged.

It uses a plastic helicoid and plastic tabs, which can deform and/or break easily.




  
  LOG IN TO REPLY
Christina
THREAD ­ STARTER
Senior Member
Avatar
633 posts
Joined Jan 2007
Location: Pittsburgh
     
Aug 11, 2009 10:11 as a reply to  @ hk300's post |  #8

So... if you were me... would you bother to pay to have it replaced? If I did... I would probably sell it - but I have no idea how to price something like this as I would certainly provide full disclosure about its history.


Christina - Pittsburgh Wedding Photographer (external link)
Syncopated Pictures (external link)
http://christinamontem​urrophotography.com/bl​og/ (external link)

  
  LOG IN TO REPLY
hk300
Senior Member
253 posts
Joined Dec 2007
     
Aug 11, 2009 10:31 |  #9

i would probably go to a independent repair shop and depending on the actual repair cost, either sell it as-is or sell it repaired... it could be a simple repair.




  
  LOG IN TO REPLY
joosay
Goldmember
Avatar
1,325 posts
Joined Jul 2009
Location: City so nice they named it twice
     
Aug 11, 2009 10:53 |  #10

Mine is on the way to canon factory service in nj... you got it replaced with a 1.2? I wish they would do that in my situation....lol but probably highly unlikely because its out of warranty and paying $95 for the repair.


Flickr (external link) - Angelito Jusay Photography (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,664 views & 0 likes for this thread
50mm f1.4 autofocus malfunctioning for the third time
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is AndieLosAngeles
836 guests, 429 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.