Canon Digital Photography Forums  

Go Back   Canon Digital Photography Forums > 'Equipment Talk' section > Canon EF and EF-S Lenses
Register Rules FAQ Members List Search Today's Posts Mark Forums Read



Reply
 
Thread Tools Display Modes
Old 25th of November 2009 (Wed)   #1
dirtdiver
Junior Member
 
Join Date: Jun 2009
Posts: 13
Default Canon L 100-400 lens error

All, I just got a canon L 100-400 lens from BH. I took about 100 pictures with it the other day and I got a handfull of instances where the focus/shutter would lock up and I would get a error message on myT1i. It said something about a communication error try cleaning the contacts and try again. The camera is a few months old and the lens is brand new. I would turn the camera off and it would work again. Any thoughts?

steve
dirtdiver is offline   Reply With Quote
This ad block will go away when you log in as member
Old 25th of November 2009 (Wed)   #2
dmccabe
User is banned from forums
 
Join Date: Feb 2009
Posts: 205
Default Re: Canon L 100-400 lens error

Sounds like dirty connections Did you try cleaning them with alcohol. You can use regular lens cleaner wraps too.
dmccabe is offline   Reply With Quote
Old 25th of November 2009 (Wed)   #3
dirtdiver
Junior Member
 
Join Date: Jun 2009
Posts: 13
Default Re: Canon L 100-400 lens error

Quote:
Originally Posted by dmccabe View Post
Sounds like dirty connections Did you try cleaning them with alcohol. You can use regular lens cleaner wraps too.
I actually did not try to clean them thinking everything was new and factory clean. I still think that dirty is a stretch. Is this a common error?
dirtdiver is offline   Reply With Quote
This ad block will go away when you log in as member
Old 25th of November 2009 (Wed)   #4
dirtdiver
Junior Member
 
Join Date: Jun 2009
Posts: 13
Default Re: Canon L 100-400 lens error

Also I have never had this error on any of my other lenses. steve
dirtdiver is offline   Reply With Quote
Old 25th of November 2009 (Wed)   #5
tvphotog
Cream of the Crop
 
tvphotog's Avatar
 
Join Date: Aug 2007
Location: New York City
Posts: 5,692
Default Re: Canon L 100-400 lens error

Call B&H and simply return it and exchange it for another. A new lens should not have dirty contact points, but check your camera's contacts. A simple pencil eraser should clean them. But if other lenses work with the body, it's the 100-400. If it's within 15 days and you have all the papers and wrappings, there will be no questions asked. That's the advantage of dealing with them.
__________________
Jay
"Ireland in Word and Image" Jay Ben Images 5D III | 5D II | 7D | Powershot S100 | 24-105L | 100-400L | 16-35 f/2.8L II | 24 T/S f /3.5L II | 17 T/S f/4L | 50mm f/1.2L| 35mm f/1.4L | 580 EX II | 600 EX-RT | Feisol 3441T/Markins lever QR | Gitzo 3542L | Gitzo 5561T
tvphotog is offline   Reply With Quote
Old 27th of November 2009 (Fri)   #6
Tdragone
Goldmember
 
Tdragone's Avatar
 
Join Date: Sep 2004
Location: San Diego, California
Posts: 2,186
Default Re: Canon L 100-400 lens error

All metals that aren't 100% gold oxidize.. Even a newly bought lens' contacts could be slightly dirty.
use a soft pencil eraser on the lens contacts and then try again. If it still errors; then I agree to send it back.
My 50 1.4 doesn't get used as much as the 10-22 and my 16-55; so I get this occasionally.
__________________
-Tom Dragonetti
Spyder Holster + 1Dmk IV, 50D, G11
10-22, 16-35 2.8Lii, , 24-70 2.8Lii, 50mm 1.4,
70-200 2.8Lii IS, 100-400L IS
1.4x TC, 580EX ii, ST-E2
Tdragone is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LENS Error Message - Canon Powershot Pro1 sfarson Canon G-series Digital Cameras 7 28th of June 2011 (Tue) 20:38
User Error, Camera Error, Monitor Error? Pictures underexposed! speedracersong Canon EOS Digital Cameras 3 5th of January 2009 (Mon) 00:45
canon powershot a430 - lens error restart camera corrinelo Small Compact Digitals by Canon 3 25th of September 2007 (Tue) 14:21
New 20D, New Canon Lens,- got " Error 99 " message? lhurd Canon EOS Digital Cameras 7 15th of August 2005 (Mon) 21:21
Canon Powershot G6 lens error! geckophile Canon G-series Digital Cameras 2 14th of August 2005 (Sun) 02:24


All times are GMT -5. The time now is 07:25.


Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
This forum is not affiliated with Canon in any way and is run as a free user helpsite by Pekka Saarinen, Helsinki Finland. You will need to register in order to be able to post messages. Cookies are required for registering and posting. HTML in messages is not allowed, plain website addresses are automatically made active by the board.