Index  •   • New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
New Posts  •   • RTAT  •   • "Best Of"  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras
Thread started 10 Feb 2010 (Wednesday) 12:16
PREV/NEXT

Canon Rebel T1i: Pop up flash is not popping up?

 
polkad0t
Member
polkad0t's Avatar
141 posts

Joined Jan 2009

New York City
MORE INFO

I've had my T1i for about 5 months. I never dropped it or bumped it into anything and always keep it in a case when I am not using it. Ever since I got my 430 EXii, I did not use the popup flash. However, when I tried using it today, the flash would not pop up. I tried going to the Menu -> Flash Control -> Built-in flash func. setting and it says "This menu cannot be displayed. External flash is attached.". What's up with this? The external flash is clearly not there, nor do I ever learn it on the camera when I don't use it. What do I do?

Feb 10, 2010 12:16

http://www.flickr.com ...t/sets/721576219641​30533/external link
Canon Rebel T1i, EF-S 18-55mm IS, EF 100mm f/2.8 USM macro, EF 50mm f/1.8, EF-S 18-135mm f/3.5-5.6, EF 24-70 f/2.8L USM, 430 EXII speedlight

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
hpulley
Goldmember
4,386 posts
Joined Oct 2009
MORE INFO

Search the forums, a little clip in the hotshoe is stuck so it always think you have an external flash mounted. You can usually pop it up with a pin or something, otherwise it needs to go to Canon but its under warranty at least.

Feb 10, 2010 12:20

flickrexternal link 1DIIN 40D 1NRS 650 1.4xII EF12II Pel8 50f1.8I 28-80II 17-40L 24-70L 100-400L 177A 199A OC-E3 RS-80N3

LOG IN TO REPLY
polkad0t
THREAD ­ STARTER
Member
polkad0t's Avatar
141 posts

Joined Jan 2009

New York City
MORE INFO

Ahh, sorry, lagging internet was not letting me search. Opened up POTN on Safari, found a thread, and got it fixed. Thank you so much!

Feb 10, 2010 12:30

http://www.flickr.com ...t/sets/721576219641​30533/external link
Canon Rebel T1i, EF-S 18-55mm IS, EF 100mm f/2.8 USM macro, EF 50mm f/1.8, EF-S 18-135mm f/3.5-5.6, EF 24-70 f/2.8L USM, 430 EXII speedlight

LOG IN TO REPLY
rmghai
Hatchling
1 post
Joined Feb 2011
MORE INFO

polkad0t wrote in post #9582255external link
Ahh, sorry, lagging internet was not letting me search. Opened up POTN on Safari, found a thread, and got it fixed. Thank you so much!

do you know where you found this thread? i have the same problem now.
thanks

Feb 15, 2011 20:53



LOG IN TO REPLY
x_tan
Cream of the Crop
x_tan's Avatar
8,025 posts
GALLERY: 50 photos
Joined Sep 2010

ɐılɐɹʇsnɐ 'ǝuɹnoqlǝɯ
MORE INFO

Happen to my EOS 400D lots time and I have a quick fix: push down the pop-up button with one finger (? on the left side), as the same time manually lifting up the pop-up with another finger.
Of course, a trip to the repairman may or may not fix the problem for good.

Feb 15, 2011 22:23

Canon 5D3 + Zoom (EF 17-40L, 24-105L & 28-300L, 100-400L II) & Prime (24L II, 85L II, 100L, 135L & 200 f/2.8L II; Zeiss 1,4/35)
Sony α7r + Zeiss 1,8/55 FE
Nikon Coolpix A; Nikon F3 & F100 + Zeiss 1,4/50
Retiring external link

LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as registered member)
h14nha
Goldmember
1,718 posts
Joined Nov 2008

South Wales, UK
MORE INFO

rmghai wrote in post #11851458external link
do you know where you found this thread? i have the same problem now.
thanks

Yes a search "7d/430exii pop up problems" will direct you to the thread I started last year on this. Get yourself a cocktail stick and you'll be sorted :D

Feb 16, 2011 18:56

Ian
There's no fool like an old skool fool :D
myflickrexternal link
My Gear - 7d, / 17-55mm / 70-200 2.8 II / 100-400 / 300mm 2.8 / :D Fuji X Pro1 18/35

LOG IN TO REPLY
Cokeman
Member
168 posts
Joined Aug 2010
MORE INFO

the plastic toothpick on a swiss army knife works well too.

Feb 16, 2011 22:16

T2i, 70-200/4, 28/1.8, 85/1.8, 28-135, 18-55, 55-250, 430EXII

LOG IN TO REPLY

5,899 views & 0 likes for this thread
Canon Rebel T1i: Pop up flash is not popping up?
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras

NOT A MEMBER YET? CLICK HERE TO REGISTER TO THE FORUMS
Registered members get all the features: search, more forums, private messaging, thread follow, notifications, own gallery, own reviews...




SEND FEEDBACK TO STAFF    •   JUMP TO FORUM    •   FORUM RULES    •   Index    •   New Posts    •   RTAT    •   "Best Of"    •   Gallery    •   Gear    •   Reviews    •   Polls

COOKIES DISCLAIMER: By using this site you agree that some cookies will be stored on your browser. For unlogged users we store one session id cookie. For registered members we store (in addition to login session cookie) only cookies that are essential for required functionality. We do not store any personal tracking data in cookies or other browsers' data storage methods.

POWERED BY AMASS 1.1version 1.1
made in Finland
by Pekka Saarinen
for photography-on-the.net
Spent 0.0008 for 4 database queries.
PAGE COMPLETED IN 0.01s
Latest registered member is APACHEPICS
1021 guests, 814 members online
Simultaneous users record so far is 3341, that happened on Dec 11, 2014