Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 17 Jun 2010 (Thursday) 03:34
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Issue with new Sigma 30mm EX

 
kingbob734
Senior Member
Avatar
869 posts
Joined Dec 2009
Location: Cheshire, UK
     
Jun 17, 2010 03:34 |  #1

Iv just got hold of a brand new sigma 30mm, but when using MF... the focus wheel keeps on going until you literally stop turning.

Does anyone else have this issue :(


Gear List flickr (external link)
5DIII | 7D | 24L | 35 | 85 | 105 | 17-40L | 70-200L II | 430EX II | 580EX II

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Nick_b
Senior Member
Avatar
968 posts
Joined Oct 2006
Location: Ottawa
     
Jun 17, 2010 04:55 |  #2

Well when I rotate the manual focus ring on mine I feel roughness (normal) untill I reach the end, then I can continue rotating but the roughness is gone. Is that what is happening to you too? because it is normal.


50D, 2 x 20D, Elan 7E, 18-55mm 3.5-5.6 IS, 30mm 1.4 , 85mm 1.8, 200mm 2.8 II, flash 430EX, 580 EX
Canon G10
Pentax P30, 50mm 2.0

  
  LOG IN TO REPLY
Jman13
Cream of the Crop
Avatar
5,558 posts
Likes: 7
Joined Dec 2005
Location: Columbus, OH
     
Jun 17, 2010 05:02 |  #3

That is true with ANY HSM/USM motor lens. Don't worry about it (and don't keep turning past the natural stop where the ring get's slightly harder to turn...it won't necessarily hurt the lens, but I don't think it's all that great for it either.)


Jordan Steele - http://www.jordansteel​e.com (external link)
Admiring Light - http://www.admiringlig​ht.com (external link)

  
  LOG IN TO REPLY
kingbob734
THREAD ­ STARTER
Senior Member
Avatar
869 posts
Joined Dec 2009
Location: Cheshire, UK
     
Jun 17, 2010 05:05 |  #4

Ahh ok, however another thing that is bothering me... sometimes i switch from MF to AF and it sust will not AF until i reboot my 7D? Only does it with the 30mm :S


Gear List flickr (external link)
5DIII | 7D | 24L | 35 | 85 | 105 | 17-40L | 70-200L II | 430EX II | 580EX II

  
  LOG IN TO REPLY
scroller52
Senior Member
964 posts
Likes: 1
Joined Dec 2009
Location: NYC
     
Jun 17, 2010 08:27 |  #5

the MF/AF switch works fine on my 7d


Canon EOS 5D3 | Canon 24mm 1.4L mkII | Canon 85mm 1.2L mkI | Canon 40mm 2.8
my flickr (external link)
my picasa (external link)

  
  LOG IN TO REPLY
Erik_L
Goldmember
3,160 posts
Likes: 1
Joined Oct 2009
Location: Minnesota
     
Jun 17, 2010 08:33 |  #6

It's supposed to do that. there is some friction between the mechanism that moves the elements and the ring... it's designed to not spin in place when the AF motor is driven, so it has to have some "play"

Canon lenses do the same.


Canon EOS 1D III
Manfrotto 190X Pro B w/324RC2 "Action Head" | Canon 580EX II
Sigma 20 f/1.8 | Canon 35 f/1.4 L | Sigma 50 f/1.4 | Sigma 85 f/1.4 | Canon 135 f/2 L
Flick (external link)r

  
  LOG IN TO REPLY
JelleVerherstraeten
Goldmember
Avatar
2,440 posts
Likes: 1
Joined Dec 2008
Location: Antwerp, Belgium
     
Jun 17, 2010 08:50 |  #7

Mine does always work immediatly when I use te AF-switch.


-Jelle l Gear l Website (external link) l

  
  LOG IN TO REPLY
kingbob734
THREAD ­ STARTER
Senior Member
Avatar
869 posts
Joined Dec 2009
Location: Cheshire, UK
     
Jun 17, 2010 09:17 |  #8

Iv been on to sigma this afternoon anyways... gonna have it sent in to be corrected! So hopefully not all is lost lol :)


Gear List flickr (external link)
5DIII | 7D | 24L | 35 | 85 | 105 | 17-40L | 70-200L II | 430EX II | 580EX II

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,080 views & 0 likes for this thread
Issue with new Sigma 30mm EX
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is miltiades
1168 guests, 294 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.