Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 27 Jul 2010 (Tuesday) 16:07
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

7D vs. Kingston Elite Pro 8gb CF cards...

 
cptrios
Goldmember
Avatar
1,744 posts
Joined Jul 2008
Location: Boston, USA / Burgundy, France
     
Jul 27, 2010 16:07 |  #1

Well, I just 'unboxed' (man I hate that word) my brand new 7D, popped in a CF card, and...the 7D can't read it. Can't even FORMAT it! I tried it with each of my four Kingston Elite Pro 8gb cards, and all had the same problem. One of my generic 4gb cards works perfectly, however.

Does anyone else have this problem? In doing my research for buying the 7D, I never thought to check whether it'd be able to read my freaking cards!


Fuji X100 / Sony NEX-7 / Contax G 45mm f/2 / The ghosts of 3 Canon bodies past / A meagre amount of talent
My weak lil' 500px (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
10megapixel
"I'm a little slow"
Avatar
3,872 posts
Likes: 3
Joined Oct 2008
Location: Â…Â…Surrounded by Corn and Rednecks in Indiana
     
Jul 27, 2010 16:22 |  #2

Where did you buy the cards? Please don't say you got a open package bundle deal on E-Bay or Amazon. There are a lot of fakes out there.



Gear List & Feedback



  
  LOG IN TO REPLY
cptrios
THREAD ­ STARTER
Goldmember
Avatar
1,744 posts
Joined Jul 2008
Location: Boston, USA / Burgundy, France
     
Jul 27, 2010 16:31 as a reply to  @ 10megapixel's post |  #3

Nope, from B&H, and I've been using them with no problem in my 40D for a year. And they still work in the 40D just fine. Perhaps the 7D's pins or too short?


Fuji X100 / Sony NEX-7 / Contax G 45mm f/2 / The ghosts of 3 Canon bodies past / A meagre amount of talent
My weak lil' 500px (external link)

  
  LOG IN TO REPLY
Snydremark
my very own Lightrules moment
19,065 posts
Gallery: 57 photos
Likes: 3376
Joined Mar 2009
Location: Issaquah, WA USA
     
Jul 27, 2010 16:39 as a reply to  @ cptrios's post |  #4

Do you have an external card reader? If so, maybe formatting them from the computer first and then reusing them in the 7D will work?

There aren't different "formats" of CF cards, so if it works in the 40D it SHOULD work in the 7D...

What sort of a message or error do you get when you try to format them in 7D?


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
cptrios
THREAD ­ STARTER
Goldmember
Avatar
1,744 posts
Joined Jul 2008
Location: Boston, USA / Burgundy, France
     
Jul 27, 2010 16:48 |  #5

I get this:

"Card cannot be accessed. Reinsert/change card or format card with camera."

And then I attempt to format the card unsuccessfully. It really is as though the camera isn't physically connecting to the card (the format screen doesn't even show the card's size, etc.)


Fuji X100 / Sony NEX-7 / Contax G 45mm f/2 / The ghosts of 3 Canon bodies past / A meagre amount of talent
My weak lil' 500px (external link)

  
  LOG IN TO REPLY
JNRSM3
Member
Avatar
229 posts
Joined Jun 2009
     
Jul 27, 2010 16:48 |  #6

hmm...my Kingston Elites work on my 7D. I have the 8gb class 6 cards.


Gripped 7D ~EF 17-40 F/4 L ~ EF 24-105 F/4 L ~ EF 70-200 F/4 L IS ~ EF 50 F/1.4 ~ Manfrotto 498RC2/055XPROB ~ Lowepro AW200

  
  LOG IN TO REPLY
Pixels
Senior Member
Avatar
454 posts
Likes: 5
Joined Jul 2003
Location: Ireland
     
Jul 27, 2010 16:49 as a reply to  @ Snydremark's post |  #7

I got a new 7D afew days ago. My old CF cards (2gb, 1gb, and 512mb) all Kingston and Sandisk brands work fine, and format perfectly in camera. I'm puzzled at what may be causing your problem, especially if one of your cards - the 4gb - works OK.
It sounds as if the cards are not making proper contact with the pins - sorry I can't be of more help.


Canon 24-105 L IS USM,
Canon 400mm L f5.6
Canon 7D, Canon 1.4 TCII
Canon 10-22, Canon 420EX speedlite,

Olympus OMD EM5, 20-40 f2.8 PRO

  
  LOG IN TO REPLY
cptrios
THREAD ­ STARTER
Goldmember
Avatar
1,744 posts
Joined Jul 2008
Location: Boston, USA / Burgundy, France
     
Jul 27, 2010 16:53 |  #8

Pixels wrote in post #10613673 (external link)
It sounds as if the cards are not making proper contact with the pins

It does seem that way. I tried formatting them with my computer, to no avail.

I tortured myself deciding between a 7D and a 5D classic...perhaps this is an omen! (I've got two weeks to return the thing)


Fuji X100 / Sony NEX-7 / Contax G 45mm f/2 / The ghosts of 3 Canon bodies past / A meagre amount of talent
My weak lil' 500px (external link)

  
  LOG IN TO REPLY
Snydremark
my very own Lightrules moment
19,065 posts
Gallery: 57 photos
Likes: 3376
Joined Mar 2009
Location: Issaquah, WA USA
     
Jul 27, 2010 16:55 |  #9

cptrios wrote in post #10613693 (external link)
It does seem that way. I tried formatting them with my computer, to no avail.

I tortured myself deciding between a 7D and a 5D classic...perhaps this is an omen! (I've got two weeks to return the thing)

You might take it back and try a different copy of the body...maybe there is a pin or two out of whack? Doesn't seem likely if it reads your 4GB card, but this sounds quite bizarre...


- Eric S.: My Birds/Wildlife (external link) (7D MkII/5D IV, Canon 10-22 f/3.5-4.5, Canon 24-105L f/4 IS, Canon 70-200L f/2.8 IS MkII, Canon 100-400L f/4.5-5.6 IS I/II)
"The easiest way to improve your photos is to adjust the loose nut between the shutter release and the ground."

  
  LOG IN TO REPLY
Optiq
Senior Member
480 posts
Gallery: 3 photos
Likes: 28
Joined May 2009
Location: Charlotte (just north of)
     
Jul 27, 2010 16:57 as a reply to  @ cptrios's post |  #10

I'm not sure if any of those firmware upgrades addressed anything with reading the cards but there is a new one out.

Is the camera on or off when you're inserting the card? Try it the other way.

I like the "format in a different device" suggestion above as well.

If none of that works, send em back!


My small but growing -=Flickr page=- (external link)

  
  LOG IN TO REPLY
ecub
Goldmember
1,487 posts
Joined May 2010
Location: Southwest suburbs of Chicago
     
Jul 27, 2010 17:06 |  #11

Did you buy a new 7D? Does any of the pins inside the camera looked bent or broke?


- Ed
Official Gear List
5D II | 7D | 16-35mm f/2.8L II | 24-70mm f/2.8L | 70-200mm f/2.8L IS II | 100-400mm f/4.5-5.6L | 50mm f/1.2L USM | 85mm f/1.2L II | 100mm f/2.8L IS macro

  
  LOG IN TO REPLY
NeutronBoy
Goldmember
2,049 posts
Likes: 1
Joined Jul 2007
Location: LI, NY
     
Jul 27, 2010 17:16 |  #12

my first thoughts too - check the pins


5D Mark II, 40D, 350d
Canon 70-200 f2.8 IS II L | Canon 100-400 IS L [COLOR=black]| Canon 24-70 L | Canon 100mm Macro f2.8 | Canon 50 f1.4| Canon 10-22 | Canon MP-E 65 | Rokinon 14mm f2.8 | Sigma 17 - 70 macro
MT-24 & 430 flashes | other junk

  
  LOG IN TO REPLY
cptrios
THREAD ­ STARTER
Goldmember
Avatar
1,744 posts
Joined Jul 2008
Location: Boston, USA / Burgundy, France
     
Jul 27, 2010 17:19 |  #13

ecub wrote in post #10613756 (external link)
Did you buy a new 7D? Does any of the pins inside the camera looked bent or broke?

Funny you should mention that! I've just been digging around for a little LED light to do just that...and guess what! One bent pin and one ENTIRELY MISSING pin.

It's a Canon Refurb bought from Adorama. In theory this should make this kind of thing LESS likely to happen. Unacceptable either way... now who knows how long I'm going to have to wait for this to ship back and for them to refund my money/send me another one!


Fuji X100 / Sony NEX-7 / Contax G 45mm f/2 / The ghosts of 3 Canon bodies past / A meagre amount of talent
My weak lil' 500px (external link)

  
  LOG IN TO REPLY
WRXTACY
Senior Member
Avatar
763 posts
Joined Jan 2009
Location: Fredericksburg , VA, USA
     
Jul 27, 2010 17:21 as a reply to  @ cptrios's post |  #14

Damn man thats a shame, I'd be pretty pissed off about it too.


-Brandon-
Canon 5D Mark 2 | Canon EF 35mm f/1.4 L | Canon EF 135mm f/2.0 L | Canon EF 24-105 f/4 IS L
Full Gear List | My flickr (external link)

  
  LOG IN TO REPLY
e02937
Goldmember
2,714 posts
Joined Dec 2008
     
Jul 27, 2010 17:21 |  #15

Interesting, he said that he had a generic card work correctly so I doubt that it's an issue with the pins.

I would definitely format it in the computer


Canon 7d
[15-85 IS] [70-200
f/4L IS] [I'm a PC]
[Full gear list and feedback]

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

8,435 views & 0 likes for this thread
7D vs. Kingston Elite Pro 8gb CF cards...
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Tophere
891 guests, 198 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.