Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Marketplace & Market Info Market Watch 
Thread started 09 Jan 2011 (Sunday) 23:16
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Issue with Maxsaver.net

 
Ball4
Senior Member
352 posts
Joined Feb 2008
Location: SoCal
     
Jan 09, 2011 23:16 |  #1

I received a B+W polarizing filter from Maxsaver the other day, but finally got a chance to open the package today and inspect it. Noticing a small circular streak is on the surface of the filter, I tried wiping it away with a microfiber cloth. No luck, it won't go away. The foam inside the plastic container also has several filter ring indentations. There should be only one. Could this have been a used one they sent me?

What's the best way to deal with this outfit since they're out in Hong Kong. Has anyone gotten a replacement or full refund from Maxsaver?




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
kwando
Goldmember
Avatar
1,345 posts
Likes: 1
Joined Aug 2008
Location: Aurora, Co
     
Jan 09, 2011 23:28 |  #2

Interested as well. My filter was fine but the plastic box was crushed


~Simon~
My Gear | My Feedback | Smugmug (external link)
https://photography-on-the.net …/showthread.php​?t=1213134

  
  LOG IN TO REPLY
sigma ­ pi
Cream of the Crop
Avatar
11,204 posts
Likes: 5
Joined Apr 2010
Location: Los Angeles
     
Jan 10, 2011 14:22 |  #3

mine was ok on both accounts sorry I can not help


Don't try to confuse me with the facts, my mind is already made up.
http://www.flickr.com …6850267535/in/p​hotostream (external link)

  
  LOG IN TO REPLY
TuanTime
Senior Member
759 posts
Joined May 2009
     
Jan 10, 2011 16:56 as a reply to  @ sigma pi's post |  #4

I can't help either but I have ordered about 10 filters from them with no issues. Good luck with yours though I would try to email them to find out what they say.




  
  LOG IN TO REPLY
crcal
Senior Member
808 posts
Likes: 1
Joined Nov 2009
Location: Honolulu, HI
     
Jan 10, 2011 17:16 as a reply to  @ TuanTime's post |  #5

Ordered from them twice with no issues so sorry I have no other advice other than to call or email them.


Calvin
Converted to Sony A7 and love it | Gear & Feedback

  
  LOG IN TO REPLY
DiMAn0684
Goldmember
Avatar
1,933 posts
Likes: 13
Joined Dec 2009
Location: Boston, MA
     
Jan 10, 2011 17:22 as a reply to  @ crcal's post |  #6

Ball4, have you had a chance to read THIS thread?

You haven't even contacted the vendor or the manufacturer yet, but you've decided to bring up the matter on the POTN.


Canon 5D MkII | Canon 16-35mm f/4 | Canon 50mm f/1.8 STM | Canon 24-105mm f/4 | Tamron 70-300mm VC | Canon 430EX II | Benro A2682TB1

  
  LOG IN TO REPLY
Ball4
THREAD ­ STARTER
Senior Member
352 posts
Joined Feb 2008
Location: SoCal
     
Jan 10, 2011 21:45 |  #7

DiMAn0684 wrote in post #11613169 (external link)
Ball4, have you had a chance to read THIS thread?

You haven't even contacted the vendor or the manufacturer yet, but you've decided to bring up the matter on the POTN.

That's right. I posted here to get opinions and seek advice from others that may have faced a similar situation.




  
  LOG IN TO REPLY
lannes
Goldmember
Avatar
4,370 posts
Likes: 5
Joined Dec 2009
Location: Perth, Australia
     
Jan 11, 2011 00:28 |  #8

Have you tried some lens cleaning solution.


1Dx, 1DM4, 5DM2, 7D, EOS-M, 8-15L, 17-40L, 24 TSE II, 24-105L, 50L, 85L II, 100L, 135L, 200L f/2.8, 300L f/4, 70-200L II, 70-300L, 400Lf/5.6

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

672 views & 0 likes for this thread
Issue with Maxsaver.net
FORUMS Marketplace & Market Info Market Watch 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is roysdaughter
1251 guests, 325 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.