Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 22 Mar 2012 (Thursday) 15:55
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

5D mark III problem ?????

 
Jcr918
Member
Avatar
148 posts
Joined Aug 2011
Location: Oklahoma
     
Mar 22, 2012 15:55 |  #1

Ok so I just got my Canon 5D mark III and I am upgrading from the t3i a bit of a learning curve.


I am having some issue I think that might be software related but I am not 100% sure.
My 5D mark III keeps freezing up the lens wont spin to focus and the menu runs slow some times. My 24-70mm 2.8 L lens works great on my t3i and for the most part on the 5D mark III but not when I can't take a picture I turn the camera off and and back on everything is good to go for awhile.


Also Last night my Canon 430exII speedlight mounted on the hotshoe in E-ttl also seemed like it was having some type of communication issue with the camera.

Does anyone know if this could be software related or is this a hardware issue ? Also what known bugs are there for the Canon 5D mark III


Canon 5D Mark III :) & Canon T3i/24-70mm 2.8/70-200mm IS 2.8 Mark II /2 600ex RT /2 430ex II/

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
5Dmaniac
Goldmember
Avatar
1,303 posts
Likes: 1
Joined Oct 2008
Location: Scottsdale, AZ
     
Mar 22, 2012 16:32 |  #2

Time to call your seller and get a replacement.




  
  LOG IN TO REPLY
Pete ­ W
Goldmember
Avatar
1,325 posts
Gallery: 44 photos
Best ofs: 1
Likes: 657
Joined Apr 2007
Location: Bishops Stortford, Herts. UK
     
Mar 22, 2012 16:36 |  #3

Give it back and ask for replacement


All the best
Pete Woods LRPS QGP ASINWP
My Website (external link)

  
  LOG IN TO REPLY
Unregistered.Coward
Senior Member
Avatar
884 posts
Joined Oct 2010
Location: Looking thru the viewfinder
     
Mar 22, 2012 16:44 |  #4

5Dmaniac wrote in post #14134468 (external link)
Time to call your seller and get a replacement.

Pete W wrote in post #14134498 (external link)
Give it back and ask for replacement

Yes, let's jump right there, not investigate whether it might be something a simple as a nearly expended battery or benign as perhaps just resetting the camera to default.


....the best camera is the one you have on you at the time.

  
  LOG IN TO REPLY
Jcr918
THREAD ­ STARTER
Member
Avatar
148 posts
Joined Aug 2011
Location: Oklahoma
     
Mar 22, 2012 16:44 as a reply to  @ Pete W's post |  #5

They have none in stock and the shop said they believe its a firmware issue. Said I have two weeks to get a replacement and 1 year warranty.


Does anyone think this could be firmware ? In honestly seems like a software issue


Canon 5D Mark III :) & Canon T3i/24-70mm 2.8/70-200mm IS 2.8 Mark II /2 600ex RT /2 430ex II/

  
  LOG IN TO REPLY
lens ­ pirate
Goldmember
Avatar
1,643 posts
Likes: 31
Joined Aug 2008
     
Mar 22, 2012 16:46 |  #6

Jcr918 wrote in post #14134529 (external link)
They have none in stock and the shop said they believe its a firmware issue. Said I have two weeks to get a replacement and 1 year warranty.


Does anyone think this could be firmware ? In honestly seems like a software issue

Firmware is software.... Get a replacement Take it back. Or your gonna end up doing the ship it in for warranty thing.


INSANE GEAR LIST
Sun flare.... the new selective color. JUST SAY NO

  
  LOG IN TO REPLY
borism
Goldmember
Avatar
3,417 posts
Gallery: 6 photos
Likes: 146
Joined Jul 2008
Location: Florida, Weston
     
Mar 22, 2012 16:48 |  #7

Well, IMHO, if i spend the cash for 5D3, id be asking for a new one if the thing is not working properly out of the box.
Yes it could be something very simple, but I wouldn't want to deal with that, Just me.


CANON 6D - SONY A6000

  
  LOG IN TO REPLY
Saint728
Goldmember
Avatar
2,892 posts
Likes: 1
Joined Jun 2009
Location: Honolulu Hawaii
     
Mar 22, 2012 17:19 |  #8

I would check the battery first. Is your battery fully charged? If the lens won't spin to focus and your menu is slow, I suspect it is a bad battery or not charged enough? I would try a different battery and see if that changes anything.

Take Care,
Cheers, Patrick


Canon EOS 1Ds Mark III | 17-40mm f/4.0L | 70-200mm f/2.8L USM | 100mm f/2.8L IS Macro | 300mm f/4.0L IS
Click Here To See My Gear
Click here to see my Flickr (external link)
http://www.runryder.co​m/helicopter/gallery/9​019/ (external link)

  
  LOG IN TO REPLY
orbitechgr
Goldmember
Avatar
1,075 posts
Likes: 3
Joined Jul 2010
     
Mar 22, 2012 17:23 |  #9

So take it there check with a new battery at the store and if not leave it for replacement..
I understand you really want it bad and cannot wait but don't risk so much money when you can get a replacement. Besides that I haven't heard any firmware issues with MkIII thus far..


Gear
Flickr (external link)
Jim

  
  LOG IN TO REPLY
Pete ­ W
Goldmember
Avatar
1,325 posts
Gallery: 44 photos
Best ofs: 1
Likes: 657
Joined Apr 2007
Location: Bishops Stortford, Herts. UK
     
Mar 22, 2012 17:24 |  #10

Unregistered.Coward wrote in post #14134526 (external link)
Yes, let's jump right there, not investigate whether it might be something a simple as a nearly expended battery or benign as perhaps just resetting the camera to default.

Well you might like defective goods but if I had just shelled out big bucks I would be taking it straight back......

Oh looks others have said take it back.... No but maybe you are right and he should hang on to it hoping a miracle will happen and it will mend itself........:rolleyes:


All the best
Pete Woods LRPS QGP ASINWP
My Website (external link)

  
  LOG IN TO REPLY
elrey2375
Thinks it's irresponsible
Avatar
4,992 posts
Gallery: 2 photos
Likes: 276
Joined Nov 2011
     
Mar 22, 2012 17:28 |  #11

borism wrote in post #14134560 (external link)
Well, IMHO, if i spend the cash for 5D3, id be asking for a new one if the thing is not working properly out of the box.
Yes it could be something very simple, but I wouldn't want to deal with that, Just me.

So instead of fixing something simple, you'd rather go to the trouble of sending it back? Sending something back is such a hassle, not to mention you don't have the use of it while you're waiting. My first thought, regardless of how much I paid, is not to jump to conclusions straight off and send the thing back. Exhaust your options as far as what could be wrong. Are you sure it's on AF and not MF? It could be something that simple. Go into focus menu and make sure something isn't changed. Are you trying to focus on something that is closer than the minimum focusing distance? All these are things I would at least try first.


http://emjfotografi.co​m/ (external link)
http://500px.com/EMJFo​tografi (external link)

  
  LOG IN TO REPLY
Jcr918
THREAD ­ STARTER
Member
Avatar
148 posts
Joined Aug 2011
Location: Oklahoma
     
Mar 22, 2012 17:48 as a reply to  @ elrey2375's post |  #12

I have only played with it for two days. I am going to give it a bit more time i guess. I have two weeks to return it. Hopefully it's something simple like user error or software:p


Canon 5D Mark III :) & Canon T3i/24-70mm 2.8/70-200mm IS 2.8 Mark II /2 600ex RT /2 430ex II/

  
  LOG IN TO REPLY
mrgooch
Goldmember
Avatar
3,193 posts
Gallery: 6 photos
Likes: 180
Joined Dec 2008
Location: Toms River NJ
     
Mar 22, 2012 17:56 |  #13

Why would you consider software a simple problem? There are no firmware updates.



  
  LOG IN TO REPLY
WickedRay
Mostly Lurking
Avatar
17 posts
Joined Nov 2005
Location: Horsham West Sussex
     
Mar 22, 2012 18:47 as a reply to  @ mrgooch's post |  #14

May I suggest that you try it using the "Green Box full auto", that should negate any user error. I have none of your problems so possibly you may have a faulty one.

Cheers, Ray.




  
  LOG IN TO REPLY
windpig
Chopped liver
Avatar
15,284 posts
Gallery: 7 photos
Likes: 1597
Joined Dec 2008
Location: Just South of Ballard
     
Mar 22, 2012 18:55 |  #15

I assume you've tried another lens.


Would you like to buy a vowel?
Go ahead, spin the wheel.
flickr (external link)
I'm accross the canal just south of Ballard, the town Seattle usurped in 1907.

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

10,779 views & 0 likes for this thread
5D mark III problem ?????
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is DTPhotography
757 guests, 208 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.