Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 08 Apr 2012 (Sunday) 21:31
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

5DIII screen flicker

 
pbelarge
Goldmember
Avatar
2,835 posts
Joined Jun 2010
Location: Westchester County, NY
     
Apr 08, 2012 21:31 |  #1

I have only shot the 5DIII on 3 different occasions, but I have noticed a trend with this camera body.
I am using the same lenses as before, 16-35MKII, 24-70, 70-200MKII and my 100L Macro.

Once I am shooting for a while (maybe 15-20minutes), I notice as I press on the shutter button, the LCD screen starts to flicker, and it seems like the camera is trying to actually release the shutter. I take my finger off the shutter button immediately, but it continues for a few seconds. I turn the camera off, then back on and it takes a little longer but occurs again. I turn the camera off, then back on again and it has stopped after the second episode. I forgot to mention, this occurs when I am bracketing 5 exposures.
I have also noticed higher battery usage with this body, than with the 5DII.

BTW: the images I have shot, show very nice IQ and I am happy with the upgrade. Of course except for this issue.

Has anyone else experienced this?
I hate to send it in to Canon, but I think I may need to.


just a few of my thoughts...
Pierre

  
  LOG IN TO REPLY
Gregg.Siam
Goldmember
Avatar
2,383 posts
Joined Jun 2010
Location: Bangkok
     
Apr 08, 2012 21:33 |  #2

I haven't seen that. I think it's time to send it in.


5D MKIII | 24-105mm f/4 L| 50mm f/1.8 | 600EX-RT [FONT=Tahoma][COLOR=bl​ue][FONT="]|
∞ 500px (external link)
flickr (external link)

  
  LOG IN TO REPLY
cheezz
Member
172 posts
Joined Apr 2010
     
Apr 08, 2012 22:15 |  #3

Too late for an exchange?


Canon 7D // EF 24-70mm f2.8L USM, EF 85mm f1.8 USM, 50mm 1.8 II Nifty Fifty, EF 28-135mm f3.5-5.6 IS USM kit lens, EF-S 55-250mm f4-5.6 IS, 430EX II
Added: EF-S 15-85mm f3.5-5.6
Added: EF 70-200mm f4L IS
Added: 1.4 II TC

  
  LOG IN TO REPLY
gacon1
Senior Member
Avatar
634 posts
Likes: 4
Joined Mar 2006
     
Apr 08, 2012 22:29 |  #4

pbelarge wrote in post #14232678 (external link)
I have only shot the 5DIII on 3 different occasions, but I have noticed a trend with this camera body.
I am using the same lenses as before, 16-35MKII, 24-70, 70-200MKII and my 100L Macro.

Once I am shooting for a while (maybe 15-20minutes), I notice as I press on the shutter button, the LCD screen starts to flicker, and it seems like the camera is trying to actually release the shutter. I take my finger off the shutter button immediately, but it continues for a few seconds. I turn the camera off, then back on and it takes a little longer but occurs again. I turn the camera off, then back on again and it has stopped after the second episode. I forgot to mention, this occurs when I am bracketing 5 exposures.
I have also noticed higher battery usage with this body, than with the 5DII.

BTW: the images I have shot, show very nice IQ and I am happy with the upgrade. Of course except for this issue.

Has anyone else experienced this?
I hate to send it in to Canon, but I think I may need to.

Return it and get a new one.




  
  LOG IN TO REPLY
julius071
Senior Member
496 posts
Joined Feb 2012
Location: Seattle, WA
     
Apr 08, 2012 23:05 |  #5

Would it be more hard to get a new one when stores are out of stock?!


Capturing moments one snap at a time.

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,496 views & 0 likes for this thread
5DIII screen flicker
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is nader23
852 guests, 206 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.