Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Sample Photo Archives Lens Sample Photo Archive 
Thread started 21 Sep 2010 (Tuesday) 04:37
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Sigma 120-300 f/2.8 EX OS

 
woos
Goldmember
Avatar
2,224 posts
Likes: 24
Joined Dec 2008
Location: a giant bucket
     
Jun 27, 2012 00:33 |  #2326

Oh no! I hope you can get it resolved. You saw my (horrible quality) youtube video showing the first copy I had of the lens, right? Where the focus just slipped and slipped? :) http://www.youtube.com​/watch?v=egiOz8xoP74 (external link)

Hopefully my 2nd copy continues to work reliably! If something dies on it, it'd definitely be getting sent in for repair though, it's so sharp and happy I wouldn't want to part with it... Friend swears up and down after looking at some full sized samples, that it's better with the 2x than the nikon 300 2.8 VR is with the 2x TC III. I still am skeptical, but he's very adamant that it's true, lol. Whatever it is, its' very good with the 2x on. Here's a 100% crop at 600mm...f6.3, too, not f/8 or anything! And, it's a 100% crop from a D800 , at that...

IMAGE NOT FOUND
IMAGE IS A REDIRECT OR MISSING!
HTTP response: NOT FOUND | MIME changed to 'image/png'


No, it's not a 600mm prime, but it has DAMN GOOD sharpness at 600mm.

amanathia.zenfolio.com

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
gabebalazs
Bird Whisperer
Avatar
7,640 posts
Gallery: 52 photos
Likes: 1069
Joined Nov 2008
Location: Toledo, OH
     
Jun 27, 2012 06:41 |  #2327

that's very good indeed.
I also watched your slipping AF video. Mine was the same, Sigma fixed it.


SONY A7RIII | SONY A7III | SONY RX10 IV | SONY RX100 | 24-70 2.8 GM | 70-200 2.8 GM | 16-35 F/4 | PZ 18-105 F/4 | FE 85 1.8 | FE 28-70 | SIGMA 35 1.4 ART | SIGMA 150-600 C | ROKINON 14 2.8
Gabe Balazs Photo (external link)
Nature Shots Portfolio (external link)

  
  LOG IN TO REPLY
woos
Goldmember
Avatar
2,224 posts
Likes: 24
Joined Dec 2008
Location: a giant bucket
     
Jun 27, 2012 10:52 |  #2328

How long did it take to get yours back, when it happened, again? Mine was brand new so I just exchanged at store. 5 year warranty gives some good peace of mind, though. Really makes it not worth it to consider one of the cheaper ebay ones from hong kong, imho. =p


amanathia.zenfolio.com

  
  LOG IN TO REPLY
gabebalazs
Bird Whisperer
Avatar
7,640 posts
Gallery: 52 photos
Likes: 1069
Joined Nov 2008
Location: Toledo, OH
     
Jun 27, 2012 12:10 |  #2329

The repair on mine took exactly 1 month. OS and slipper focus. They had to order parts hence the delay.
I bought my Sigma used, I actually traded my 100-400L + cash for it.


SONY A7RIII | SONY A7III | SONY RX10 IV | SONY RX100 | 24-70 2.8 GM | 70-200 2.8 GM | 16-35 F/4 | PZ 18-105 F/4 | FE 85 1.8 | FE 28-70 | SIGMA 35 1.4 ART | SIGMA 150-600 C | ROKINON 14 2.8
Gabe Balazs Photo (external link)
Nature Shots Portfolio (external link)

  
  LOG IN TO REPLY
Evan ­ Idler
Goldmember
Avatar
1,600 posts
Likes: 4
Joined May 2005
Location: Edmonton, Alberta, Canada
     
Jun 27, 2012 12:18 |  #2330

So far mine has been behaving nicely. And the 10 Year Canadian Warranty is also very nice to have.
I just wish I had places around me, like Gabe has, that I could go set up a blind and take pictures.

--Evan


Canon5DIII + Some L + Some non L + Some Sigma + Some Tamron + other stuff....
Patiently awaiting a winning Lottery Ticket to afford all the toys I would really like :-P

  
  LOG IN TO REPLY
Jay ­ T
Senior Member
Avatar
463 posts
Gallery: 7 photos
Likes: 212
Joined Mar 2008
Location: phila. pa
     
Jun 27, 2012 16:50 as a reply to  @ Evan Idler's post |  #2331

I called siigma today and they said it was shipping out today but was to early to give me a tracking number. I'll call thursday and ask for tracking number and what they did to it.If they really shipped it today I should have it by thursday or friday at the latest.I'll keep my fingers crossed.


1DX\ 5diii gripped \ tokina 12-24 f/4 /sigma 24-60 f2.8 \ \ sigma 120-300 OS \ sigma 50 f1.4 \ canon 500 f4 IS \ canon1.4 III tc \ canon 2xii tc \sigma 2x dg tc \ 580ex \ 2x 430ex flickr (external link)

  
  LOG IN TO REPLY
BenMont
Member
Avatar
107 posts
Likes: 76
Joined May 2012
Location: Cambridge, UK
     
Jun 27, 2012 16:59 as a reply to  @ Jay T's post |  #2332

A friend of mine has a copy that he says is showing severe ghosting in the images, both wide open at 2.8 and stopped down to at least 7.1. Anyone else experienced this, or is this a "new" fault?


BenMontgomery.co.uk (external link) | Airliners.net (external link) | Flickr (external link) | My Photography Facebook Page (external link)

  
  LOG IN TO REPLY
bobbyz
Cream of the Crop
20,505 posts
Likes: 3436
Joined Nov 2007
Location: Bay Area, CA
     
Jun 27, 2012 17:02 |  #2333

Jay T wrote in post #14630797 (external link)
http://www.youtube.com​/watch?v=Mgmdy4wrkNI (external link) Its not a isolated case. I googled it and this guy posted this video and my lens is doing the same thing. Check out the link

What is the clicking noise?


Fuji XT-1, 18-55mm
Sony A7rIV, , Tamron 28-200mm, Sigma 40mm f1.4 Art FE, Sony 85mm f1.8 FE, Sigma 105mm f1.4 Art FE
Fuji GFX50s, 23mm f4, 32-64mm, 45mm f2.8, 110mm f2, 120mm f4 macro
Canon 24mm TSE-II, 85mm f1.2 L II, 90mm TSE-II Macro, 300mm f2.8 IS I

  
  LOG IN TO REPLY
Jay ­ T
Senior Member
Avatar
463 posts
Gallery: 7 photos
Likes: 212
Joined Mar 2008
Location: phila. pa
     
Jun 27, 2012 17:17 |  #2334

bobbyz wrote in post #14640887 (external link)
What is the clicking noise?

If you watched the video It makes a click and the af goes the other way a little and stops makes a click again and goes the other way and just keeps repeating it self. I thing the click is from the change of direction of the auto focus. Thats my best guess.


1DX\ 5diii gripped \ tokina 12-24 f/4 /sigma 24-60 f2.8 \ \ sigma 120-300 OS \ sigma 50 f1.4 \ canon 500 f4 IS \ canon1.4 III tc \ canon 2xii tc \sigma 2x dg tc \ 580ex \ 2x 430ex flickr (external link)

  
  LOG IN TO REPLY
bobbyz
Cream of the Crop
20,505 posts
Likes: 3436
Joined Nov 2007
Location: Bay Area, CA
     
Jun 27, 2012 17:33 |  #2335

I never heard my canon lenses make that click even when I focus from one end to the other. These kind of things sare me about getting this lens not to mention my bad experience with 120-300mm non OS version.


Fuji XT-1, 18-55mm
Sony A7rIV, , Tamron 28-200mm, Sigma 40mm f1.4 Art FE, Sony 85mm f1.8 FE, Sigma 105mm f1.4 Art FE
Fuji GFX50s, 23mm f4, 32-64mm, 45mm f2.8, 110mm f2, 120mm f4 macro
Canon 24mm TSE-II, 85mm f1.2 L II, 90mm TSE-II Macro, 300mm f2.8 IS I

  
  LOG IN TO REPLY
Jay ­ T
Senior Member
Avatar
463 posts
Gallery: 7 photos
Likes: 212
Joined Mar 2008
Location: phila. pa
     
Jun 27, 2012 19:16 |  #2336

If I have any more problems with this lens I'll have to sell it and get a used canon 500 f/4 IS which I'm starting to think I should of did at the start.


1DX\ 5diii gripped \ tokina 12-24 f/4 /sigma 24-60 f2.8 \ \ sigma 120-300 OS \ sigma 50 f1.4 \ canon 500 f4 IS \ canon1.4 III tc \ canon 2xii tc \sigma 2x dg tc \ 580ex \ 2x 430ex flickr (external link)

  
  LOG IN TO REPLY
Tesign
Member
Avatar
135 posts
Likes: 12
Joined Feb 2011
Location: Singapore
     
Jun 27, 2012 19:23 |  #2337

The reason why I'm on this trhead still though I've the Canon 300mm f2.8 IS USM is bekuz I still love to have this lens for its zoom..I can live with the weight. I certainly hope Sigma addresses this random 'problem' permanently with a more reliable OS component for their newer batch if any. Just love all those images it can produce here.


EF 50 1.8 II/EF100 F2/EF70-200L 2.8 Mk II/EF70-300L /EF300mm 2.8 MK II/EF 50mm f2.5 Macro & EF Life Size Converter/EF 180mm f3.5 Macro/EFS 10-22/15-85/17-55 2.8/18-135/60D/7D/Canon TC 1.4x II/1.4x III/TC 2x III/Kenko TC 1.4x Telepro 300 DGX/Di866/LCW ND MarkII/580EXII/Gitzo GH5380S Head/GITZO GT3542LS/Gitzopod G1565/Velbon SPT-1

  
  LOG IN TO REPLY
Jay ­ T
Senior Member
Avatar
463 posts
Gallery: 7 photos
Likes: 212
Joined Mar 2008
Location: phila. pa
     
Jun 29, 2012 12:06 |  #2338

I got mine back from sigma today. It says they replaced a GMR sensor. Seems to be working fine. I sent it out Monday and got it back today.


1DX\ 5diii gripped \ tokina 12-24 f/4 /sigma 24-60 f2.8 \ \ sigma 120-300 OS \ sigma 50 f1.4 \ canon 500 f4 IS \ canon1.4 III tc \ canon 2xii tc \sigma 2x dg tc \ 580ex \ 2x 430ex flickr (external link)

  
  LOG IN TO REPLY
gabebalazs
Bird Whisperer
Avatar
7,640 posts
Gallery: 52 photos
Likes: 1069
Joined Nov 2008
Location: Toledo, OH
     
Jun 29, 2012 12:33 |  #2339

Jay T wrote in post #14649060 (external link)
I got mine back from sigma today. It says they replaced a GMR sensor. Seems to be working fine. I sent it out Monday and got it back today.

That's cool!
What's a GMR sensor???


SONY A7RIII | SONY A7III | SONY RX10 IV | SONY RX100 | 24-70 2.8 GM | 70-200 2.8 GM | 16-35 F/4 | PZ 18-105 F/4 | FE 85 1.8 | FE 28-70 | SIGMA 35 1.4 ART | SIGMA 150-600 C | ROKINON 14 2.8
Gabe Balazs Photo (external link)
Nature Shots Portfolio (external link)

  
  LOG IN TO REPLY
Jay ­ T
Senior Member
Avatar
463 posts
Gallery: 7 photos
Likes: 212
Joined Mar 2008
Location: phila. pa
     
Jun 29, 2012 15:30 |  #2340

gabebalazs wrote in post #14649165 (external link)
That's cool!
What's a GMR sensor???

I googled it and its a magnetic sensor that detects where the focus is at. The sigma 85mm f/1.4 is also known to have the same problem.


1DX\ 5diii gripped \ tokina 12-24 f/4 /sigma 24-60 f2.8 \ \ sigma 120-300 OS \ sigma 50 f1.4 \ canon 500 f4 IS \ canon1.4 III tc \ canon 2xii tc \sigma 2x dg tc \ 580ex \ 2x 430ex flickr (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,610,128 views & 369 likes for this thread
Sigma 120-300 f/2.8 EX OS
FORUMS Sample Photo Archives Lens Sample Photo Archive 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Jesterj75
780 guests, 173 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.