Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
Thread started 16 Jul 2012 (Monday) 17:51
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

SX20 is memory card problem

 
mahgninnuc93
Hatchling
1 post
Joined Jul 2012
     
Jul 16, 2012 17:51 |  #1

I am getting the memory card error as shown in the picture. No matter if I use an old or new card. I am wondring if there is and easy fix for this. Perhaps a custom firmware? If so does anyone know where I can get a custom firmware
It's my wife's camera and she doesn't want to get a new one. Any suggestions would be helpful. We are leaving on our anniversary trip iin 2 days and she wants to take this one not my DSLR. Any help is appreciated!


HOSTED PHOTO
please log in to view hosted photos in full size.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Jon
Cream of the Crop
Avatar
69,628 posts
Likes: 220
Joined Jun 2004
Location: Bethesda, MD USA
     
Jul 16, 2012 19:30 |  #2

Specs on the cards?


Jon
----------
Cocker Spaniels
Maryland and Virginia activities
Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE

  
  LOG IN TO REPLY
bdasmith
Hatchling
8 posts
Likes: 1
Joined Dec 2010
Location: Saskatchewan
     
Jul 16, 2012 23:40 |  #3

Did this error occur "out of thin air"?

have you saved all the pics from memory cards to computer and formatted the sd cards?




  
  LOG IN TO REPLY
imjason
Goldmember
1,667 posts
Likes: 3
Joined Nov 2010
Location: Bay Area, CA
     
Jul 17, 2012 00:30 |  #4

Google around and you will find different solutions (external link).

Some I've found include:
1. Cleaning the contacts of the card reader with electronics contact cleaner.
2. Changing the internal battery (requires disassembly)

Also someone on POTN had a similar problem with a fix: https://photography-on-the.net/forum/showthre​ad.php?t=310525

You can also reset your camera. Take out the battery for a min. Turn on the camera and reformat the card. I doubt a custom firmware would work as there will not be a way for you to install it without the memory card.

Good luck!


Canon gear: EOS M, Canonet QL17, SX230HS, S95, SD1200IS
Non-Canon gear: D600, D5000, D70, XG-2, U20
Flickr (external link)

  
  LOG IN TO REPLY
exwintech
Gone, but not forgotten . . .
551 posts
Joined Apr 2009
Location: Croydon Park, Sydney, Australia
     
Jul 17, 2012 17:58 as a reply to  @ imjason's post |  #5

Mahgninnuc93 - Whether a used or new card, you might be getting a formatting error. How do you format your New cards?

With the SX10-20-30-40 Canons (and some other models) - you can do a Low-Level card format in the camera. See Page 22 in your SX20 Manual. Costs you nothing to try that...

Regards, Dave.




  
  LOG IN TO REPLY
YARDBURNER
Member
116 posts
Joined Dec 2010
Location: Damascus, MD
     
Jul 18, 2012 10:22 as a reply to  @ exwintech's post |  #6

Actually the internal battery is accessed through the AA battery compartment.
There's a little battery holder that slides out from between the AA cells.

It's on page 156 of your manual.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

3,774 views & 0 likes for this thread
SX20 is memory card problem
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Ribosio80
847 guests, 348 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.