Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 12 Sep 2012 (Wednesday) 07:20
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

EOS Utility won't detect 7D/5D Mark III on Windows 8

 
artyman
Sleepless in Hampshire
Avatar
14,403 posts
Gallery: 17 photos
Likes: 71
Joined Feb 2009
Location: Hampshire UK
     
Sep 12, 2012 16:35 |  #16

My son is a software developer and he thinks Windows 8 is rubbish. I work on the principle "if it ain't broke don't fix it" so shan't be rushing to upgrade.


Art that takes you there. http://www.artyman.co.​uk (external link)
Ken
Canon 7D, 350D, 15-85, 18-55, 75-300, Cosina 100 Macro, Sigma 120-300

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
PerfectTan
Senior Member
Avatar
440 posts
Joined Aug 2010
Location: Washington
     
Sep 12, 2012 16:36 |  #17

artyman wrote in post #14982598 (external link)
My son is a software developer and he thinks Windows 8 is rubbish.

Thanks for sharing. Did we ask your son for his opinion?


My Gear: Do you really want to know?

  
  LOG IN TO REPLY
artyman
Sleepless in Hampshire
Avatar
14,403 posts
Gallery: 17 photos
Likes: 71
Joined Feb 2009
Location: Hampshire UK
     
Sep 12, 2012 16:38 |  #18

PerfectTan wrote in post #14982604 (external link)
Thanks for sharing. Did we ask your son for his opinion?

No, but you can have it anyway :D


Art that takes you there. http://www.artyman.co.​uk (external link)
Ken
Canon 7D, 350D, 15-85, 18-55, 75-300, Cosina 100 Macro, Sigma 120-300

  
  LOG IN TO REPLY
waterrockets
Goldmember
Avatar
3,940 posts
Gallery: 8 photos
Likes: 297
Joined Jun 2010
Location: Austin (near TX)
     
Sep 12, 2012 16:46 |  #19

Yeah, pretty much every 2nd major release is OK. Windows 7 actually moved into the "good stuff" category. 8 is 7 with Metro, so they'll surely screw up Metro. 9 should be badass in 2015 though (about the time I buy my used 1D X)
NT +
2000 -
XP +
Vista -
7 +
8 -

The next one should be fine though


1D MkIV | 1D MkIII | 550D w/grip & ML| EF 70-200mm f2.8L| EF 24-105mm f4L IS | Canon EF 100-400mm f/4.5-5.6L IS | Samyang 14mm f/2.8 IF ED UMC | 430EXii | EF 50mm f1.8

  
  LOG IN TO REPLY
OneJZsupra
Goldmember
Avatar
2,378 posts
Joined Aug 2009
Location: Guam
     
Sep 12, 2012 16:56 |  #20

Good to know.


Gear List | Feed Back | My Site (external link)
YN RF-603 O-ring solution


  
  LOG IN TO REPLY
Beanie's ­ Dad
Senior Member
581 posts
Joined Nov 2008
Location: Irvine, Scotland
     
Sep 12, 2012 17:59 |  #21

artyman wrote in post #14982598 (external link)
My son is a software developer and he thinks Windows 8 is rubbish.

I think Windows 8 (for PC) is going to be one of those releases that polarizes users into two camps: those who hate it, and those who really hate it.


5DIII, 5DII, EF24-105, EF 70-200 f4L IS, EF 85 1.8, "Sigmalux" 50 1.4, EF 35 f2, EF17-40 f4L

  
  LOG IN TO REPLY
MakisM1
Cream of the Crop
Avatar
5,634 posts
Gallery: 25 photos
Likes: 377
Joined Dec 2011
Location: Houston
     
Sep 12, 2012 18:05 |  #22

Beanies Dad wrote in post #14982857 (external link)
=Beanie's Dad;14982857]I think Windows 8 (for PC) is going to be one of those releases that polarizes users into two camps: those who hate it, and those who really hate it.

...and then there are those of us PC users who are coldly indifferent :cool:


Gerry
Canon 5D MkIII/Canon 60D/Canon EF-S 18-200/Canon EF 24-70L USM II/Canon EF 70-200L 2.8 USM II/Canon EF 50 f1.8 II/Σ 8-16/ 430 EXII
OS: Linux Ubuntu/PostProcessing: Darktable/Image Processing: GIMP

  
  LOG IN TO REPLY
Stickman
Goldmember
Avatar
1,964 posts
Likes: 2
Joined Nov 2006
     
Sep 12, 2012 21:00 |  #23

PerfectTan wrote in post #14982604 (external link)
Thanks for sharing. Did we ask your son for his opinion?


I'm not sure why you are fussy, but I appreciate the info. :D


Stick
http://www.flickr.com/​photos/stickgunner/ (external link)

  
  LOG IN TO REPLY
rcarlton
Senior Member
Avatar
594 posts
Gallery: 93 photos
Likes: 402
Joined Oct 2011
Location: Dallas, TX
     
Nov 14, 2012 16:24 |  #24

I know this a is an old post...but...I have the same problem. It will not download from my 5D mark II to EOS utilities. Windows 8 recognizes EOS utilities since it asked me how I wanted to download. Selected EOS utilities and get nothing. Options are still grayed out. Looks like I have an old version...will report back if this fixes the problem! Latest version: 2:12.0.0. Installed, rebooted computer still does not work.


Sony α7rii, α6500, Metabones IV, Zeiss Batis 18mm f/2.8, FE 24-70mm f/2.8 GM, FE 50mm f/1.8, EF 70-200L II IS USM f2.8, EF 100mm 1:2.8L IS USM Macro

  
  LOG IN TO REPLY
*Jayrou
Goldmember
Avatar
1,121 posts
Gallery: 5 photos
Likes: 8
Joined Sep 2010
Location: Jersey UK
     
Nov 14, 2012 16:35 |  #25

rcarlton wrote in post #15246181 (external link)
I know this a is an old post...but...I have the same problem. It will not download from my 5D mark II to EOS utilities. Windows 8 recognizes EOS utilities since it asked me how I wanted to download. Selected EOS utilities and get nothing. Options are still grayed out.

Software for Windows 8 is available from the Canon website

"http://www.canon.co.u​k/Support/Consumer_Pro​ducts/products/cameras​/Digital_SLR/EOS_5D_Ma​rk_II.aspx?type=downlo​ad&page=1

Id download everything from there and update


James
Flickr  (external link)
Website (external link)

  
  LOG IN TO REPLY
rcarlton
Senior Member
Avatar
594 posts
Gallery: 93 photos
Likes: 402
Joined Oct 2011
Location: Dallas, TX
     
Nov 14, 2012 16:52 |  #26

Have newest software running...computer does recognize the 5D mark II. Has a driver date of 6/21/2006, driver version 6.2.9200.16384(win8_rt​m.120725-1247). Still won't download files.

Not a show stopper for me as I have a Laptop with Windows 7 which works fine.

Found this on the Canon website (external link): EOS Utility 2.12.0 To launch this application, it may be necessary to download and install .NET3.5.

Still doesn't work.


Sony α7rii, α6500, Metabones IV, Zeiss Batis 18mm f/2.8, FE 24-70mm f/2.8 GM, FE 50mm f/1.8, EF 70-200L II IS USM f2.8, EF 100mm 1:2.8L IS USM Macro

  
  LOG IN TO REPLY
starkyrulz
Senior Member
Avatar
561 posts
Joined Oct 2011
Location: Calcutta, India
     
Nov 14, 2012 22:38 |  #27

eos utility does not recognize mt t3i on windows 8 either - hopefully some future release will.


| 5D Mark III | T3i | 24-70 f2.8 MK II L | 70-200 f2.8 IS mk II L | 18-200 f3.5-5.6 | Σ 30mm f1.4 | 50 f1.8 | 430exII | YongnouYN560 | YongnouRF603 | Vangaurd 263AT |

http://www.flickr.com/​photos/suprateep/ (external link)
http://500px.com/stark​yrulz (external link)

  
  LOG IN TO REPLY
Buylongterm
Goldmember
Avatar
2,080 posts
Gallery: 1 photo
Likes: 55
Joined Jan 2010
Location: Chi-town
     
Nov 14, 2012 23:47 |  #28

I recently installed Windows 8 and I have no issues with the EOS utility and my 5DIII.


Christian
flickr (external link)
@WerthLiving (Follow me on Instagram)
Canon EOS 5D MK III Gripped | 35mm f/1.4L | 70-200mm f/2.8L IS MK II |100mm f/2.8L Macro | 24mm-105mm f/4.0L |

  
  LOG IN TO REPLY
rakesh
THREAD ­ STARTER
Member
225 posts
Likes: 43
Joined Sep 2005
Location: Bangalore, India
     
Nov 15, 2012 00:52 |  #29

I connected my 7D and 5D Mark III. Windows 8 recognizes both the cameras but in EOS Utilities it fails to detect.


Gears:
My WildLife Gallery :
http://www.justwildlif​e.com (external link)
My Kids Project Galleries : http://www.facebook.co​m …otography/15851​1907574485 (external link)

  
  LOG IN TO REPLY
rcarlton
Senior Member
Avatar
594 posts
Gallery: 93 photos
Likes: 402
Joined Oct 2011
Location: Dallas, TX
     
Nov 15, 2012 11:44 |  #30

Tried my old 50D and computer recognizes it, but EOS Utility will not download images as this option is grayed out.


Sony α7rii, α6500, Metabones IV, Zeiss Batis 18mm f/2.8, FE 24-70mm f/2.8 GM, FE 50mm f/1.8, EF 70-200L II IS USM f2.8, EF 100mm 1:2.8L IS USM Macro

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

36,589 views & 0 likes for this thread
EOS Utility won't detect 7D/5D Mark III on Windows 8
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member was a spammer, and banned as such!
1223 guests, 291 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.