Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
Thread started 09 Dec 2012 (Sunday) 16:58
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Pictures are pink and stripy

 
mckiernj
Hatchling
1 post
Joined Dec 2012
     
Dec 09, 2012 16:58 |  #1

I have a Canon G-12. Of course, the week before my wedding and our Maui honeymoon, the camera starts doing funny things. It doesn't always happen, but there are times that the images come up as being pink and stripy. It isn't something that just happens on the screen of the camera because it show up that way on the computer. Also, there isn't anything on the lens of the camera, so I don't know what's wrong. Please give me some insight and see if there is anything I should be doing to make my camera function. Thanks!


HOSTED PHOTO
please log in to view hosted photos in full size.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
crn3371
Cream of the Crop
Avatar
7,198 posts
Likes: 1
Joined Mar 2005
Location: SoCal, USA
     
Dec 09, 2012 23:45 |  #2

Maybe a bad memory card, but really kind of looks like a sensor issue. Try a different card, if that doesn't solve it then it's off to Canon for a repair.




  
  LOG IN TO REPLY
irishjim
Member
Avatar
120 posts
Likes: 1
Joined Apr 2012
Location: Massillon, Ohio
     
Dec 11, 2012 15:39 |  #3

Probably related to the sensor, line errors usually indicate sensor problems.


Canon 7D; Sigma 17-50, EF-S 10-22, Sigma 30mm, Canon 6D; EF 17-40mm, EF 70-200 F2.8 IS II, EF 24-105, Sigma 105mm, Kenko 1.4 & 2.0 Tele con's, Canon G1 X, G5, Konica Minolta 7D & A2, Sony RX100 III.

  
  LOG IN TO REPLY
steve40
Member
Avatar
188 posts
Joined Aug 2011
Location: Asheville, North Carolina
     
Dec 11, 2012 15:42 as a reply to  @ irishjim's post |  #4

Definitely a bad sensor, sooner or later this issue will become a permanent condition.


Steve40.
http://steveslandscape​s.50webs.com (external link)
Cameras: Canon G12, SX150 is, & A1200.
Darkroom & Printer: PhotoShop Elements 9, Canon Pixma iX6520.
Tripods: Manfrotto 190XPROB & Giottos MT 9251 + Several Heads.

  
  LOG IN TO REPLY
Rally ­ Man
Member
199 posts
Joined Jul 2009
Location: SoCal
     
Dec 11, 2012 16:59 |  #5

Agreed, sensor is going kaput.


canon | sigma | thinktank | sandisk | lexar | radiopopper | rrs | b+w | eneloop | creative light | westcott | upstrap

  
  LOG IN TO REPLY
AbPho
Goldmember
Avatar
3,165 posts
Gallery: 2 photos
Likes: 106
Joined Jan 2009
Location: Planet Earth
     
Dec 11, 2012 17:59 as a reply to  @ Rally Man's post |  #6

Better buy a new camera for the trip. Not worth the risk.


I'm in Canada. Isn't that weird!

  
  LOG IN TO REPLY
gug
Senior Member
Avatar
354 posts
Gallery: 27 photos
Likes: 161
Joined Oct 2011
     
Dec 13, 2012 05:58 |  #7

I just had this happen a few weeks back. It is the sensor. You can contact Canon and for about $140.00 they will replace it and anything else needed as well.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,406 views & 0 likes for this thread
Pictures are pink and stripy
FORUMS Canon Cameras, Lenses & Accessories Canon G-series Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is mcsdet
1541 guests, 273 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.