Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Post Processing, Marketing & Presenting Photos Video and Sound Editing 
Thread started 12 Dec 2012 (Wednesday) 18:52
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Magic Lantern for 5dmkii

 
jrm27
Senior Member
797 posts
Likes: 4
Joined Oct 2008
Location: Vail, Co
     
Dec 12, 2012 18:52 |  #1

Hi all,

I'm currently running ML on my t2i and I love it. I want to install it on my 5dmkii. it appears there are two builds... one is the unified build, and the other is a 5dmkii specific build. Does it matter which I install? I'm running the latest firmware (I believe) of 2.1.2.

-jon


http://www.flickr.com/​photos/jrmelot/ (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
dngphoto
Senior Member
Avatar
384 posts
Joined Nov 2011
     
Dec 12, 2012 21:27 |  #2

hey, both of the builds are the same. You need to make sure your 5d2 has the newest firmware prior to installing ML. I followed the instructions provided and installed perfectly. Love ML and have on my t2i and 5d2


Sean - dngphoto&film 5dii Gripped / Σ 50 1.4 / Canon 28-135 USM / Σ 12-24 HSM

  
  LOG IN TO REPLY
akivisuals
Member
67 posts
Joined Mar 2010
Location: Los Angeles
     
Dec 14, 2012 14:39 |  #3

ML 2.3 is the bees knees! :D


Canon 5D3 | 5D2 | 15 fish | 35L | 50L | 50 macro | 85L | 100L macro | 135L | 17-40L | 24-70L | 24-105L | 70-200L IS II | 100-400L | 1.4x | 3x 580EX | 550EX | 2x 540EZ

  
  LOG IN TO REPLY
agphotography
Goldmember
Avatar
3,726 posts
Likes: 5
Joined Mar 2008
Location: Orange County, CA
     
Dec 17, 2012 10:49 |  #4

Agreed, the additional tools provided by ML 2.3 have been extremely helpful.

Though.... has anyone else noticed excessive battery drain as a result of the firmware? I can't quite nail it down but it seems to just chew through my batteries at an alarming rate.


-Abram-
www.goglanianphoto.com (external link)
500px (external link) / Flickr (external link)
Tumblr (external link)

  
  LOG IN TO REPLY
akivisuals
Member
67 posts
Joined Mar 2010
Location: Los Angeles
     
Dec 18, 2012 19:39 |  #5

hmmmm.... haven't noticed my batteries draining any quicker than normal.


Canon 5D3 | 5D2 | 15 fish | 35L | 50L | 50 macro | 85L | 100L macro | 135L | 17-40L | 24-70L | 24-105L | 70-200L IS II | 100-400L | 1.4x | 3x 580EX | 550EX | 2x 540EZ

  
  LOG IN TO REPLY
Scatterbrained
Cream of the Crop
Avatar
8,472 posts
Gallery: 246 photos
Best ofs: 12
Likes: 4298
Joined Jan 2010
Location: Chula Vista, CA
     
Dec 18, 2012 19:58 |  #6

akivisuals wrote in post #15383430 (external link)
hmmmm.... haven't noticed my batteries draining any quicker than normal.

I have. Sometimes considerably. Granted I don't do much video, but I use the intervalometer as well as the bulb timer function and the focus peaking.


VanillaImaging.com (external link)"Vacuous images for the Vapid consumer"
500px (external link)
flickr (external link)
1x (external link)
instagram (external link)

  
  LOG IN TO REPLY
agphotography
Goldmember
Avatar
3,726 posts
Likes: 5
Joined Mar 2008
Location: Orange County, CA
     
Dec 30, 2012 12:10 |  #7

I had to uninstall it from my 5D. It was causing ridiculous battery drain, and it was even draining the batteries while the camera was turned off.

Sometimes the camera wouldn't turn on and I'd have to pull the battery and the memory card out just to get it to start up.

Not worth the hassle for me. I reverted back to stock.


-Abram-
www.goglanianphoto.com (external link)
500px (external link) / Flickr (external link)
Tumblr (external link)

  
  LOG IN TO REPLY
dngphoto
Senior Member
Avatar
384 posts
Joined Nov 2011
     
Dec 30, 2012 19:31 |  #8

^ok had the same problem this past week, however my initial thought would be the non-oem grip i have. I will have to check and see if its ML


Sean - dngphoto&film 5dii Gripped / Σ 50 1.4 / Canon 28-135 USM / Σ 12-24 HSM

  
  LOG IN TO REPLY
ArcticShooter
Goldmember
Avatar
1,828 posts
Likes: 1
Joined Dec 2006
Location: Arctic Norway (Tromsø)
     
Dec 30, 2012 21:19 |  #9

In my 5DmkII it drained the battery 15% faster. So shooting in the arctic made me uninstall it. But I will reinstall when the weather is getting warmer


Helge
Summer is great :)

My gearMy (external link)Flickr  (external link) (external link)G+ (external link)

  
  LOG IN TO REPLY
agphotography
Goldmember
Avatar
3,726 posts
Likes: 5
Joined Mar 2008
Location: Orange County, CA
     
Dec 30, 2012 21:48 |  #10

I could live with battery drain as long as I remembered to take the batteries out first, but I did not like that my camera would occasionally not turn on, that had me worried. My 5DmkII has worked like a champ from day one in 2008 when I got it and now suddenly it's getting glitchy due to ML 2.3, I'm not going to mess with it.


-Abram-
www.goglanianphoto.com (external link)
500px (external link) / Flickr (external link)
Tumblr (external link)

  
  LOG IN TO REPLY
Kolor-Pikker
Goldmember
2,790 posts
Likes: 59
Joined Aug 2009
Location: Moscow
     
Dec 31, 2012 03:04 |  #11

Yep, it drains my batteries too, even when the camera is off, so you're not alone in this. I also have a non-OEM grip, but I've had it for years without fault, ML and bam! Empty batteries.

My only solution thus far is to keep ML on a separate CF card.


5DmkII | 24-70 f/2.8L II | Pentax 645Z | 55/2.8 SDM | 120/4 Macro | 150/2.8 IF
I acquired an expensive camera so I can hang out in forums, annoy wedding photographers during formals and look down on P&S users... all the while telling people it's the photographer, not the camera.

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,945 views & 0 likes for this thread
Magic Lantern for 5dmkii
FORUMS Post Processing, Marketing & Presenting Photos Video and Sound Editing 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is umeiri
897 guests, 204 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.