Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 03 Jan 2013 (Thursday) 17:06
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

New Sigma 17-50 F/2.8 Focus Issue???

 
vsocks
Member
Avatar
172 posts
Joined Dec 2012
Location: Belgium, WI
     
Jan 03, 2013 17:06 |  #1

Just got it brand new and tried it on the 60D. With lens AI on - it goes in/out everytime shutter is depressed half way. Never gets locked on with beep & can't take the picture. Bad copy or am I doing something wrong???? First non canon lens!


Canon 6D, 70D, Rokinon 14mm, 17-40 F4L, Zeiss Planar 50mm f/1.4 T* ZE, 50 f1.8, 85 f/1.8, Canon 24-105 F/4L, 70-200 2.8L IS II, Tamron 150-600 VC, Speedlight 430EX II, 12mm Extension Tube, Canon 1.4X & 2.0X iii Converters

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
wayne.robbins
Goldmember
2,062 posts
Joined Nov 2010
     
Jan 03, 2013 19:34 |  #2

take the lens off.. wipe the contacts off with a soft cloth... put lens back on and ensure it is firmly attached..

Flip the switches both directions a couple of times- and then place it back to the desired settings... If it fails after that- I'd be calling for an RMA --- unless you have another camera around that you can try it on.


EOS 5D III, EOS 7D,EOS Rebel T4i, Canon 70-200 f/2.8 IS II, Canon 24-105L, Canon 18-135 IS STM, 1.4x TC III, 2.0x TC III, Σ 50mm f/1.4, Σ 17-50 OS, Σ 70-200 OS, Σ 50-500 OS, Σ 1.4x TC, Σ 2.0x TC, 580EXII(3), Canon SX-40, Canon S100
Fond memories: Rebel T1i, Canon 18-55 IS, Canon 55-250 IS, 18-135 IS (Given to a good home)...

  
  LOG IN TO REPLY
nccb
Senior Member
425 posts
Joined Aug 2011
     
Jan 03, 2013 20:10 |  #3

"With lens AI on"....not following you. You mean with AI Servo on the camera? Or Lens AF on?

If AI Servo is set I didn't think you'd hear a beep (I may be wrong, not familiar with 60D).

If the lens AF is on and focus mode is one shot, and it hunts constantly, this happened to me as well. I had to send to sigma and get a GMR sensor repair.


5D3 | 24-105mm L | 85mm 1.8

  
  LOG IN TO REPLY
vsocks
THREAD ­ STARTER
Member
Avatar
172 posts
Joined Dec 2012
Location: Belgium, WI
     
Jan 03, 2013 21:23 as a reply to  @ nccb's post |  #4

Surprisingly enough it seems to be working now! We will see if it continues & at first sign of trouble I will send back for replacement. Now I have to test it this weekend some more!


Canon 6D, 70D, Rokinon 14mm, 17-40 F4L, Zeiss Planar 50mm f/1.4 T* ZE, 50 f1.8, 85 f/1.8, Canon 24-105 F/4L, 70-200 2.8L IS II, Tamron 150-600 VC, Speedlight 430EX II, 12mm Extension Tube, Canon 1.4X & 2.0X iii Converters

  
  LOG IN TO REPLY
vsocks
THREAD ­ STARTER
Member
Avatar
172 posts
Joined Dec 2012
Location: Belgium, WI
     
Jan 04, 2013 07:34 as a reply to  @ vsocks's post |  #5

I am beginning to wonder if it was a cold issue......lens was outside for delivery in WI cold....didn't work at first...later worked fine. May have to test this theory to know for sure. Anyone test this lens in cold weather conditions for an extended period??


Canon 6D, 70D, Rokinon 14mm, 17-40 F4L, Zeiss Planar 50mm f/1.4 T* ZE, 50 f1.8, 85 f/1.8, Canon 24-105 F/4L, 70-200 2.8L IS II, Tamron 150-600 VC, Speedlight 430EX II, 12mm Extension Tube, Canon 1.4X & 2.0X iii Converters

  
  LOG IN TO REPLY
wayne.robbins
Goldmember
2,062 posts
Joined Nov 2010
     
Jan 04, 2013 19:42 |  #6

Maybe it wasn't cold--- maybe it was a condensation issue ... just theorizing...


EOS 5D III, EOS 7D,EOS Rebel T4i, Canon 70-200 f/2.8 IS II, Canon 24-105L, Canon 18-135 IS STM, 1.4x TC III, 2.0x TC III, Σ 50mm f/1.4, Σ 17-50 OS, Σ 70-200 OS, Σ 50-500 OS, Σ 1.4x TC, Σ 2.0x TC, 580EXII(3), Canon SX-40, Canon S100
Fond memories: Rebel T1i, Canon 18-55 IS, Canon 55-250 IS, 18-135 IS (Given to a good home)...

  
  LOG IN TO REPLY
nccb
Senior Member
425 posts
Joined Aug 2011
     
Jan 04, 2013 22:09 |  #7

Does it happen at different focus distances? Before sigma repaired it, mine would do fine at distance but have trouble in close (<6 feet). Sent it in and now it's. fine.


5D3 | 24-105mm L | 85mm 1.8

  
  LOG IN TO REPLY
Photojihad
Mostly Lurking
14 posts
Joined Feb 2013
     
Feb 20, 2013 16:23 |  #8
bannedPermanent ban

Sigma has poor quality control...?




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,414 views & 0 likes for this thread
New Sigma 17-50 F/2.8 Focus Issue???
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is cery333
955 guests, 333 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.