Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 24 Feb 2013 (Sunday) 19:37
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

my Canon EOS 550d , TT520 flash speedlite & off canon shoe cord 2 problem.

 
metalkapil
Hatchling
8 posts
Joined Feb 2013
     
Feb 24, 2013 19:37 |  #1

I have a Canon EOS 550d. I use as

  • Canon EOS 550d + TT520 flash speedlite = works OK.
  • Canon EOS 550d + off Canon shoe cord 2 = works OK.



But, when I use
Canon EOS 550d + TT520 flash speedlite + off canon shoe cord 2 = doesn't work

off canon shoe cord 2 cannot send signals to speedlite.

Is there anyone who has the same problem?
How can this be solved?
Camera firmware update is required?

Help please.



  
  LOG IN TO REPLY
imsellingmyfoot
Goldmember
1,025 posts
Gallery: 40 photos
Likes: 161
Joined Apr 2011
Location: Dallas, TX
     
Feb 24, 2013 19:40 |  #2

How are you determining that combination 2 works properly?


Canon 6D | Sigma 24A | Sigma 35A | Canon 50 f/1.8 | Canon 70-200 f/4
Check out Welcome to Downtown Plano (external link), a time lapse video I created.
BLOG (external link)| INSTAGRAM (external link) | flickr (external link) | Buy/Sell Feedback

  
  LOG IN TO REPLY
Jon
Cream of the Crop
Avatar
69,628 posts
Likes: 218
Joined Jun 2004
Location: Bethesda, MD USA
     
Feb 24, 2013 19:45 |  #3

How do you have the 550EX, TT529 and OC-S2 configured? If the TT520 really does work consistently as a remote triggered flash via the 550EX, I'd be surprised if adding a good OC cable made it malfunction.


Jon
----------
Cocker Spaniels
Maryland and Virginia activities
Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE

  
  LOG IN TO REPLY
Wilt
Reader's Digest Condensed version of War and Peace [POTN Vol 1]
Avatar
40,241 posts
Gallery: 1 photo
Likes: 2040
Joined Aug 2005
Location: Belmont, CA
     
Feb 24, 2013 22:20 |  #4

Jon wrote in post #15648226 (external link)
I'd be surprised if adding a good OC cable made it malfunction.

Jon,
I once took my existing OC-E2 cable, a new OC-E3 cable, a new aftermarket cable from Yungnuo and and a new aftermarket cable from another manufacturer (the last two loaned to me by FlashZebra), and my ETTL would reliably work on my 40D hotshoe but would NOT work RELIABLY in ETTL in any one of the four off-camera cords! It kind of flies in the face of that statement of yours, unfortunately.


You need to give me OK to edit your image and repost! Keep POTN alive and well with member support https://photography-on-the.net/forum/donate.p​hp
Canon dSLR system, Olympus OM 35mm system, Bronica ETRSi 645 system, Horseman LS 4x5 system, Metz flashes, Dynalite studio lighting, and too many accessories to mention

  
  LOG IN TO REPLY
CliveyBoy
R.I.P.      He will be missed
Avatar
3,272 posts
Likes: 42
Joined Nov 2005
Location: Tauranga, NZ
     
Feb 25, 2013 06:08 |  #5

metalkapil wrote in post #15648210 (external link)
Canon EOS 550d + TT520 flash speedlite = works OK.
Canon EOS 550d + off Canon shoe cord 2 = works OK.

Canon EOS 550d + TT520 flash speedlite + off canon shoe cord 2 = doesn't work. off canon shoe cord 2 cannot send signals to speedlite.

I seem to be missing something.

550D (T2i) -> on-cam TT520 = OK
550D -> on-cam OC cable -> what? = OK
550D -> on-cam OC cable -> TT520 = Bad
The second configuration is a mystery. Where is a flash to determine "OK"?

The Neewer TT520 is not actually a "Speedlite". And, is your cable a genuine Canon one, or is it a 3rd party one with a hotshoe available at each end?

If it is the latter, they could have built in a switch. The problem is that the Canon system is a two-way communication It is designed to drive only one flash on-camera or on-cable. That flash can be stand-alone or master.

I have a Yongnuo Componor 3-way off-camera cable set, but it has switches at the camera end to ensure that only one flash has full service. Yours could be similar.


Clive, and Great G/D Abbie
50D; 580EXII, 430EXII, 550EX, YN685EX; YN-622C II, YN622C-TX and YN560-TX controllers TOYUG II v5.10 YN622 System Guide (external link)
I tried retiring, but gave it up - it's a dead end

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,668 views & 0 likes for this thread
my Canon EOS 550d , TT520 flash speedlite & off canon shoe cord 2 problem.
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is suitman1
1168 guests, 326 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.