Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
Thread started 15 Apr 2013 (Monday) 11:25
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Stay away from the S95, 100 and 110

 
tvphotog
Cream of the Crop
Avatar
6,093 posts
Gallery: 1 photo
Likes: 37
Joined Aug 2007
Location: New York City
     
Apr 15, 2013 11:25 |  #1

Just got the fatal "lens error" message on my S100. This is the second S100 camera that has failed. This one failed three months after the warranty expired. Stay away from this Product until Canon corrects the problem.


Jay
Ireland in Word and Image (external link) Jay Ben Images (external link)5D IV | 5DS/R | Powershot S100 | 24-105L | 100-400 IIL | 16-35 f/2.8 IIL | 24 T/S f /3.5L II | 17 T/S f/4L | 50mm f/1.2L | 35mm f/1.4L | 70-200 f/2.8L II | 580 EX II | 600 EX-RT | Feisol 3441T/Markins Q3T lever QR | Gitzo 3542L Markins Qi20 BV-22 | Gitzo 5561T RRS MH-02

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
EowynCarter
Member
33 posts
Joined Feb 2012
     
Apr 15, 2013 14:58 |  #2

It's a know problem. Canon repair even outside of warranty period
http://talk.sonymobile​.com/message/298902#29​8902 (external link)

Last batch of the S100 shoudn't be affected.




  
  LOG IN TO REPLY
v35skyline
Goldmember
3,572 posts
Likes: 16
Joined Apr 2007
Location: San Diego, CA
     
Apr 15, 2013 15:35 |  #3

I know this is an issue with the S100, but didn't know the S95 and S110 are affected.


X100s | X-Pro1 | X-T1 | XF 14 | XF 18 | XF 35 | XF 56 | XF 60 | XF 10-24
Gear List & Feedback

  
  LOG IN TO REPLY
Tigerkn
Goldmember
4,064 posts
Likes: 156
Joined Feb 2009
Location: CA
     
Apr 15, 2013 15:37 |  #4

Really, I plan to pick up a S110 for her.


Website (external link) | Facebook (external link) | Instagram (external link) | Gears (external link)

  
  LOG IN TO REPLY
HaroldC3
Goldmember
3,003 posts
Gallery: 24 photos
Likes: 238
Joined May 2007
Location: West Richland, WA
     
Apr 15, 2013 16:22 |  #5

That's the reason why I picked up an S95 and not an S100.


Flickr (external link) ~ Buy/Sell Feedback

  
  LOG IN TO REPLY
avigar
Senior Member
Avatar
296 posts
Gallery: 2 photos
Likes: 8
Joined Jun 2009
Location: Northern IL
     
Apr 15, 2013 18:36 |  #6

tvphotog wrote in post #15830041 (external link)
Just got the fatal "lens error" message on my S100. This is the second S100 camera that has failed. This one failed three months after the warranty expired. Stay away from this Product until Canon corrects the problem.

Possible root cause and DIY fix for the S100 problem is here: http://www.dpreview.co​m/forums/post/51148353 (external link)




  
  LOG IN TO REPLY
leroy_sunset
Senior Member
Avatar
679 posts
Joined Oct 2008
Location: Olympia, WA
     
Apr 15, 2013 20:10 |  #7

My S95 has been going strong for years.


Canon's Jurassic Park - 1Ds, 1D bodies
My traveling buddy: the trusty S95
Newest addition: T2i
Glass - 50mm 1.4, 40mm 2.8 STM, "the dirty 85" 1.8, 100mm 2.8 Macro, 430exII, 270ex, and more... including my favorite Lens: the 17-40mm!

  
  LOG IN TO REPLY
bigpow
Senior Member
708 posts
Likes: 12
Joined May 2002
     
Apr 16, 2013 02:23 |  #8

Must be lucky then.
Had my s95 since launch day (when amazon first stock them)
It's been to several countries now.
Still as good as new.
Doesn't prevent me from buying an RX100 tho..


[5DM2: 50L, 100L, 24-105L, 70-200/2.8IS L II, Zeiss 2/35 ZE]
[Fuji X100S] [Sony A7 II: 55/1.8, 28-70]

  
  LOG IN TO REPLY
loveymiller
Hatchling
Avatar
2 posts
Joined Jan 2013
Location: India
     
Apr 16, 2013 05:21 |  #9

This problems also occurred in 100. I really had a bad experience with it!! :(




  
  LOG IN TO REPLY
dave_bass5
Goldmember
Avatar
4,303 posts
Gallery: 34 photos
Best ofs: 1
Likes: 193
Joined Apr 2005
Location: London, centre of the universe
     
Apr 18, 2013 04:44 |  #10

Never had any issues with my S95. I'm now on a S110 but so far its been fine.
Hopefully it will continue to be fine.


Dave.
Gallery@http://www.flickr.com/​photos/davebass5/ (external link)
Canon 5DMKIV | Canon EOS-M50 | Canon 24-70 f/2.8L MKII | 70-300L | 135L f/2.0 | EF-S 10-18 | 40 f/2.8 STM | 35mm f/2 IS | Canon S110 | Fuji F31FD | Canon 580EXII, 270EXII | Yongnuo YN-622C Triggers.

  
  LOG IN TO REPLY
Madwrench
Senior Member
633 posts
Likes: 8
Joined Feb 2011
     
Apr 18, 2013 15:46 as a reply to  @ dave_bass5's post |  #11

My S95 is just fine after two years of abuse as well.




  
  LOG IN TO REPLY
v35skyline
Goldmember
3,572 posts
Likes: 16
Joined Apr 2007
Location: San Diego, CA
     
Apr 18, 2013 16:05 |  #12

AFAIK, it's only an issue with the S100.


X100s | X-Pro1 | X-T1 | XF 14 | XF 18 | XF 35 | XF 56 | XF 60 | XF 10-24
Gear List & Feedback

  
  LOG IN TO REPLY
riverdog1
Senior Member
335 posts
Joined Oct 2010
Location: East Central IL
     
Apr 19, 2013 13:26 as a reply to  @ v35skyline's post |  #13

With my S-95 I got that one time only. The battery ran out while taking a photo and the
lens was out. I popped in a freshly charged battery and sadly got the lens error message.
I tried several more times of turning the camera on/off etc to no avail. I searched the web
and while coming here first it was elsewhere I got "the fix" (at least it worked for me).
I very gently tapped the camera on a soft surface while turning it on and it "fixed" it the
first try. I have used the camera for a year since with no more problems.




  
  LOG IN TO REPLY
froughty
Member
133 posts
Joined Nov 2011
     
Apr 19, 2013 14:16 |  #14

EowynCarter wrote in post #15830862 (external link)
It's a know problem. Canon repair even outside of warranty period
http://talk.sonymobile​.com/message/298902#29​8902 (external link)

Last batch of the S100 shoudn't be affected.


Can anyone elaborate on this and how to get it? I just called Canon and they're refusing to repair my S95. Same issue




  
  LOG IN TO REPLY
Jon
Cream of the Crop
Avatar
69,628 posts
Likes: 225
Joined Jun 2004
Location: Bethesda, MD USA
     
Apr 19, 2013 18:02 |  #15

froughty wrote in post #15845861 (external link)
Can anyone elaborate on this and how to get it? I just called Canon and they're refusing to repair my S95. Same issue

It's a known problem with the S100, not with the S95 or S110. The S95 and S110 are different optically and mechanically; they didn't have the systemic problems the S100 did with the lens, so Canon's response to you indicates that they consider your problem to be due to some form of user error.


Jon
----------
Cocker Spaniels
Maryland and Virginia activities
Image Posting Rules and Image Posting FAQ
Report SPAM, Don't Answer It! (link)
PERSONAL MESSAGING REGARDING SELLING OR BUYING ITEMS WITH MEMBERS WHO HAVE NO POSTS IN FORUMS AND/OR WHO YOU DO NOT KNOW FROM FORUMS IS HEREBY DECLARED STRICTLY STUPID AND YOU WILL GET BURNED.
PAYPAL GIFT NO LONGER ALLOWED HERE

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

3,394 views & 0 likes for this thread
Stay away from the S95, 100 and 110
FORUMS Canon Cameras, Lenses & Accessories Small Compact Digitals by Canon 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Fireman
3213 guests, 297 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.