Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Forums  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear
Guest
Forums  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear
Register to forums    Log in

 
FORUMS Cameras, Lenses & Accessories Canon G-series Digital Cameras 
Thread started 27 Feb 2014 (Thursday) 14:27
Search threadPrev/next
sponsored links (only for non-logged)

Menu and function buttons not working

 
boppy2010x
Mostly Lurking
12 posts
Joined May 2012
     
Feb 27, 2014 14:27 |  #1

The last few times I've tried to use my G1x I've been unable to access functions or menus.

I can turn the display on and off, which is the bottom part of the wheel around the function button, but no other parts of the wheel work.

And becuase I can't get the Menu button to work, I can't do a reset.

Any suggestions on how to get these functions working again?




  
  LOG IN TO REPLY
CarloY
Senior Member
681 posts
Likes: 30
Joined Sep 2009
     
Feb 28, 2014 00:01 |  #2

If you have not had any problem with exposure to moisture or condensation in the camera, and if the G1X does not have loose-parts rattling inside, has not been dropped... then you could try using a fully-charged new or different battery. Also may as well try new/different SD Card at same time. (let it sit without a battery for some good time >15 min)

It seems you had a previous problem... is it the same camera??
https://photography-on-the.net …/showthread.php​?t=1306827


G9's... enthusiast and hobby clicker... toying w/ Canon 2x Tele & Raynox .7x Wide.

  
  LOG IN TO REPLY
Trumper
Goldmember
1,381 posts
Likes: 619
Joined May 2003
     
Feb 28, 2014 04:05 |  #3

If you have tried all these things you really have to get it looked at .The problem will be cost,weigh up the repair compared to a new camera.




  
  LOG IN TO REPLY
boppy2010x
THREAD ­ STARTER
Mostly Lurking
12 posts
Joined May 2012
     
May 24, 2014 23:37 |  #4

Hi folks, sorry for the delay in getting back here.

The lack of reaction to those buttons continues intermittently. Some days I can take lots of photos, and other days, like now, the buttons work some times and not others.

It's the same camera I bought in 2012. It's never been wet. It has been dropped lightly on to carpet.

It was under hot lights and I have noticed some rippling on the casing on the top. I suspect that may have caused the problem.




  
  LOG IN TO REPLY
PapaGary
Senior Member
Avatar
515 posts
Likes: 5
Joined Jul 2010
Location: Toe-puke-ah, Kansas
     
May 25, 2014 00:23 |  #5

boppy2010x wrote in post #16928168 (external link)
It was under hot lights and I have noticed some rippling on the casing on the top. I suspect that may have caused the problem.

Wow. I would suspect the same.




  
  LOG IN TO REPLY
Trumper
Goldmember
1,381 posts
Likes: 619
Joined May 2003
     
May 26, 2014 08:12 |  #6

If the g1x is built the same as the MK11 then i would think that something has definitely been cooked or maybe dried out connections inside causing intermittent contact through the heat.




  
  LOG IN TO REPLY
sponsored links (only for non-logged)

5,597 views & 0 likes for this thread, 4 members have posted to it.
Menu and function buttons not working
FORUMS Cameras, Lenses & Accessories Canon G-series Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Forums   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset   •  Home

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.58forum software
version 2.58 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is softex
718 guests, 127 members online
Simultaneous users record so far is 15,144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.