Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 21 Apr 2014 (Monday) 06:41
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Autofocus problem Canon EFS 17 - 85 Is lens

 
Antonvdr
Hatchling
1 post
Joined Apr 2014
     
Apr 21, 2014 06:41 |  #1

I have a Canon Efs 17- 85 stabiliser ultrasonic lens. Recently I start to have problems with the autofocus. When you focus on somthing you can hear the lens motor trying to focus. You can see the focus point and the autofocus keep on searching the focus.
What can be the problem and how can it be fixed. I need help please.

Anton
South Africa




  
  LOG IN TO REPLY
RWK
Member
207 posts
Gallery: 2 photos
Likes: 15
Joined Feb 2006
Location: Alaska
     
Apr 21, 2014 08:43 |  #2

The cable is broken inside. $130 in the US to get it fixed at Canon. Not sure how much where you are. About a $5 part on Ebay for the Cable. Requires soldering on a board. Or $30 for the board & cable on ebay. Requires taking the lens totally apart. Most people here on the forum will say to get a different lens.


Rebel T4i 18-55 IS Kit Lens :cool:
Rebel XT Kit Lens
EF-S 17-85
EF 50 1.8
EF 70-300
EF-S 18-135 STM

  
  LOG IN TO REPLY
RWK
Member
207 posts
Gallery: 2 photos
Likes: 15
Joined Feb 2006
Location: Alaska
     
Apr 21, 2014 09:22 as a reply to  @ RWK's post |  #3

Welcome to the Forum.


Rebel T4i 18-55 IS Kit Lens :cool:
Rebel XT Kit Lens
EF-S 17-85
EF 50 1.8
EF 70-300
EF-S 18-135 STM

  
  LOG IN TO REPLY
110yd
Senior Member
774 posts
Likes: 23
Joined Jan 2005
     
Apr 21, 2014 22:40 |  #4

Antonvdr wrote in post #16849788 (external link)
I have a Canon Efs 17- 85 stabiliser ultrasonic lens. Recently I start to have problems with the autofocus. When you focus on somthing you can hear the lens motor trying to focus. You can see the focus point and the autofocus keep on searching the focus.
What can be the problem and how can it be fixed. I need help please.

Anton
South Africa

I had a similar problem with the 17 to 85mm. A trip to the Canon repair facility solved the problem. I believe it was the ribbon cable. My lens would continuously hunt when zoomed long. I do not remember what the repair cost was. If I had it to do over, I would park the money in another lens...I have not used the 17 to 85mm since getting it repaired. It will only work with older bodies.

Regards,

110yd




  
  LOG IN TO REPLY
RWK
Member
207 posts
Gallery: 2 photos
Likes: 15
Joined Feb 2006
Location: Alaska
     
Apr 22, 2014 00:04 |  #5

110yd wrote in post #16851775 (external link)
It will only work with older bodies.

Regards,

110yd

It works on newer bodies still. Canon still makes EF-S.


Rebel T4i 18-55 IS Kit Lens :cool:
Rebel XT Kit Lens
EF-S 17-85
EF 50 1.8
EF 70-300
EF-S 18-135 STM

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,277 views & 0 likes for this thread
Autofocus problem Canon EFS 17 - 85 Is lens
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is 7DMalinois
802 guests, 213 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.