Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Photography Talk by Genre General Photography Talk 
Thread started 28 May 2014 (Wednesday) 07:05
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

6d issue with Exposure Mode Button

 
rebeen
Member
217 posts
Likes: 3
Joined Nov 2007
Location: AUS
     
May 28, 2014 07:05 |  #1

hi there
This (6D canon) camera 4 week old and 10 day after purchased this happen I Don't know how it happened but it happened any idea how to fix it or what to do

IMAGE NOT FOUND
IMAGE IS A REDIRECT OR MISSING!
HTTP response: NOT FOUND | MIME changed to 'image/gif' | Redirected to error image by FLICKR
photo (external link) by rebeen world (external link), on Flickr

Canon EOS 6D,Canon EOS 5D mark II,Canon EOS 40D, lens: canon 70-200 f2.8L ,canon 40mm F1.8 ,canon 50mm f1.8,Tamron 90mm macro f2.8 /Tokina 12-24mm f4,Sigma 24 F1.8 DG,Canon 17-40 f4L,Canon 35-70 f4
http://www.flickr.com/​photos/rebeen_photogra​phy/ (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
John ­ from ­ PA
Cream of the Crop
10,054 posts
Likes: 1060
Joined May 2003
Location: Southeast Pennsylvania
     
May 28, 2014 07:29 |  #2

Warranty???




  
  LOG IN TO REPLY
Blaster6
Member
Avatar
238 posts
Likes: 1
Joined Feb 2013
Location: Central PA
     
May 28, 2014 07:35 |  #3

I would say that is a warranty issue. If no warranty can it be glued? Never looked under mine.

1-800-OK-CANON


No, I never claimed to be outstanding in the field of photography. I said I was out standing in the field taking photos.

  
  LOG IN TO REPLY
rebeen
THREAD ­ STARTER
Member
217 posts
Likes: 3
Joined Nov 2007
Location: AUS
     
May 28, 2014 07:40 |  #4

Is that is cover by Warranty ?


Canon EOS 6D,Canon EOS 5D mark II,Canon EOS 40D, lens: canon 70-200 f2.8L ,canon 40mm F1.8 ,canon 50mm f1.8,Tamron 90mm macro f2.8 /Tokina 12-24mm f4,Sigma 24 F1.8 DG,Canon 17-40 f4L,Canon 35-70 f4
http://www.flickr.com/​photos/rebeen_photogra​phy/ (external link)

  
  LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
10,054 posts
Likes: 1060
Joined May 2003
Location: Southeast Pennsylvania
     
May 28, 2014 10:55 |  #5

rebeen wrote in post #16935465 (external link)
Is that is cover by Warranty ?

I don't see any dents or anything similar that would indicate a hard knock so if a valid warranty exists I would say it is covered. Note I said "valid" so if you purchased it used then it may not be covered.




  
  LOG IN TO REPLY
eriet30
Goldmember
Avatar
2,651 posts
Gallery: 1 photo
Likes: 2666
Joined Jul 2011
Location: Phoenix AZ
     
May 28, 2014 10:59 as a reply to  @ John from PA's post |  #6

Happened 2x on my 6d .... then I dropped it 3 stories and it popped off again!!!!

They replaced the whole button this time... but not under warranty for me.


"Vision is the art of seeing that which is invisible"
http:// … flickr (external link) www.paulvanderveen.net (external link)

A9 / A7R4 -CV10, Tam 17-28, Loxia 21, CV40, Tam 70-180, FE 100-400GM, FE 200-600 G, Rok 8mm Fish, Sony 1.4x
Legacy Glass: Canon FD 55 1.2 / Jupiter 9 85mm 1.4 / Viv S1 90 2.5 macro FOR SALE A6000InfraRed,

  
  LOG IN TO REPLY
rebeen
THREAD ­ STARTER
Member
217 posts
Likes: 3
Joined Nov 2007
Location: AUS
     
May 28, 2014 21:52 |  #7

are you serious eriet30 from 3 stories , My one didn't drop on me , the problem i need to send it to another state because canon his one branch in all australia for servicing ????


Canon EOS 6D,Canon EOS 5D mark II,Canon EOS 40D, lens: canon 70-200 f2.8L ,canon 40mm F1.8 ,canon 50mm f1.8,Tamron 90mm macro f2.8 /Tokina 12-24mm f4,Sigma 24 F1.8 DG,Canon 17-40 f4L,Canon 35-70 f4
http://www.flickr.com/​photos/rebeen_photogra​phy/ (external link)

  
  LOG IN TO REPLY
eriet30
Goldmember
Avatar
2,651 posts
Gallery: 1 photo
Likes: 2666
Joined Jul 2011
Location: Phoenix AZ
     
May 29, 2014 00:45 as a reply to  @ rebeen's post |  #8

You could always super glue it but i hate to even suggest that.

Yes I was on a construction site getting on a ladder and for some reason did not have it strapped to the wrist so as i grabbed the ladder it slipped through hit the third floor deck bounced and then in slow motion fell 3 stories to concrete..... hitting lens 17-40 first. Lens is toast bent the rim bounced the outer lens off (amazing did not shatter or scratch) and small plastic part inside came out. Camera then took the second bounce and slightly bend the metal strap attachment the part you show fell off and the eyecup dislodged. Canon replaced the knob and also replaced the screen back although I did not notice an issue I am CPS gold so they did the repair for 175. I do have to send it back as the new screen has light bleed in the bottom corner but that is under the repair warranty.

If your good with glue might be the fast cheap fix for that top part. but it is a design flaw that it pops off so easy.


"Vision is the art of seeing that which is invisible"
http:// … flickr (external link) www.paulvanderveen.net (external link)

A9 / A7R4 -CV10, Tam 17-28, Loxia 21, CV40, Tam 70-180, FE 100-400GM, FE 200-600 G, Rok 8mm Fish, Sony 1.4x
Legacy Glass: Canon FD 55 1.2 / Jupiter 9 85mm 1.4 / Viv S1 90 2.5 macro FOR SALE A6000InfraRed,

  
  LOG IN TO REPLY
rebeen
THREAD ­ STARTER
Member
217 posts
Likes: 3
Joined Nov 2007
Location: AUS
     
May 29, 2014 04:21 |  #9

that is quiet story man amazing it is a life after all this bounce good lock for next time actually i went to camera repair shop and they glued but the glue come of afere cple day thanks for all input man much appreciated


Canon EOS 6D,Canon EOS 5D mark II,Canon EOS 40D, lens: canon 70-200 f2.8L ,canon 40mm F1.8 ,canon 50mm f1.8,Tamron 90mm macro f2.8 /Tokina 12-24mm f4,Sigma 24 F1.8 DG,Canon 17-40 f4L,Canon 35-70 f4
http://www.flickr.com/​photos/rebeen_photogra​phy/ (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,078 views & 0 likes for this thread
6d issue with Exposure Mode Button
FORUMS Photography Talk by Genre General Photography Talk 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is kennthadams
827 guests, 245 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.