Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 11 Sep 2014 (Thursday) 11:15
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

canon 70-200 ver II having issues

 
ralliart_04
Senior Member
260 posts
Likes: 3
Joined Aug 2008
     
Sep 11, 2014 11:15 |  #1

when i put on this lens on my canon 5d2, the lens makes noise. When I look at the evf and the lcd screen, the image i see shifts. When the camera is on menu, the noise stops. Has anyone experienced this issue?


Canon 6D/ 7D2 / 50 F1.4 / 70-200 F2.8L IS II / / 135L / Fuji X-T1 / Fuji 23 F1.4 ; Flashes: 2 x Yongnuo 600
Feedback:https://photography-on-the.net …showthread.php?​p=17932199

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
joeblack2022
Goldmember
3,005 posts
Likes: 5
Joined Sep 2011
Location: The Great White North
     
Sep 11, 2014 11:22 |  #2

It sounds like your IS is working. It doesn't work silently.

Try turning IS off and see what happens.


Joel

  
  LOG IN TO REPLY
ralliart_04
THREAD ­ STARTER
Senior Member
260 posts
Likes: 3
Joined Aug 2008
     
Sep 11, 2014 11:23 |  #3

i tried to turn off the IS and even the AF and still, there is something making noise inside it. The noise it creates is really loud.


Canon 6D/ 7D2 / 50 F1.4 / 70-200 F2.8L IS II / / 135L / Fuji X-T1 / Fuji 23 F1.4 ; Flashes: 2 x Yongnuo 600
Feedback:https://photography-on-the.net …showthread.php?​p=17932199

  
  LOG IN TO REPLY
vienhuynh
Senior Member
308 posts
Likes: 33
Joined Jun 2012
     
Sep 11, 2014 12:17 |  #4

may be u have a leprechaun inside your lens...


6D|Canon EF 24-70mmL f2.8ii|Canon EF 17-40mmL|Canon 70-200mmL f2.8 ii|Dolica

  
  LOG IN TO REPLY
ralliart_04
THREAD ­ STARTER
Senior Member
260 posts
Likes: 3
Joined Aug 2008
     
Sep 11, 2014 20:52 |  #5

So im assuming my lens then is an isolated one. No one seems to have an issue with it.


Canon 6D/ 7D2 / 50 F1.4 / 70-200 F2.8L IS II / / 135L / Fuji X-T1 / Fuji 23 F1.4 ; Flashes: 2 x Yongnuo 600
Feedback:https://photography-on-the.net …showthread.php?​p=17932199

  
  LOG IN TO REPLY
Reservoir ­ Dog
A Band Apart
Avatar
3,279 posts
Gallery: 469 photos
Best ofs: 9
Likes: 435
Joined Jan 2013
Location: Out of the pack
     
Sep 11, 2014 21:44 |  #6

No no issue, i got loud sound with the 100-400 2 years ago, Iris and IS was dead ...


150 Free online photos editing application (external link) / 100 Free Desktop Photo Editor Software (external link) / Free Photography eBooks (external link) / My photography blog (external link)

  
  LOG IN TO REPLY
ralliart_04
THREAD ­ STARTER
Senior Member
260 posts
Likes: 3
Joined Aug 2008
     
Sep 11, 2014 22:02 |  #7

Did you get it repaired?


Canon 6D/ 7D2 / 50 F1.4 / 70-200 F2.8L IS II / / 135L / Fuji X-T1 / Fuji 23 F1.4 ; Flashes: 2 x Yongnuo 600
Feedback:https://photography-on-the.net …showthread.php?​p=17932199

  
  LOG IN TO REPLY
Reservoir ­ Dog
A Band Apart
Avatar
3,279 posts
Gallery: 469 photos
Best ofs: 9
Likes: 435
Joined Jan 2013
Location: Out of the pack
     
Sep 11, 2014 22:17 |  #8

ralliart_04 wrote in post #17149225 (external link)
Did you get it repaired?

Yes sure, total cost me around $300 > power diaphragm+IS+labor+vat (but i'm not in the USA ;) )


150 Free online photos editing application (external link) / 100 Free Desktop Photo Editor Software (external link) / Free Photography eBooks (external link) / My photography blog (external link)

  
  LOG IN TO REPLY
DreDaze
happy with myself for not saying anything stupid
Avatar
18,032 posts
Gallery: 40 photos
Likes: 2230
Joined Mar 2006
Location: S.F. Bay Area
     
Sep 11, 2014 22:40 |  #9

can you take, and upload a video of it?

when i bought my first DSLR and the kit 28-135IS...the lens made a crazy ticking sound...most said it was probably the IS, until i posted the video...it sounded like it had a bomb in there

a video will help others tell you if it's normal, or a defect


Andre or Dre
gear list
Instagram (external link)
flickr (external link)

  
  LOG IN TO REPLY
bobbyz
Cream of the Crop
19,409 posts
Likes: 1537
Joined Nov 2007
Location: Bay Area, CA
     
Sep 12, 2014 00:48 |  #10

It is grinding noise? I have seen posts here where folks get loud grinding kid of noise from their 70-200mm f2.8 IS II. Usually faulty IS unit.


5dmk3, 35L, 85L II, 300mm f2.8 IS I, 400mm f5.6
Fuji XT-1, 14mm f2.8, 23mm f1.4, 35mm f1.4, 56mm f1.2, 90mm f2, 50-140mm f2.8

  
  LOG IN TO REPLY
the ­ flying ­ moose
Goldmember
1,635 posts
Likes: 73
Joined Dec 2006
     
Sep 12, 2014 02:16 |  #11

DreDaze wrote in post #17149286 (external link)
can you take, and upload a video of it?

when i bought my first DSLR and the kit 28-135IS...the lens made a crazy ticking sound...most said it was probably the IS, until i posted the video...it sounded like it had a bomb in there

a video will help others tell you if it's normal, or a defect

I bought a used 28-135 and the sound it made was like a whirring. It was quite loud but didn't affect the image as far as I know.




  
  LOG IN TO REPLY
c2thew
Goldmember
Avatar
3,929 posts
Likes: 4
Joined Aug 2008
Location: Not enough minerals.
     
Sep 12, 2014 04:46 |  #12

sounds like a damaged IS unit. It happened to me on a canon 100-400L lens.


Flickr (external link) |Gear|The-Digital-Picture (external link)|The $6 mic | MAGIC LANTERN (external link) | Welding Filter
Go Support Magic Lantern 2.3!!

  
  LOG IN TO REPLY
Invertalon
Cream of the Crop
Avatar
6,495 posts
Likes: 21
Joined Jun 2009
Location: Cleveland, OH
     
Sep 12, 2014 06:24 |  #13

He said he turned the IS off and still makes the noise.


-Steve
Facebook (external link)
Flickr (external link)

  
  LOG IN TO REPLY
ralliart_04
THREAD ­ STARTER
Senior Member
260 posts
Likes: 3
Joined Aug 2008
     
Sep 12, 2014 08:18 |  #14

I tried it again last night. It is a grinding sound. When I had thr camera with the lens facing up or down, the sound stops, regardless whether IS is turned on or off. Sounds like it is a faulty IS unit.

Anyone who had it, what did you suspect was the cause of it?


Canon 6D/ 7D2 / 50 F1.4 / 70-200 F2.8L IS II / / 135L / Fuji X-T1 / Fuji 23 F1.4 ; Flashes: 2 x Yongnuo 600
Feedback:https://photography-on-the.net …showthread.php?​p=17932199

  
  LOG IN TO REPLY
c2thew
Goldmember
Avatar
3,929 posts
Likes: 4
Joined Aug 2008
Location: Not enough minerals.
     
Sep 12, 2014 11:31 |  #15

Invertalon wrote in post #17149669 (external link)
He said he turned the IS off and still makes the noise.


again... I experienced the same issue with the IS switch on off mode as well.... Canon replaced the image stabilization unit for $250 with CPS gold membership.


Flickr (external link) |Gear|The-Digital-Picture (external link)|The $6 mic | MAGIC LANTERN (external link) | Welding Filter
Go Support Magic Lantern 2.3!!

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,003 views & 0 likes for this thread
canon 70-200 ver II having issues
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is HamPhoto
869 guests, 314 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.