Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
Thread started 01 Dec 2014 (Monday) 10:43
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Questions, questions....

 
this thread is locked
mmmfotografie
hanging up-side-down in a cave
2,114 posts
Likes: 491
Joined Jul 2013
Location: Helsinki Airport
     
Dec 01, 2014 14:38 as a reply to  @ post 17301146 |  #46

I don't see anything strange in Wireshark and my pictures are replaced by POTN with this link:

https://photography-on-the.net …UI_images/img_e​rror_1.png




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,756 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1522
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 01, 2014 14:43 |  #47

lovemyram4x4 wrote in post #17301216 (external link)
In there gear section it says there are dedicated threads for requesting additions/corrections. I'm not seeing any aside from the request for gear photos. I'm not sure how you want to do this but I think a single pinned thread may be easier than multiple threads for you(Pekka) or any others you may have helping. I've already came across some errors and missing items while trying to find my gear to add. Should I(or someone) start a single thread for additions/corrections?

Started one here:
https://photography-on-the.net …/showthread.php​?t=1409239


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
ppmax
Member
170 posts
Likes: 32
Joined Feb 2009
     
Dec 01, 2014 14:45 |  #48

Pekka wrote in post #17301215 (external link)
There is zero browser-related js code.

Proxies can do anything, good and bad.

??

You've got 7 referenced JS files, not including any inline JS that may exist, so there is definitely client side code running. I was asking if the link for the login button was hardcoded in your PHP files or if it is rendered client side?

Re squid:
I don't have any troubles logging into other sites, nor did I have any troubles logging into the previous site. This site is new, so it's not unreasonable to think there may be an issue with the site, rather than the proxy server.

Is there anything specific you want me to check when I get back to Safari?

thx
PP


Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
Pekka
THREAD ­ STARTER
El General Moderator
Avatar
17,756 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1522
Joined Mar 2001
Location: Hellsinki, Finland
     
Dec 01, 2014 14:47 |  #49

mmmfotografie wrote in post #17301241 (external link)
I don't see anything strange in Wireshark and my pictures are replaced by POTN with this link:

https://photography-on-the.net …UI_images/img_e​rror_1.png

For example in your post https://photography-on-the.net …showthread.php?​p=17275882 the images are not returned as the URL tells. That is why AMASS does not embed them, but give an explanation why and link to them. This is for member safety.

The image calls to that server you use are apparently passing though some system which returns a 12KB png and then redirects.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
dalto
Senior Member
Avatar
758 posts
Likes: 16
Joined Apr 2009
Location: Austin, TX
     
Dec 01, 2014 14:47 |  #50

+1 on the why can't you mark all forums read question? This seems like fairly useful functionality.

My other question would be is there a way to see if a forum has any unread posts in it or do you have to click in and out of each forum individually?

Lastly, I know you already addressed it but the ability to subscribe to forums is a hugely useful feature and I would love to see it in a future release.

Thanks!




  
  LOG IN TO REPLY
mmmfotografie
hanging up-side-down in a cave
2,114 posts
Likes: 491
Joined Jul 2013
Location: Helsinki Airport
Post edited over 4 years ago by mmmfotografie.
     
Dec 01, 2014 14:54 as a reply to  @ Pekka's post |  #51

Maybe because the referring URL is different of the requesting URL

referring is: http://photography-on-the (external link) dot net
requesting is: http://images.photogra​phy-on-the (external link) dot net

I will try it with the redirecting control off.




  
  LOG IN TO REPLY
vipergts831
Has the TF retired? Or just being utterly lazy?
Avatar
43,923 posts
Gallery: 38 photos
Likes: 230
Joined Apr 2009
Location: Taking better shots with an iPhone than MDJAK with a 1DX
     
Dec 01, 2014 14:57 |  #52

Flickr Exif extract does not work.

Seems to be since it points to a link.

For personal gallery can Camera + lens be the only mandatory information to be requested while making everything else optional? Makes it easier to add images to our galleries when auto exif info retrieval does not work.


-Omar- Flickr (external link) , 5px (external link)
Phaseone 645DF+...because only the best will make up for my lack of skills.
Beginners worry about gear, professionals worry about skill and masters worry about light

  
  LOG IN TO REPLY
ppmax
Member
170 posts
Likes: 32
Joined Feb 2009
     
Dec 01, 2014 14:58 |  #53

ppmax wrote in post #17301284 (external link)
??

You've got 7 referenced JS files, not including any inline JS that may exist, so there is definitely client side code running. I was asking if the link for the login button was hardcoded in your PHP files or if it is rendered client side?

Re squid:
I don't have any troubles logging into other sites, nor did I have any troubles logging into the previous site. This site is new, so it's not unreasonable to think there may be an issue with the site, rather than the proxy server.

Is there anything specific you want me to check when I get back to Safari?

thx
PP

Your login form contains code like this:
<form action="./" method="post">
etc...

I bet a ham sandwich that your action tag is the source of the problem. An action attribute value should be a URI; "./" contains no protocol identifier. So even though it might "work" it's probably not "right." Since it contains no protocol identifier, what should the client do...assume it's http or https or...?



HOSTED PHOTO
please log in to view hosted photos in full size.


Hope this helps--
PP

Canon 1DX Mark II, EF 100-400 f/4.5-5.6 IS USM Mark II, EF 70-200mm f/4L IS USM, EF 24-105mm f/4L IS USM, EF 50mm f/1.4
Rokinon 85mm f/1.4 AS IF, 14mm f/2.8 ED AS IF UMC

  
  LOG IN TO REPLY
jc1350
Member
157 posts
Likes: 6
Joined Apr 2006
Location: Maryland
     
Dec 01, 2014 15:04 |  #54

no "mark forums read" command

Read more at: https://photography-on-the.net …/showthread.php​?t=1409170

Bummer. I use that all the time on all the forums I frequent to help me quickly pick up where I last left off.


--
John

  
  LOG IN TO REPLY
mmmfotografie
hanging up-side-down in a cave
2,114 posts
Likes: 491
Joined Jul 2013
Location: Helsinki Airport
Post edited over 4 years ago by mmmfotografie. (4 edits in all)
     
Dec 01, 2014 15:04 as a reply to  @ Pekka's post |  #55

OK I have a work around......

I edit my posting with the pictures that are not show and save the posting. Then I wait until images.photography-on-the.net has read in the pictures and on success the pictures are shown. I can see the pictures being checked in my Apache log.

This the redirect of the images check:

162.252.87.117 - - [01/Dec/2014:22:17:10 +0100] "GET /files/POTN/Daiki/Daik​i-1.jpg HTTP/1.1" 302 240 "https://photography-on-the.net" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0"

I have now changed the filtering so that the image.photography-on-the.net is filtered out and allowed to to access without a matching referrer. I am sure that on other sites the referrer check is present.

Now I have a good check of the picture:

162.252.87.117 - - [01/Dec/2014:23:25:06 +0100] "GET /files/POTN/Daiki/Daik​i-1.jpg HTTP/1.1" 200 201659 "https://photography-on-the.net" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0"




  
  LOG IN TO REPLY
BrandonSi
Nevermind.. I'm silly.
Avatar
5,306 posts
Gallery: 62 photos
Best ofs: 1
Likes: 143
Joined Sep 2004
Location: Chicago
     
Dec 01, 2014 15:14 |  #56

Any thoughts around moving the '[whatever camera body] UNITE!' threads from the camera discussion forum to the actual camera sample forum. All those are are 90% photos, and it fits in with the lens samples already there.. :)


[ www (external link)· flickr (external link)]

  
  LOG IN TO REPLY
SkipD
Cream of the Crop
Avatar
20,476 posts
Likes: 154
Joined Dec 2002
Location: Southeastern WI, USA
Post edited over 4 years ago by SkipD.
     
Dec 01, 2014 15:14 |  #57

Yno wrote in post #17300957 (external link)
Why no "mark forums read" command? I'm old enough that I sometimes forget what I have read...

I agree with the above question. I really need a "mark forums read" tool as there's no way that I can open every thread just to mark them as "read". I just want to show what's new since I last logged on. Thus, I always "mark forum read" as I leave each forum area. I do the same thing in most forums (except one other that doesn't have the "mark forums read" tool and it's a royal pain there).

Great project, Pekka. I can only imagine the work that went into it.

Thanks.


Skip Douglas
A few cameras and over 50 years behind them .....
..... but still learning all the time.

  
  LOG IN TO REPLY
mguffin
Goldmember
Avatar
2,627 posts
Gallery: 17 photos
Likes: 17
Joined Jul 2010
Location: Allendale, NJ
     
Dec 01, 2014 15:45 |  #58

Very nice indeed...


Mike
Nikon D800 ~ Nikon D500
Sigma 35 f/1.4 DG ~ Nikkor 50 f/1.8G ~ Nikkor 85 f/1.8G ~ Nikkor 12-24 f/4 DX ~ Nikkor 17-55 f/2.8 DX ~ Nikkor 70-200 f/2.8 VR ~ Sigma 18-35 f/1.8 DC ~ Sigma 50-100 f/1.8 DC

  
  LOG IN TO REPLY
Harm
I don't always post, but when I do, I drink Dos Equis....
Avatar
48,610 posts
Gallery: 13 photos
Likes: 471
Joined Jan 2008
     
Dec 01, 2014 15:55 |  #59

SkipD wrote in post #17301397 (external link)
I agree with the above question. I really need a "mark forums read" tool as there's no way that I can open every thread just to mark them as "read". I just want to show what's new since I last logged on. Thus, I always "mark forum read" as I leave each forum area. I do the same thing in most forums (except one other that doesn't have the "mark forums read" tool and it's a royal pain there).

Great project, Pekka. I can only imagine the work that went into it.

Thanks.

Skip, on the top menu is the "new and followed" menu.

When you click on that, you get that list of all your subscribed threads or all the new threads that are on the forum. On the right of that list is an a column where you can click on a thread to say "all seen". I think that is what you are after...


SmugMug (external link)

  
  LOG IN TO REPLY
myphotographic
Member
Avatar
218 posts
Likes: 12
Joined Oct 2010
     
Dec 01, 2014 16:34 |  #60

Some of the sub-forums have a column of recently posted photos down the left. While I understand the idea, I'm finding it horrendously distracting to the eye as I try to scan down the list of threads. Is there a way to turn these off, or if not can it be added to the to-do list of features to add?


Paul

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

111,448 views & 181 likes for this thread
Questions, questions....
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is Smoky Moments
953 guests, 295 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.