Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 25 May 2003 (Sunday) 04:01
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

canon 10D \"error99\"

 
bgaras2001
Member
120 posts
Joined Oct 2002
     
May 25, 2003 04:01 |  #1

i just got my 10D yesterday. i shot 10 frames and got "error99" and cant get rid of it. i tryed both batteries and 3 different flash cards . have you ever had this problem? is there a fix ?




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
garybermanphotography
Junior Member
20 posts
Joined Apr 2003
     
May 25, 2003 04:19 |  #2

If you look through this board you will find several messages about the "Error 99"...It seems to happen with certain lenses that are not compatible or need to be updated for the 10D....What lenses are you using in your 10D....is it an older lens...or a non Canon lens ???




  
  LOG IN TO REPLY
neil_r
Cream of the Proverbial Crop
Landscape and Cityscape Photographer 2006
Avatar
18,065 posts
Likes: 8
Joined Jan 2003
Location: The middle of the UK
     
May 25, 2003 04:20 |  #3

Save you hunting look here:-

https://photography-on-the.net …wthread.php?t=1​1095#53351


Neil


Neil - © NHR Photography
Commercial Site (external link) - Video Site (external link) - Blog - (external link)Gear List There are no rules for good photographs, there are only good photographs. ~ Ansel Adams

  
  LOG IN TO REPLY
aripeka_john
Hatchling
6 posts
Joined May 2003
     
May 25, 2003 16:53 |  #4

Sigma is re chipping non HSM lenses for free.




  
  LOG IN TO REPLY
tzrider
Member
66 posts
Joined May 2003
     
May 28, 2003 02:46 |  #5

Err99 is a typical 10D error and many 10D's are
sended back to Canon because if this. This
seems to be a larger problem the the front or
backfocus. Many dealers do an initial check
on the bodies before selling them to check if
this error occurs .... So send it back to Canon,
and be patient, very patient ....

Err99:DESCRIPTION: This error occurs if there is an internal malfunction detected during the camera's self-checking procedure that's executed before every attempted exposure. This is somewhat similar to the flashing 'BC' warning that occasionally appears on EOS-1 series 35mm SLRs.
REMEDIAL MEASURE: Try releasing the error by turning the main power switch OFF and then back ON. If this does not solve the problem, have the EOS D60 examined by a qualified service technician. Please be careful to note the conditions under which the error message occurred. This error is similar to Error 09 or Error 10 on the D30.




  
  LOG IN TO REPLY
woody60
Senior Member
Avatar
482 posts
Gallery: 13 photos
Likes: 37
Joined Jul 2007
Location: Dorset On Englands South Coast
     
Sep 27, 2015 05:41 |  #6

This is quite a common problem , take off the lens and try cleaning the contacts with a rubber/ eraser , try another lens [Some lenses don't seem to contact correctly] try another memory card , if still the same then try a new battery or a different one , this error mostly seems to be a communication error between the lens and body . hope this works . ;-)a


Powershot SX40 HS

  
  LOG IN TO REPLY
sandpiper
Cream of the Crop
Avatar
7,171 posts
Gallery: 1 photo
Likes: 50
Joined Aug 2006
Location: Merseyside, England
     
Sep 27, 2015 09:23 |  #7

woody60 wrote in post #17723227 (external link)
This is quite a common problem , take off the lens and try cleaning the contacts with a rubber/ eraser , try another lens [Some lenses don't seem to contact correctly] try another memory card , if still the same then try a new battery or a different one , this error mostly seems to be a communication error between the lens and body . hope this works . ;-)a

As the last post in this thread was over 12 years ago, I imagine that the OP has changed camera several times since he had this problem. If they ARE still using the 10D with the problem, I would think that they fixed it by now.




  
  LOG IN TO REPLY
davesrose
Title Fairy still hasn't visited me!
3,640 posts
Likes: 503
Joined Apr 2007
Location: Atlanta, GA
     
Sep 27, 2015 09:40 |  #8

Wow, this is the most epic thread bump I think I've ever seen!:lol:


Canon 5D mk IV
EF 135mm 2.0L, EF 70-200mm 2.8L IS II, EF 24-70 2.8L II, EF 50mm 1.4, EF 100mm 2.8L Macro, EF 16-35mm 4L IS, Sigma 150-600mm C, 580EX, 600EX-RT, MeFoto Globetrotter tripod, grips, Black Rapid RS-7, CAMS plate and strap system, Lowepro Flipside 500 AW, and a few other things...
smugmug (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

2,212 views & 2 likes for this thread
canon 10D \"error99\"
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is astrobalcony
786 guests, 228 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.