Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
Thread started 02 Aug 2017 (Wednesday) 03:08
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Canon 70-200 f/2.8 unusual problem

 
go4saket
Member
124 posts
Likes: 4
Joined Jul 2007
Location: India
     
Aug 02, 2017 03:08 |  #1

Hi guys. I brought a new Canon 70-200 lens a few days back without warranty. It was working fine when I brought it. Now when I switch on the camera, the focus motor keeps working continuously even when the shutter is not pressed. It allows me to take photos but no focus can be set as the focus motor is running all the time. When I try to go to live view mode, there is no display amd when I try to go to video mode, it gives an error message saying "ensure the lens is attached" and even that time the motor keeps running. I have tried going to manual mode amd also switched off the IS but nothing is working.

Please help.


Canon 6D, 24-105 f/4L IS, 55-250 f/3.5-5-6 IS, 50MM f/1.8, Yongnuo 600RT+E3RT, Sekonic L-308S
Experience : Learning :)

  
  LOG IN TO REPLY
TreeburnerCT
Senior Member
Avatar
416 posts
Gallery: 102 photos
Likes: 404
Joined Dec 2016
Location: Stratford, CT, USA
     
Aug 02, 2017 06:36 |  #2

Have you tried cleaning the contacts on the lens and body? Also would try using a bulb blower to blow out the inside of the body in case there's a large bit of dust or something on the sensor. Barring these issues it sounds like you may have gotten a bum lens - if you only bought it a few days ago I hope you can return it despite no warranty, otherwise the only other option is paying out of pocket for a repair.

-Joe


RapidPhotoCT.com (external link) | RapidPhotoCT Facebook (external link) | RapidPhotoCT Instagram (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,201 views & 0 likes for this thread
Canon 70-200 f/2.8 unusual problem
FORUMS Canon Cameras, Lenses & Accessories Canon EF and EF-S Lenses 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is megahtz
905 guests, 408 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.