Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
Thread started 09 Aug 2017 (Wednesday) 12:25
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Old POTN uploaded image tags (attachment.php) conversion...

 
TeamSpeed
01010100 01010011
Avatar
33,583 posts
Gallery: 81 photos
Best ofs: 2
Likes: 3771
Joined May 2002
Location: Northern Indiana
     
Aug 09, 2017 12:25 |  #1

I most likely did a no-no in the old POTN forum, but in this post, I was posting IMG tags around the POTN uploaded images. Now these obviously don't work in AMASS, but is there a way I can fix this post to display the files?

https://photography-on-the.net …showthread.php?​p=11147831


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
Nogo
I could have been worse....
6,874 posts
Gallery: 15 photos
Likes: 470
Joined Dec 2013
Location: All Along the Natchez Trace (Clinton, MS)
Post edited over 1 year ago by Nogo.
     
Aug 09, 2017 12:40 |  #2

IMG tags work the same now as they did in the old forum. The reason they did not work is because the URL you placed tags around were not image URL's that work with the tags.

The tags work with addresses ending in .jpg .png. .gif. There may be others but those are the common ones.


Philip
Does the TF actually know about the soda cans and PVC pipe from 30 years ago?

  
  LOG IN TO REPLY
TeamSpeed
THREAD ­ STARTER
01010100 01010011
Avatar
33,583 posts
Gallery: 81 photos
Best ofs: 2
Likes: 3771
Joined May 2002
Location: Northern Indiana
Post edited over 1 year ago by TeamSpeed. (2 edits in all)
     
Aug 09, 2017 12:55 |  #3

Those did work in the old forum.... :)

The URLs are now sending back 404s, which I think is the issue. I am sure the suffix at the end doesn't drive the code and web presentation, but rather when the server goes to the URL in the IMG tag, it looks to see if the Content-Type is one of an image file.

Example, the image file that used to be served up by this, no longer exists: https://photography-on-the.net …486906&stc=1&d=​1287791946


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)

  
  LOG IN TO REPLY
Nogo
I could have been worse....
6,874 posts
Gallery: 15 photos
Likes: 470
Joined Dec 2013
Location: All Along the Natchez Trace (Clinton, MS)
     
Aug 09, 2017 13:30 |  #4

Below are the tags and URL's from that post you listed above. These are not addresses that a BBCode IMG Tag would recognize in any BBCode based forum. I replaced the img tag with an URL tag below the code box and the system will not pull them up. That problem is one that you will need to get Pekka to figure out if it can be corrected...

TeamSpeed wrote in post #11147831 (external link)


[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6906&stc=1&d=128779194​6[/IMG]
[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6907&stc=1&d=128779194​6[/IMG]

[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6908&stc=1&d=128779214​1[/IMG]
[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6909&stc=1&d=128779214​1[/IMG]

[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6926&stc=1&d=128779674​8[/IMG]
[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6927&stc=1&d=128779674​8[/IMG]

[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6928&stc=1&d=128779693​9[/IMG]
[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6929&stc=1&d=128779693​9[/IMG]

https://photography-on-the.net …486906&stc=1&d=​1287791946
https://photography-on-the.net …486907&stc=1&d=​1287791946

https://photography-on-the.net …486908&stc=1&d=​1287792141
https://photography-on-the.net …486909&stc=1&d=​1287792141

https://photography-on-the.net …486926&stc=1&d=​1287796748
https://photography-on-the.net …486927&stc=1&d=​1287796748

https://photography-on-the.net …486928&stc=1&d=​1287796939
https://photography-on-the.net …486929&stc=1&d=​1287796939


Philip
Does the TF actually know about the soda cans and PVC pipe from 30 years ago?

  
  LOG IN TO REPLY
Pekka
El General Moderator
Avatar
17,589 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1356
Joined Mar 2001
Location: Hellsinki, Finland
Post edited over 1 year ago by Pekka.
     
Aug 09, 2017 14:11 |  #5

TeamSpeed wrote in post #18423205 (external link)
I most likely did a no-no in the old POTN forum, but in this post, I was posting IMG tags around the POTN uploaded images. Now these obviously don't work in AMASS, but is there a way I can fix this post to display the files?

https://photography-on-the.net …showthread.php?​p=11147831

Not a bug, by design. Php files are not accepted as embedded images. There is no such script as attachment.php here.

To show them:

Copy the attachment id from each url and paste it inside attach tag. So,

[IMG]http://photograph​y-on-the.net/forum/attachme​nt.php?attachmentid=48​6906&stc=1&d=128779194​6[/IMG]

becomes

[ATTACH]486906[/ATTACH]

and displays in post as

thumbnail
Hosted photo: posted by TeamSpeed in
./showthread.php?p=111​47387&i=i107341593
forum: Canon EOS Digital Cameras


You get the big image only in the original post where the attach id was uploaded. If you add the (hosted) photo to your gallery, you can use 'pick from gallery' tag to show it in full size in any post.

I hope this solves your dilemma.

The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
CyberDyneSystems
Admin (type T-2000)
Avatar
48,473 posts
Gallery: 84 photos
Likes: 4559
Joined Apr 2003
Location: Rhode Island USA
     
Aug 09, 2017 14:15 |  #6

Cool, I had forgotten this all together. :)


GEAR LIST
CDS' HOT LINKS
Jake Hegnauer Photography (external link)

  
  LOG IN TO REPLY
Nogo
I could have been worse....
6,874 posts
Gallery: 15 photos
Likes: 470
Joined Dec 2013
Location: All Along the Natchez Trace (Clinton, MS)
     
Aug 09, 2017 15:27 |  #7

Good to know. Problem is it is likely I will forget how to do it by the time I may need to do this myself. :-D


Philip
Does the TF actually know about the soda cans and PVC pipe from 30 years ago?

  
  LOG IN TO REPLY
Pekka
El General Moderator
Avatar
17,589 posts
Gallery: 35 photos
Best ofs: 7
Likes: 1356
Joined Mar 2001
Location: Hellsinki, Finland
Post edited over 1 year ago by Pekka.
     
Aug 09, 2017 16:02 |  #8

Nogo wrote in post #18423383 (external link)
Good to know. Problem is it is likely I will forget how to do it by the time I may need to do this myself. :-D

I could have the conversion done automatically, but then again there will be moments like "where the h*** did those thumbs appear??", also there are so many possibilities to still get a broken tag, and those old urls are not so common that I want to put my time into that right now. I'll update the title of this thread so that it is more possible to find here later.


The Forum Boss, El General Moderator
AMASS 2.1 Changelog (installed here now)

  
  LOG IN TO REPLY
TeamSpeed
THREAD ­ STARTER
01010100 01010011
Avatar
33,583 posts
Gallery: 81 photos
Best ofs: 2
Likes: 3771
Joined May 2002
Location: Northern Indiana
     
Aug 09, 2017 16:16 |  #9

Cool, got it. As I find my old reviews and get into them, I will redo the tags. thanks!


Past Equipment | My Personal Gallery (external link) My Business Gallery (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,117 views & 3 likes for this thread
Old POTN uploaded image tags (attachment.php) conversion...
FORUMS Community Talk, Chatter & Official Stuff AMASS Forum Software Talk 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is stp0830
754 guests, 282 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.