Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Photo Sharing & Visual Enjoyment Weddings & Other Family Events 
Thread started 19 Sep 2017 (Tuesday) 14:51
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

I've been volunteered to shoot wedding

 
Chet
my rates fluctuate
Avatar
42,726 posts
Gallery: 125 photos
Likes: 1692
Joined Sep 2007
Post edited 8 months ago by Chet. (2 edits in all)
     
Sep 26, 2017 10:34 |  #61

jimmy_beaner wrote in post #18460759 (external link)
Thank you for your reply and I'm glad the pictures are acceptable for a "free" service. I have 580EXII already with three sets of fully charged batteries and I have 3 Canon batteries for the 6D (technically for the 7D as well, but I only use it gripped so I can only use 2 at a time). That should provide me enough juice for the day.


I had to shoot for a fire house yesterday. I only brought my 1dmkiii with me, and at the last minute thought to bring my bag of flashes and stands. Turns out when I got the the station for a 7pm shoot it was getting pretty dark so I set up 3 flashes with my Radio popper triggers. As the fire and rescue crew were still showing up I could work on setup. Thing is, I couldn't for the life of me get my flashes to trigger from the camera. I swapped batteries, flipped the dip switches on the receivers and transmitter, now in the dark, couldn't get the things to fire. They got a call in so 2 trucks (part of the picture) and crew left. I figured this gave me some time, but to no avail. Luckily 10 minutes later they radioed in and they told me we would have to reschedule. I recommended we start earlier so that we have some light to work with and went home. Seems my hot shoe switch was dirty or gunged up, so after a bit of frustration and cleaning it seems to trigger 85% of the time. Also one of the triggers went out. Disappointed that Canon no longer services this body as I use off camera flash often for shoots.

Moral of the story, have backups for everything (I have 5 Canon flashes). I should had brought my other body, but the 1d never lets me down ... Until yesterday. It's rescheduled for next Monday at 6.


Curator of the Bob's Pickle Emporium experience. -As always, One location to serve you better!
~Feel good today and donate to this great forum~ LINK
My Gear List

  
  LOG IN TO REPLY
-Duck-
my head is usually in the way
Avatar
1,496 posts
Gallery: 8 photos
Best ofs: 1
Likes: 427
Joined Apr 2016
Location: Shelton, CT USA
     
Sep 26, 2017 12:42 |  #62

Chet wrote in post #18460774 (external link)
[...] Thing is, I couldn't for the life of me get my flashes to trigger from the camera. I swapped batteries, flipped the dip switches on the receivers and transmitter, now in the dark, couldn't get the things to fire. [...]

Been there, done that. I'm pretty sure most photographers have face a similar situation at one point or another. I set up a Yongnuo in a softbox with PW's. I couldn't get the flash to fire. I tried everything; cleaning contacts, putting fresh batteries in, etc... There too I ended up rescheduling. Come to find out, the flash was set to a slave mode that disregarded the radio trigger. Who knew that was a thing?


"If you didn't learn something new today, you wasted a day."
Unitas Photography (external link)Blog (external link)Facebook (external link)Flickr (external link)

  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

4,186 views & 43 likes for this thread
I've been volunteered to shoot wedding
FORUMS Photo Sharing & Visual Enjoyment Weddings & Other Family Events 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is brotherbear86
814 guests, 276 members online
Simultaneous users record so far is 6430, that happened on Dec 03, 2017

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.