Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS General Gear Talk Flash and Studio Lighting 
Thread started 30 Apr 2019 (Tuesday) 06:33
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

Canon speedlite 600 ex rt wont fire

 
Thumbsup
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
Apr 30, 2019 06:33 |  #1

Does anyone know why my Canon 600 will turn on but won't fire by either pushing the test button or mounted on the camera?
Thank you




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)
John ­ from ­ PA
Cream of the Crop
9,261 posts
Likes: 833
Joined May 2003
Location: Southeast Pennsylvania
Post edited 5 months ago by John from PA.
     
Apr 30, 2019 08:04 |  #2

Similar problems have been reported with this unit.

Some fixes that have worked supposedly is to remove the batteries, turn the power switch ON, install the batteries (switch is still ON), then close the battery door. Make sure the batteries are fully charged or fresh if non-rechargeable.

The other thing to try would be a full factory reset which I believe is in the manual somewhere around page 38




  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
Apr 30, 2019 08:52 as a reply to  @ John from PA's post |  #3

Thank you for the reply I had my hopes up but tried both of those suggestions and still wont fire I guess I will have to send it in to Canon I know any repair by them is so expensive but I guess its better than buying a new one. Thanks again!




  
  LOG IN TO REPLY
OceanRipple*
Senior Member
841 posts
Likes: 173
Joined Dec 2014
     
Apr 30, 2019 11:34 as a reply to  @ Thumbsup's post |  #4

Hi, May not work, but standard reset sequence is:

1. Turn the flash off.
2. Remove batteries (or just open the battery door)
3. Turn the flash on.
4. Hit the test button.
5. Turn flash off
6. Put batteries back etcetc

i.e. you missed 'Hit the test button/lamp' while the batteries are out with the On switch to On.




  
  LOG IN TO REPLY
John ­ from ­ PA
Cream of the Crop
9,261 posts
Likes: 833
Joined May 2003
Location: Southeast Pennsylvania
     
Apr 30, 2019 14:07 |  #5

There are some people mentioning success with a reset at https://community.usa.​canon.com …-problem/td-p/9779/page/2 (external link). With the procedure mentioned, using button 2 and 3, one guy mentions it worked but he had to do it several times, so keep at it and hopefully you will be met with success.




  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
Apr 30, 2019 15:27 as a reply to  @ John from PA's post |  #6

Thanks I will try some more!




  
  LOG IN TO REPLY
Grand_gator
Member
Avatar
221 posts
Joined Mar 2011
Location: North Central Fl.
     
May 01, 2019 23:55 |  #7

I have the same problem, but still it won’t fire. How much is a lamp replacement by canon on this flash (no cps)? Anthony has it done recently?


5Diii / 70-200 L IS II / 100-400 L IS II / 24-105 L IS / 100mm 2.8 L Macro IS / Σ 35mm 1.4 Art / Σ 85mm 1.4 Art / EF-S 10-22mm / EF-S 17-55mm IS / EF 70-300mm IS / 50mm 1.8 II / 600 EX RT + 430 EX II

  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
May 03, 2019 10:53 as a reply to  @ Grand_gator's post |  #8

Without cps around 160 to 200 dollars! ouch!




  
  LOG IN TO REPLY
N2bnfunn
Senior Member
Avatar
713 posts
Gallery: 7 photos
Likes: 62
Joined Dec 2010
     
May 03, 2019 11:48 |  #9

Ok I have 3 600 ex's question are you using rechargeable batteries ?
Have you try using a Q-tip and some alcohol cleaning the battery contacts?
Now this would be your last result: take the positive part of the battery and put in on negative, and the negative on the positive
and turn the power on for 2 or seconds and flip the batteries back to normal sometimes the reverse polarity can get a unit that is
not powering up to work.


Good Luck

Let me know.


Canon EOS R EF 70-200 L 2.8 L 24-70 2.8L II Canon Pixma PRO-1 3 Canon 600EX-RT Speedlites

  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
May 03, 2019 12:55 as a reply to  @ N2bnfunn's post |  #10

Thank you for the suggestions!




  
  LOG IN TO REPLY
N2bnfunn
Senior Member
Avatar
713 posts
Gallery: 7 photos
Likes: 62
Joined Dec 2010
     
May 05, 2019 21:55 |  #11

Hello so give us an update?


Canon EOS R EF 70-200 L 2.8 L 24-70 2.8L II Canon Pixma PRO-1 3 Canon 600EX-RT Speedlites

  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
May 06, 2019 13:35 as a reply to  @ N2bnfunn's post |  #12

I joined Canon Cps and I am going to send in for repair.




  
  LOG IN TO REPLY
Grand_gator
Member
Avatar
221 posts
Joined Mar 2011
Location: North Central Fl.
     
May 06, 2019 23:19 as a reply to  @ Thumbsup's post |  #13

Please, let me know how that goes. I might have to do the same


5Diii / 70-200 L IS II / 100-400 L IS II / 24-105 L IS / 100mm 2.8 L Macro IS / Σ 35mm 1.4 Art / Σ 85mm 1.4 Art / EF-S 10-22mm / EF-S 17-55mm IS / EF 70-300mm IS / 50mm 1.8 II / 600 EX RT + 430 EX II

  
  LOG IN TO REPLY
Thumbsup
THREAD ­ STARTER
Senior Member
Avatar
677 posts
Gallery: 2 photos
Likes: 7
Joined Oct 2008
Location: New Hampshire
     
May 07, 2019 05:19 as a reply to  @ Grand_gator's post |  #14

I will let you know the cost estimate I am waiting for my cps kit to arrive so I can ship it to them.




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

762 views & 5 likes for this thread
Canon speedlite 600 ex rt wont fire
FORUMS General Gear Talk Flash and Studio Lighting 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is wooricoin
821 guests, 218 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.