Approve the Cookies
This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and our Privacy Policy.
OK
Index  •   • New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Guest
New posts  •   • RTAT  •   • 'Best of'  •   • Gallery  •   • Gear  •   • Reviews
Register to forums    Log in

 
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
Thread started 04 Oct 2004 (Monday) 09:42
Search threadPrev/next
sponsored links
(this ad will go away when you log in as a registered member)

10D Power Issues

 
hbuhrmann
Hatchling
2 posts
Joined Oct 2004
     
Oct 04, 2004 09:42 |  #1

I hope somebody else has come across this problem, and I hope there is an easy fix, as it is rather difficult to get authorised Canon service and repairs in Central London - shame on them :evil:

My 10D is about 15 months old, and I experience an intermittent problem on power up, or when changing between picture taking and review mode - the camera will power up with "EOS" appearing in the LCD, and then immediately power down completely, at other times it carries on repeating powering up and then powering down immediately.

Tried new batteries, the AC power supply, battery grip, all the same. Hope somebody can help, I can't live without my camera for 4 weeks




  
  LOG IN TO REPLY
Olegis
Goldmember
Avatar
2,073 posts
Likes: 2
Joined Apr 2004
Location: Israel
     
Oct 04, 2004 10:28 |  #2

I would check the contacts inside the battery department for any traces of dirt / rust, and try to clean them with some alcohol.


Best wishes,
Oleg.

www.Olegis.com (external link)
My equipment list
'I take orders from no one except the photographers' – Harry S Truman

  
  LOG IN TO REPLY
hbuhrmann
THREAD ­ STARTER
Hatchling
2 posts
Joined Oct 2004
     
Oct 04, 2004 14:42 |  #3

Thanks

Thanks Oleg, I'll give it a try and hope it works

Hannes




  
  LOG IN TO REPLY
ingouk
Member
54 posts
Joined Jul 2004
     
Oct 04, 2004 14:44 |  #4

if you still got problem, you can try fixation near vauxhall station. they do canon and nikon repairs. www.fixationuk.com (external link)




  
  LOG IN TO REPLY
sponsored links
(this ad will go away when you log in as a registered member)

1,613 views & 0 likes for this thread
10D Power Issues
FORUMS Canon Cameras, Lenses & Accessories Canon EOS Digital Cameras 
AAA
x 1600
y 1600

Jump to forum...   •  Rules   •  Index   •  New posts   •  RTAT   •  'Best of'   •  Gallery   •  Gear   •  Reviews   •  Member list   •  Polls   •  Image rules   •  Search   •  Password reset

Not a member yet?
Register to forums
Registered members may log in to forums and access all the features: full search, image upload, follow forums, own gear list and ratings, likes, more forums, private messaging, thread follow, notifications, own gallery, all settings, view hosted photos, own reviews, see more and do more... and all is free. Don't be a stranger - register now and start posting!


COOKIES DISCLAIMER: This website uses cookies to improve your user experience. By using this site, you agree to our use of cookies and to our privacy policy.
Privacy policy and cookie usage info.


POWERED BY AMASS forum software 2.1forum software
version 2.1 /
code and design
by Pekka Saarinen ©
for photography-on-the.net

Latest registered member is tnt2112
1093 guests, 332 members online
Simultaneous users record so far is 15144, that happened on Nov 22, 2018

Photography-on-the.net Digital Photography Forums is the website for photographers and all who love great photos, camera and post processing techniques, gear talk, discussion and sharing. Professionals, hobbyists, newbies and those who don't even own a camera -- all are welcome regardless of skill, favourite brand, gear, gender or age. Registering and usage is free.